Autor Tópico: Partições Sumiram  (Lida 526 vezes)

Offline ubunteiro2

  • Usuário Ubuntu
  • *
  • Mensagens: 5
  • Não diga "sou um inútil" nem no momento que morrer
    • Ver perfil
Partições Sumiram
« Online: 14 de Março de 2017, 01:21 »
Bom dia pessoal.
Sempre usei Ubuntu 32bits, mas anteontem eu instalei uma partição Lubuntu 64 bits pois tinha uma partição vazia e precisava aos poucos migrar para 64 bit (por isso não instalei no Virtual Box).
antes da instalação:
- partição ubuntu32 de 560 Gb
- partição swap/estendida de 5 Gb
- partição vazia de 130 Gb

Então escolhi a opção "instalar ao lado do Ubuntu" e foi intalado com sucesso. reiniciando e usando o Lubuntu não aconteceu nada, mas ao iniciar o Ubuntu começou a aparecer uma mensagem no meio do boot, algo como "não foi localizada a partição <número do UUID> no disco <nome do disco>", mas inicializava com sucesso.

Ontem quando loguei no Ubuntu, nada de errado. Mas depois de travar totalmente (isso é raríssimo), eu reiniciei e começaram os problemas:
- Ao voltar notei no monitor do sistema que a memória swap não estava disponível. Dei um "swapon" e depois um "fdisk -l"no console e a surpresa:
ao invés de uma partição swap tinha outra do menor que ela chamada "Solaris/mac".

Reiniciei novamente e não aparecia o grub, mas um aviso da ASUS para apertar em "del" e entrar no setup. Quando saía do setup não acontecia mais nada. Resetando novamente coloquei o live cd do Lubuntu64, escolhi "iniciar pelo disco", depois "corrigir erros" e não deu certo. Então escolhi " testar memória" e o teste passou e finalmente entrei no Lubunto sem instalar.

No nautilus ele não reconhecia as outras partições. então iniciei o gpart e estava assim:
- /dev/sr0p1  unknown  4kib
-unallocated unallocated 646,48 MiB
-/dev/sr0p2   unknown  2,22 MiB
-unallocated unallocated 41,30 MiB
(notem que a soma deles não dá nem 1 Giga)

E na linha de comando aparecia:
"Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0 has been opened read-only."

E ao rodar o comendo "sudo fdisk -l" no console  isso foi impresso:

Disk /dev/loop0: 615,1 MiB, 644939776 bytes, 1259648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk /dev/zram0: 491,6 MiB, 515436544 bytes, 125839 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk /dev/zram1: 491,6 MiB, 515436544 bytes, 125839 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
lubuntu@lubuntu:~$ sudo fdisk -lu

Disk /dev/loop0: 615,1 MiB, 644939776 bytes, 1259648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk /dev/zram0: 491,6 MiB, 515436544 bytes, 125839 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk /dev/zram1: 491,6 MiB, 515436544 bytes, 125839 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

e depois do comando "sudo parted -l" no console:

Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Model: TSSTcorp CDDVDW SH-S223C (scsi)                                   
Disk /dev/sr0: 724MB
Sector size (logical/physical): 2048B/2048B
Partition Table: mac
Disk Flags:

Number  Start  End    Size    File system  Name   Flags
 1      2048B  6143B  4096B                Apple
 2      678MB  680MB  2327kB               EFI


Model: Unknown (unknown)
Disk /dev/zram0: 515MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

Number  Start  End    Size   File system     Flags
 1      0,00B  515MB  515MB  linux-swap(v1)


Model: Unknown (unknown)
Disk /dev/zram1: 515MB
Sector size (logical/physical): 4096B/4096B
Partition Table: loop
Disk Flags:

Number  Start  End    Size   File system     Flags
 1      0,00B  515MB  515MB  linux-swap(v1)



Por favor pessoal, preciso da ajuda de vcs.
« Última modificação: 27 de Março de 2017, 09:55 por ubunteiro2 »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.406
    • Ver perfil
Re:Partições Sumiram
« Resposta #1 Online: 14 de Março de 2017, 03:10 »
Aparentemente o disco rígido simplesmente não está aparecendo, não há indicação da existência de um hd nesse computador.

Talvez algo que tenha sido alterado no setup da máquina não está permitindo a identificação do hd ou então ele morreu mesmo, o que precisa ser avaliado por outros métodos (hdparm etc).

De toda forma a primeira e mais urgente providência até que se tenha um diagnóstico melhor é **não tente gravar absolutamente nada no disco**.
Não tente nenhum procedimento que possa alterar o estado atual das coisas sob pena de perda irrecuperável dos seus arquivos pessoais, se é que os tinha nesse sistema.

Repetindo: **não grave absolutamente nada no disco**

O inimigo mortal da recuperação de arquivos é sobrescrever arquivos.

Essa hora da matina não dá para prosseguir no assunto, amanhã alguém continua a ajuda (ou eu próprio se conseguir estar aqui) no sentido de um diagnóstico.

« Última modificação: 14 de Março de 2017, 03:12 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline ubunteiro2

  • Usuário Ubuntu
  • *
  • Mensagens: 5
  • Não diga "sou um inútil" nem no momento que morrer
    • Ver perfil
Re:Partições Sumiram
« Resposta #2 Online: 14 de Março de 2017, 10:27 »
Pessoal, O boot estava demorando muito e quando consegui carregar o live (depois de muitos erros e "time-outs" e desabilitar o "boot rápido" na bios da Asus) fiz outro live no pendrive. e descobri algumas coisas: quando ele acaba de carregar notei que essa partição que aparece era de um cdrw (isso explica o tamanho e a demora). Devo ter errado ao comprar pq ele não é tão velho assim.
Isso foi até bom, porque sem esse "boot rápido" ele fez os testes completos no boot e fui escrevendo. Exemplo:
 - Antes de entrar na tela de boot acusa esses erros:
ACPI PCC PROBE FAILED
SRST FAILED
e durante o boot apertei ESC e vi esses outros erros:
/dev/sda(sdb, etc): no medium found
worker[127]/devices/PC<ZEROS>/<ZEROS> IF.2/ata3/host2/target<não lembro>/block/<sda>ao<sr0> is taking a long temp
worker[134]
etc.

Outra bomba: ESTOU SEM BATERIA! Tenho que setar data e hora quando desligo pelo estabilizador.

druidaobelix, obrigado por responder.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.406
    • Ver perfil
Re:Partições Sumiram
« Resposta #3 Online: 14 de Março de 2017, 13:08 »
Não há hd no sistema, todo o resto é irrelevante.

O setup não depende de sistema operacional x ou y, ele existe por si só e precede qualquer sistema operacional.

1) A providência é ir ver no setup da máquina (=BIOS) se o disco aparece lá.
Todo setup possui uma seção de identificação de disco rígido, o disco tem que estar aparecendo lá.
Não apenas aparecendo como mostrando as características de identificação.

Se aparecer, se possível traga ao tópico uma imagem (=foto, celular) do que está vendo.

2) Ainda no setup da máquina verifique se por engano não está acionado como enabled RAID, se tiver, desligue.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.406
    • Ver perfil
Re:Partições Sumiram
« Resposta #4 Online: 14 de Março de 2017, 13:12 »
Quando for necessário postar a saída de um comando, dê preferência a marcar e copiar com o botão direito do mouse e então colar aqui no seu tópico o texto referente ao resultado, é muito mais prático e funcional do que usar imagens para essa simples finalidade, como já vem fazendo.

Entretanto, naqueles casos em que for imprescindível, necessário mesmo disponibilizar uma imagem da tela, use um servidor externo de imagens, postando no tópico um link da miniatura da imagem, pois há uma regra de limitação de tamanho de imagens que se pode postar no Fórum, que é de 40Kb.

Confira aqui (item 8 -X):

http://ubuntuforum-br.org/index.php/topic,43147.0.h

Para aprender como anexar uma imagem em miniatura ao tópico (porque há limite nas regras do Fórum) através de um servidor de imagens externo, veja esse tópico e nele especialmente o post #2 do colega /Creto/:

Anexar uma imagem ao tópico

http://ubuntuforum-br.org/index.php/topic,117916.msg649065.html#msg649065

http://imgur.com
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline ubunteiro2

  • Usuário Ubuntu
  • *
  • Mensagens: 5
  • Não diga "sou um inútil" nem no momento que morrer
    • Ver perfil
Re:Partições Sumiram
« Resposta #5 Online: 14 de Março de 2017, 22:36 »
Druidaobelix, abri o computador e apertei os fios de dados e energia do hd. Agora aparece o grub e entrei no Ubuntu 32bits. Estou fazendo backup pelo menos dos arquivos que eu nunca poderia perder.
fiz um fdisk -l, saída:

Disco /dev/sda: 500.1 GB, 500107862016 bytes
Dispositivo Boot      Início             Fim                  Blocos             Id  Sistema
/dev/sda1   *                        2048   706708734   353353343+  83  Linux
/dev/sda2                 706709502   976773119   135031809       5  Estendida
/dev/sda5                 964880384   976773119        5946368     82  Linux swap / Solaris
/dev/sda6                 706709504   964880383   129085440     83  Linux
Partições lógicas fora da ordem do disco

e ao lançar o comando "free", swap desativada ainda (e a mémoria usada não é o valor abaixo, é 800000 segundo o monitor de systemas):

                   total           usado          livre           compart.  buffers     em cache
Mem:       2029048    1605880     423168     160092     153252     796492
-/+ buffers/cache:     656136    1372912
Swap:            0          0          0



Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.406
    • Ver perfil
Re:Partições Sumiram
« Resposta #6 Online: 14 de Março de 2017, 22:57 »
[...] abri o computador e apertei os fios de dados e energia do hd. Agora aparece o grub e entrei no Ubuntu 32bits. Estou fazendo backup pelo menos dos arquivos que eu nunca poderia perder.

Então já melhorou muito, o disco rígido reapareceu e era mau contato, parece que não perdeu nada e ainda está fazendo backup, ótimo, ótimo.  :D
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.406
    • Ver perfil
Re:Partições Sumiram
« Resposta #7 Online: 15 de Março de 2017, 00:44 »
[...] e ao lançar o comando "free", swap desativada ainda [...]

Terminou o backup? Suponho que tenha feito um backup externo, isto é, para algum lugar que não o próprio computador, não é mesmo?
Um backup externo seguro e confiável dos arquivos pessoais é sempre imprescindível.
Arquivos pessoais são aqueles que não existem em outras fontes, que não se pode recuperar de outras formas, tais como aquela foto única, aquele documento autoral e por aí vai. Todo o resto se reinstala, poder dar algum trabalho, mas se reinstala, jamais será perda definitiva.

Isso posto, podemos ver a questão da swap.

É preciso que ela esteja definida no arquivo fstab para que seja montada quando do boot do sistema.

Traga ao tópico o resultado desses dois comandos para avaliarmos a situação:

Código: [Selecionar]
cat /etc/fstab
Código: [Selecionar]
sudo blkid
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline ubunteiro2

  • Usuário Ubuntu
  • *
  • Mensagens: 5
  • Não diga "sou um inútil" nem no momento que morrer
    • Ver perfil
Re:Partições Sumiram
« Resposta #8 Online: 27 de Março de 2017, 09:52 »
druida, desculpe retornar tão tarde. Fiz o que vc falou e o arquivo fsab estava uma bagunça! (inclusive o número da partição swap errado). Acho que a causa são as várias máquinas virtuais que tenho aqui e mexi manualmente nas propriedades de uma. Por intuição coloquei o número certo e voltou a reconhecer a swap.
Só que tem algumas coisas estranhas, exemplo: partição estendida está muito grande e incluindo a recente instalação do ubuntu 64 bits

<sudo blkid>
/dev/sda1: UUID="631aed60-178c-496e-99f3-d3026c434272" TYPE="ext4"
/dev/sda5: UUID="61161c21-101d-4544-9ae9-4c8197a06b4e" TYPE="swap"
/dev/sda6: UUID="35bbea73-7ca6-40e9-982e-84bde4063180" TYPE="ext4"

<fstab>
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=631aed60-178c-496e-99f3-d3026c434272 /               ext4    errors=remount-ro 0       1
UUID=61161c21-101d-4544-9ae9-4c8197a06b4e none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

O fdisk -l ainda dispara esta mensagem:
"Partições lógicas fora da ordem do disco"

Dispositivo
/dev/sda1    Linux (ubuntu 32bits )
/dev/sda2    Estendida (ubuntu 64 instalado recentemente e a estendida ). Antiga sda3
/dev/sda5    Linux swap / Solaris (antiga sda4)
/dev/sda6    Linux (ubuntu 64 )



« Última modificação: 27 de Março de 2017, 10:38 por ubunteiro2 »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.406
    • Ver perfil
Re:Partições Sumiram
« Resposta #9 Online: 27 de Março de 2017, 16:59 »
[...] Por intuição coloquei o número certo e voltou a reconhecer a swap.

Se voltou a reconhecer a swap então o problema está resolvido, melhor assim.   :)

De fato está correto no fstab quando cotejado à informação do blkid, senão vejamos:

Citar
blkid:
/dev/sda5: UUID="61161c21-101d-4544-9ae9-4c8197a06b4e" TYPE="swap"
fstab:
UUID=61161c21-101d-4544-9ae9-4c8197a06b4e none            swap    sw              0       0

Como se vê, são coincidentes, portanto, está correto.


o arquivo fsab estava uma bagunça! (inclusive o número da partição swap errado). Acho que a causa são as várias máquinas virtuais que tenho aqui e mexi manualmente nas propriedades de uma

Alterar propriedades de máquina virtual (VM) não altera o fstab da máquina hospedeira, a host da VM, a causa deve ser sucessivas instalações e reinstalações do sistema real propriamente dito, mas o importante é que no momento nesse ascpecto tudo parece estar correto.

O fdisk -l ainda dispara esta mensagem:
"Partições lógicas fora da ordem do disco"

Essa mensagem não tem importância maior, é resultado de criar, apagar e reaproveitar espaço em disco.
Se for olhar os marcadores de início e fim dos blocos verá que eles não estarão em ordem númerica sequencial direta.

Note na imagem do GParted postada que a partição sda6 está antes da sda5, portanto, está fora da ordem do disco.

E no que isso concretamente prejudica o sistema?
Em nada, então deixe assim mesmo, não procure confusão, a menos que a confusão seja parte do aprendizado, aí então vale a pena procurar confusão e se divertir com ela.

Querer intensamente que as coisas estejam em ordem numérica sequencial pode ser parte de um TOC, transtorno obsessivo compulsivo, atrelado a uma visão especial de organização estática, porém parece que o universo é realmente quântico e não newtoniano-cartesiano, mas como já se disse, as duas teorias concorrentes são na verdade complementares. {claro, só uma brincadeira  :)  }

Não é realmente necessário que as partições estejam em ordem numérica, pode ser desejável, mas não necessário, ou como dizem os gringos "It is not necessary, it is desirable, everything will work as it is", além do que isso passou a ser mais desimportante ainda quando predominantemente se passou a usar o UUID para as identificações realmente importantes no sistema.

« Última modificação: 27 de Março de 2017, 17:00 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.