Autor Tópico: Não consigo acessar o Banco do Brasil  (Lida 7543 vezes)

Offline Miguel-1501

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #15 Online: 13 de Março de 2017, 09:15 »
Eu cheguei a instalar o programa em Linux Mint 18.1, aparecia no gestor de programas, mas não funcionava. Na hora de fazer o diagnóstico, na interface do programa yad, pedia para instalar dependências, mas o processo ficava detido por causa do Telnet:
Código: [Selecionar]
telnet: Unable to connect to remote host: Connection refused
stat: no se puede efectuar `stat' sobre '/usr/local/bin/warsaw/core': No existe el archivo o el directorio
stat: no se puede efectuar `stat' sobre '/etc/xdg/autostart/warsaw.desktop': No existe el archivo o el directorio
stat: no se puede efectuar `stat' sobre '/usr/local/lib/warsaw/ld-linux-x86-64.so.2': No existe el archivo o el directorio
stat: no se puede efectuar `stat' sobre '/usr/local/lib/warsaw/ld-linux.so.2': No existe el archivo o el directorio
stat: no se puede efectuar `stat' sobre '/etc/init.d/warsaw': No existe el archivo o el directorio
stat: no se puede efectuar `stat' sobre '/usr/local/etc/warsaw/local.cfg': No existe el archivo o el directorio
Código: [Selecionar]

Há uma pessoa, no fórum da web Viva o Linux, que conseguiu chegar no final. Ele inclusive mostra a foto do programa com todos os itens em verde, mas não esclarece como é que conseguiu. No seu tutorial ele segue os passos do tutorial do Banco do Brasil e não acrescenta nenhuma informação que possa ajudar a desvendar o mistério.  Ele não voltou ao fórum, assim que não temos como averiguar o quid da questão.

Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 367
  • Cabo Frio - RJ - Brasil
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #16 Online: 13 de Março de 2017, 10:36 »
meu ubuntu é o 16.04 e o icedteaplugin é o 8 e ff  52
continua funcionando
ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  16.10, ssd 120G, hd 500 g

Offline Miguel-1501

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #17 Online: 13 de Março de 2017, 12:58 »
meu ubuntu é o 16.04 e o icedteaplugin é o 8 e ff  52
continua funcionando

Mas, quando você está acessando, aparecem essas janelas de módulo de segurança pedindo permissão?
« Última modificação: 13 de Março de 2017, 13:48 por Miguel-1501 »

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 354
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Re:Não consigo acessar o Banco do Brasil
« Resposta #18 Online: 14 de Março de 2017, 02:33 »
A presença do Java (Icedtea, JRE proprietário da Oracle ou o que for) é completamente irrelevante para o funcionamento do novo módulo de segurança Warsaw.

O Banco do Brasil migrou para o Warsaw justamente porque a versão mais recente do Firefox (a partir da versão 52) não executa o plugin Java (JRE) e o Warsaw não usa Java: o Warsaw não depende do Java, para funcionar.

O Warsaw para Linux basicamente executa o shell do Linux para rodar o openssl, que por sua vez cria e assina certificados SSL digitais que são então injetados pelo Warsaw nos seus navegadores web. Em seguida, o Warsaw usa esses certificados para estabelecer uma conexão websocket (um protocolo de comunicação web que "roda" por cima do protocolo TCP usando SSL) com o servidor websocket do Banco do Brasil.

Enfim: warsaw = linguagem shell script do Linux + SSL + conexão websocket sobre TCP (via Internet, usando certificados digitais SSL autoassinados). Não tem nada de JRE (ambiente de execução Java). Esqueçam Java. :P

O que o usuário pode fazer é usar uma versão anterior do Firefox (versão 51 ou mais antiga), para poder acessar a página do Banco do Brasil usando o (agora antigo) módulo de segurança Java, que por enquanto ainda está presente no website do Banco do Brasil. Mas uma hora o Banco do Brasil vai desativar esse módulo de segurança Java, daí não vai dar mais pra acessar o banco usando navegador antigo com plugin Java, e então passará a ser imprescindível o Warsaw funcionar. Aí é que reside o problema (já que o Warsaw está dando problema). :(
« Última modificação: 14 de Março de 2017, 02:35 por Sampayu »
Yuri Sucupira ("Sampayu")

Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 367
  • Cabo Frio - RJ - Brasil
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #19 Online: 14 de Março de 2017, 07:51 »
estas janelas do modulo de segurança não estão aparecendo mais. aparentemente está acessando via plugin icedtea.
como disse o sampayu, vamos ver até quando vão permitir isto. devem estar a solucionar o warsaw.
ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  16.10, ssd 120G, hd 500 g

Offline Miguel-1501

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #20 Online: 14 de Março de 2017, 10:25 »
Eu já consegui instalar o módulo de segurança. Primeiro instalei o arquivo fornecido pelo banco na sua web. Abri o programa e o diagnóstico mostrava uma advertência relativa às sockets. Então instalei o warsaw_setup.deb disponível na Gas tecnologia. Reiniciei o computador e nesta vez no diagnóstico estava tudo verde. Entrei na web do banco e mostrou que tinha instalado o módulo de segurança. Foi então que tentei acessar, mas fica no "aguarde, iniciando o acesso" e não sai do canto.
Ainda estou com firefox 51. Para a tentativa desativei icedtea. Se o ativo acesso é feito sem problemas.

Offline Miguel-1501

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #21 Online: 15 de Março de 2017, 09:36 »
A solução está em esquecer o tutorial do BB e seguir a dica de Bruno Gonçalves publicada no blog Talesan.org. Segundo ele, o hda_bb é um instalador de um instalador, por tanto não faz sentido. Então, é só instalar o warsaw_setup que fornece a Gas Tecnologia. Fechem o navegador, instalem pelo "centro de software", reiniciem e pronto, nem diagnósticos, nem dependências incompletas. Tudo num clique.

https://talesam.org/2017/03/14/instalando-o-modulo-de-seguranca-banco-brasil-warsaw/

« Última modificação: 15 de Março de 2017, 09:37 por Miguel-1501 »

Offline mpinho

  • Usuário Ubuntu
  • *
  • Mensagens: 10
  • Manoel Pinho
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #22 Online: 15 de Março de 2017, 10:11 »

Offline joan_alvarez

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #23 Online: 17 de Março de 2017, 18:45 »
Fui instalar num outro com Mint e funcionou apenas instalando o warsaw sem usar o hda_bb.

Mas o engraçado é que no Mate não deu certo
Será que é por eu ter instalado antes e haver corrompido alguma dependência, ou por causa do Ubuntu MATE?
Tentei remover todos os resquícios do hda_bb, logo instalei o warsaw_setup64.deb
http://www.dieboldnixdorf.com.br/warsaw
Faço diagnóstico warsaw, mas acusa como "Warsaw não instalado"
Ubuntu MATE 16.04 VAIO VPCEB46FX

Offline gilbertoros

  • Usuário Ubuntu
  • *
  • Mensagens: 69
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #24 Online: 17 de Março de 2017, 21:00 »
Caso a alteração de versão já tenha ocorrido, então remova a versão atual, baixe a anterior e instale novamente.

Remover a instalação atual

Código: [Selecionar]
sudo apt-get remove firefox
Baixar a versão anterior, conforme a arquitetura do sistema.

Para ver a arquitetura:

Código: [Selecionar]
arch
Baixar e instalar:

Código: [Selecionar]
cd ~/Downloads  #entra no diretório Downloads
64-bit

Código: [Selecionar]
wget https://sourceforge.net/projects/ubuntuzilla/files/mozilla/apt/pool/main/f/firefox-mozilla-build/firefox-mozilla-build_51.0.1-0ubuntu1_amd64.deb
Código: [Selecionar]
sudo dpkg -i firefox-mozilla-build_51.0.1-0ubuntu1_amd64.deb
32-bit

Código: [Selecionar]
wget https://sourceforge.net/projects/ubuntuzilla/files/mozilla/apt/pool/main/f/firefox-mozilla-build/firefox-mozilla-build_51.0.1-0ubuntu1_i386.deb
Código: [Selecionar]
sudo dpkg -i firefox-mozilla-build_51.0.1-0ubuntu1_i386.deb

FIZ O PROCEDIMENTO E ATÉ O MOMENTO (17/03/2017) ESTÁ FUNCIONANDO OK ! PELO QUE ENTENDI ESTA VERSÃO 51 NÃO UTILIZA O WARSAW E SIM OJAVA !

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.639
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #25 Online: 17 de Março de 2017, 21:20 »
FIZ O PROCEDIMENTO E ATÉ O MOMENTO (17/03/2017) ESTÁ FUNCIONANDO OK ! PELO QUE ENTENDI ESTA VERSÃO 51 NÃO UTILIZA O WARSAW E SIM OJAVA !

Então, "gilbertoros",

É isso mesmo, porém isso não vai muito longe, daqui a pouco o BB inabilita totalmente o acesso por essa versão mais antiga.

Experimente instalar o bb-warsaw, está permitindo o acesso sem maiores dificuldades, porém precisa ser no Firefox versão 52 (ou Chrome 57 ou Opera 43, todos funcionam)

Se quiser testar, fiz um pequeno script para facilitar a vida, dê uma olhada nesse tópico, o script tá linkado lá e ainda exposto, é só testar:

Solução para acessar o home banking do Banco do Brasil no Ubuntu (com warsaw)

http://ubuntuforum-br.org/index.php?topic=121558.msg667968#msg667968

bb-warsaw-install.sh pode ser baixado nesse link:

https://drive.google.com/file/d/0B4-_QQ0rcvfTLXJUcWR3THVTRE0/view?usp=sharing

Mas também usando o método do instalador próprio do BB, que é o pacote hda-bb_0.1_all.deb está funcionando perfeitamente bem, sem problemas, sendo possível fazer a instalação completa e funcional pela interface gráfica sem nenhuma dificuldade, como está devidamente explicado no tópico mencionado.
« Última modificação: 18 de Março de 2017, 02:10 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline gidalte

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #26 Online: 18 de Março de 2017, 12:55 »
Lendo o drama de alguns aqui com o famigerado warsaw, venho relatar minha luta na instalação em um Majaro, e acredito que funcione para demas distribuições, por que parti do arquivo de configuração que faz todo trabalho pesado "warsaw_64_installer" ou "warsaw_32_installer":

Podem ser baixados aqui: https://www14.bancobrasil.com.br/downloads/ws/warsaw_64_installer.run ou aqui https://www14.bancobrasil.com.br/downloads/ws/warsaw_32_installer.run (as duas aquiteturas 64 e 32).

Como obtive esses links? Ao tentar acessar minha conta no site do Banco, abria uma tela onde apresentava
links para testar se o módulo de segurança estava presente, reconheicia a minnha distribuição como não Unbuntu e derivado e num botão orientava baixar o dito scritpt para outro tipo distribuição (que não usa
pacotes deb).

Estes script tem 22,8 megas, 79742 linhas!, porque ele carrega em seu interior uma parte de pre-instalação e na outra parte a compactação dos binarios, bibliotecas e arquivos de configuração, que o próprio script descompacta na pasta /tmp. Aconselho a quem desejar estudar o script abri-lo com o editor vim, é bem mais rápido para edita-lo e isso no shell. O que está legível vai até a linha 362, o restante como já falei é a compactação dos arquivos necessario para funcionar o core do warsaw.

O que deu certo no meu caso:

1 - Copiei "warsaw_64_installer.run" ou "warsaw_32_installer.run" (vai depender da sua arquitetura 64 ou 32),
      para a pasta /tmp;
2 - Tentei executa-lo como sudo (isso depois de: sudo chmod +x warsaw_64_installer.run) e esbarrava na linha
      22 do script: " cd /tmp/warsaw_x64/ && ./configure && make install" ;
3- Olhando mais atentamente notei que para que essa linha funcionasse era preciso o script ter antes
     descompactado aos binarios, bibliotecas e arquivos de configuração compactados nele (o  script), o que era
     feito na linha 146:  "tail -n +$L $0 | tar -zxvf - -C /"(e isso dentro da pasta /tmp);
4- Depois de uns 3 noites pensado na solução, já que não sou especialista em script shell, reproduzí
     manualmente dentro da pasta /tmp o comando:  "sudo tail -n +363 warsaw_64_installer.run | tar -zxvf- -C/";
     (363 é a linha apartir do qual é feita a leitura para  descompactar, deu umas mesagens  de erro no final,
      mas
     nada que comprometesse(bingo! descompactou numa pasta /tmp/warsaw_x64);
5 - Em seguda rodei novmente o script: "sudo ./warsaw_64_install.run", depois desta operação ele, após   
      alguns minutos carrega  o core com "/etc/init.d/warsaw start"(que será necessário para sempre antes de
      acessar o banco se não quiser deixar na inicializaçao, como eu que não gosto de consumo de recursos se
      não estou usando;

osb: Firefox sem rodar nesse momento, e mesmo que estja ele dá uma menssagen pedido para fechar.

Dai foi só correr para o abraço:




Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.639
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #27 Online: 18 de Março de 2017, 22:43 »
Não há na verdade nenhum problema com o instalador BB (hda-bb_0.1_all.deb) do warsaw, o que existe, parece, é nem sempre uma correta compreensão do processo como um todo e do que deve ser feito na instalação.

O pacote instalador foi feito pensando numa instalação utilizando a interface gráfica, no caso o Ubuntu-Software, e não por outro meio (dpkg) e é exatamente isso que consta nas instruções de instalação lá no site do Banco do Brasil, embora não de forma expressa.

"Dúvidas sobre o módulo de segurança

1. UBUNTU/MINT - Não consigo acessar o Internet Banking no Linux. O que devo fazer?
"

https://seg.bb.com.br/duvidas.html

É apenas seguir exatamente o que está lá e a instalação dará certo, permitindo o acesso do correntista à conta-corrente.

Note constar expressamente daquelas instruções: "dê um duplo clique no arquivo para iniciar a instalação", vale dizer, novamente, é para usar a interface gráfica para instalar, essa é a previsão de quem fez o instalador.

Também não está lá dito expressamente, o que é uma falha, que o warsaw aplica-se ao Firefox a partir da versão 52, portanto, não tente instalar na versão 51 anterior, pois não irá conseguir completar o acesso.

Embora existam outras formas de instalar, o pacote instalador BB hda-bb_0.1_all.deb é uma rotina escrita em bash script, bem elaborada e muito interessante, deve ser preferida.

Acontece que o usuário Linux, na sua imensa maioria, é um utilizador contumaz de linha de comando (eu próprio), não pode ver um pacote .deb que já vai para o dpkg, é hábito puro.

Quando se instala pela interface gráfica (duplo clique), que usa o Ubuntu-Software, este provê as dependências necessárias e a instalação dará certo, o que já não ocorre quando se vai para o dpkg na cmdline e então a instalação irá falhar, a menos que se instale antes as dependências ou após usar o dpkg se faça a correção dessas dependência, apenas isso.

Em resumo:

1) Prefira fazer usando a interface gráfica do Ubuntu-Software (duplo click no pacote .deb);

Entretanto, se for fazer por linha de comando:

2) Instale antes das dependências necessárias:

Código: [Selecionar]
sudo apt install -y yad libnspr4-0d libnss3-tools
depois simplesmente faça:

Código: [Selecionar]
sudo dpkg -i hda-bb_0.1_all.deb
Daí em diante basta ir no Dash e clicar no ícone HDA_BB

Na janela que se abre clicar em Instalar (símbolo +) e seguir as telas gráficas.

Após a instalação, confirme se está tudo correto clicando em Diagnóstico

3) Se esqueceu de instalar antes as dependências, como mencionado acima em 2), então após instalar pelo dpkg corrija isso, também dará certo.

Código: [Selecionar]
sudo dpkg -i hda-bb_0.1_all.deb
Código: [Selecionar]
sudo apt-get -f install
Confirme tudo acessando esse endereço:

Seg.BB - Diagnóstico do Módulo de Segurança

https://seg.bb.com.br/home.html

« Última modificação: 18 de Março de 2017, 22:48 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline gidalte

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re:Não consigo acessar o Banco do Brasil
« Resposta #28 Online: 19 de Março de 2017, 07:00 »
Conssegui instalar no elementaryOS (derivado Ubuntu) que uso com a TV na minha sala, mas não deu certo via pacotes deb. Sobre a questão de sempre preferir interface grafica, é que nos coloca como usários windows, só sabe fazer as coisas se tiver um inteface grafica, no dia que ela quebra você vai e reintala todo sistema desnecessarimante. A curva de aprendizado no linux é praticamente inesgotável. Antes que digam o contrário, uso Ubuntu 16.04 no trabalho e a instalação via hda-bb_0.1_all.deb deu certo de primeira, sobre as instruções do Banco do Brasil, não é só via interface gráfica:


Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 354
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Re:Não consigo acessar o Banco do Brasil
« Resposta #29 Online: 20 de Março de 2017, 04:21 »
Eu também não detectei nenhuma diferença entre os três métodos de instalação.

A propósito, os três métodos de instalação atualmente são estes:

1) Instalar o instalador HDA_BB, que por sua vez instalará o módulo de segurança Warsaw pra você.

2) Instalar o módulo de segurança Warsaw diretamente, usando o pacote DEB (o link ao lado é para a versão de 64 bits).

3) Instalar o módulo de segurança Warsaw diretamente, usando o shell script RUN (o link ao lado é para a versão de 64 bits).

O programa DPKG instala manualmente um pacote DEB, porém não analisa se esse pacote possui dependências, ou seja, não analisa se, para funcionar, esse pacote precisa ser instalado junto com outros pacotes DEB dos quais ele depende. Para instalar qualquer pacote DEB na linha de comandos (terminal do shell do Linux) resolvendo as dependências desse pacote DEB, você precisa usar o programa GDEBI, ao invés de usar o DPKG. Caso não tenha o GDEBI, instale-o com este comando:

Código: [Selecionar]
sudo apt-get install gdebi -y
Após isso, para instalar um pacote DEB no terminal do shell basta executar o comando sudo gdebi /caminho/para/o/pacote.deb, portanto se você salvou um arquivo como p.ex. hda-bb_0.1_all.deb em um local como p.ex. /home/fulano/Downloads/, o comando de instalação desse pacote DEB será:

Código: [Selecionar]
sudo gdebi /home/fulano/Downloads/hda-bb_0.1_all.deb
O mesmo vale para o caso de você decidir instalar manualmente o pacote DEB do módulo de segurança Warsaw. Portanto, se por exemplo você pegar o arquivo warsaw_setup64.deb e salvá-lo em /home/fulano/Downloads/, este será o comando para instalar manualmente esse pacote DEB no terminal do shell do Linux, já resolvendo as dependências do pacote:

Código: [Selecionar]
sudo gdebi /home/fulano/Downloads/warsaw_setup64.deb
Já no caso do arquivo de script RUN, para instalá-lo você precisa primeiro torná-lo executável, o que se consegue executando-se o comando sudo chmod +x /caminho/para/o/arquivo.run, portanto se o arquivo tiver um nome como por exemplo warsaw_64_installer.run e você o salvar em /home/fulano/Downloads/, o comando para torná-lo executável e então instalá-lo será este:

Código: [Selecionar]
sudo chmod +x /home/fulano/Downloads/warsaw_64_installer.run && sudo /home/fulano/Downloads/warsaw_64_installer.run
Durante a instalação do módulo Warsaw por qualquer um desses métodos, é necessário deixar todos os navegadores fechados.

=> Desinstalar o HDA_BB é fácil. Basta executar este comando, no terminal do shell:

Código: [Selecionar]
sudo apt-get purge hda-bb
Desinstalar o Warsaw instalado via pacote DEB também é fácil. Basta executar este comando, no terminal do shell:

Código: [Selecionar]
sudo apt-get purge warsaw
Já para desinstalar o Warsaw instalado via script RUN, é necessário executar o desinstalador dele. O comando é este:

Código: [Selecionar]
sudo /usr/bin/warsaw_uninstall
Após cada instalação ou desinstalação, é recomendável reiniciar o sistema.


O que eu já fiz, até agora...

Eu já instalei o módulo de segurança Warsaw por intermédio de cada um dos três métodos acima citados. Nenhum funcionou para o meu caso: a página https://seg.bb.com.br/home.html continua me informando que não possuo o módulo de segurança Warsaw, ao acessar a página http://www.dieboldnixdorf.com.br/warsaw (da empresa que comprou a GAS Tecnologia, desenvolvedora do Warsaw) e informar que meu banco é o Banco do Brasil, também recebo a informação de que meu sistema não possui o módulo Warsaw. Mas eu sei que o Warsaw está instalado, pois o daemon (o "serviço", o processo residente na memória do sistema) do Warsaw é o arquivo binário executável core, que se encontra em /usr/local/bin/warsaw/ (caminho completo: /usr/local/bin/warsaw/core), e esse daemon está em execução (ou seja: uma cópia do arquivo core encontra-se presente na memória RAM que está sendo usada pelo sistema operacional Linux). Eu inclusive executei o comando abaixo, para interromper o daemon do Warsaw:

Código: [Selecionar]
sudo service warsaw stop
Daí executei este outro comando, para iniciar novamente o daemon / serviço Warsaw:

Código: [Selecionar]
sudo service warsaw start
...e então executei o comando:

Código: [Selecionar]
ps -ef |grep -i warsaw |grep -v grep
...que me mostrou que de fato existe um daemon / serviço warsaw executando o arquivo binário executável core a partir de /usr/local/bin/warsaw (o arquivo binário core está residente na memória do computador), portanto o Warsaw está em execução. Consequentemente, se aqueles dois websites estão informando que o Warsaw não está instalado é porque esses websites não estão conseguindo se comunicar com o daemon que se encontra em execução no meu sistema, e isso sinaliza um problema (ou dificuldade) ou no daemon ou em algum componente do daemon: pode ser uma biblioteca faltando; uma configuração errada dentro desse daemon; alguma biblioteca funcionando diferentemente do que devia e, por isto, impedindo que, por exemplo, uma conexão websocket seja estabelecida entre o daemon e o servidor do banco; daemon sendo bloqueado por outro processo etc.

Quando executo o programa HDA_BB, ele me informa que o módulo está de fato instalado e em execução, porém dá aquele erro de websocket / soquete que tantos outros usuários estão vivenciando (eu, inclusive). Meu sistema é o XUbuntu versão 16.04 de 64 bits e estou usando o kernel estável 4.7.10 (número completo da versão: 4.7.10-040710-generic). Como o daemon do warsaw está em execução mas mesmo assim estou tendo esse problema, pensei na possibilidade de isso estar relacionado a alguma incompatibilidade do kernel (ou do iptables que executa o componente netfilter do kernel) com essa versão do Warsaw, por isto instalei o kernel versão 4.4, que é nativo desse XUbuntu que estou usando. Infelizmente, não fez diferença nenhuma.

Também experimentei instalar versões anteriores (antigas) do Warsaw, mas nenhuma funcionou.  :(

Como mudar de kernel não fez diferença, experimentei mexer no iptables (o firewall interno do Linux): percebi que quando o script /usr/local/bin/HDA_BB/HDA_BB é executado, ele testa a conectividade do websocket executando o comando telnet na porta 30900 do endereço IP 127.0.0.1 (codinome localhost). Então executei este comando, no terminal do shell:

Código: [Selecionar]
telnet 127.0.0.1 30900
...e o resultado foi "connection refused" (conexão recusada). Daí pensei: "Mmmm... É por isso que o programa HDA_BB informa que o websocket não está conectado: é porque a porta 30900 está fechada. Como o módulo Warsaw (o arquivo binário core) tenta usar essa porta 30900, mas não consegue, o HDA_BB informa esse problema".

Como dentro do arquivo /usr/local/bin/HDA_BB/HDA_BB há uma linha com o comando echo open 127.0.0.1 30800, resolvi executar este comando que usa o telnet para testar a conectividade da porta TCP nº 30800 no endereço IP 127.0.0.1:

Código: [Selecionar]
telnet 127.0.0.1 30800
...e, para minha surpresa, o telnet confirmou que a porta 30800 está aberta (antes de você instalar o Warsaw, essa porta fica fechada, mas com a instalação do Warsaw essa porta passa a ficar aberta). Então tive a ideia de usar o iptables para redirecionar para a porta 30800 todos os pedidos que chegarem à porta 30900. Você faz isso executando este comando, no terminal do shell:

Código: [Selecionar]
sudo iptables -t nat -A OUTPUT -p tcp -d 127.0.0.0/8 --dport 30900 -j REDIRECT --to-port 30800
Executei novamente o programa HDA_BB e... tadá! O programa mostrou o "sinal verde" para o item "Socket" (conectividade do websocket "ok"). :D

...mas alegria de pobre dura pouco, rs. ;D Apesar de esse meu artifício ter funcionado para "enganar" o programa HDA_BB, pelo visto a porta 30900 não é a única usada pelo Warsaw para estabelecer uma conexão websocket (o que inclusive reforça ainda mais o meu receio em usar esse módulo, diga-se de passagem... Detesto programas "obscuros", que não tenho como saber como funcionam porque são programas compilados, proprietários, a cujo código-fonte eu não tenho acesso...  ???).

Bom, enfim: dei essa volta toda e, por enquanto, ainda não consegui fazer esse módulo de segurança funcionar:'( Por ora, o que está me salvando é que instalei o VirtualBox para Linux, em seguida criei uma máquina virtual Linux genérica, baixei o ISO do Android 4.4, usei esse ISO para instalar o Android 4.4 na máquina virtual, daí dei boot nesse "Android virtualizado", instalei o aplicativo do BB nesse Android, e-pronto (eu sacaneando a propaganda do Banco do Brasil... :P): estou usando o notebook com XUbuntu Linux para acessar o Banco do Brasil via aplicativo instalado no Android virtualizado. Claro que isso está longe de ser uma solução, mas é um paliativo recomendado a quem por ora está como estou: sem acesso via navegador.

Como por enquanto o módulo de segurança Java do Banco do Brasil continua funcionando (continua ativo no website do Banco do Brasil), usar um navegador que dê suporte ao plugin NPAPI do JRE (popularmente conhecido como "plugin Java") possibilita que, por ora, o usuário possa continuar acessando sua conta corrente via módulo de segurança Java. Como a partir da versão 52 o Firefox deixou de dar suporte a plugins de arquitetura NPAPI, não dá pra usar essa versão do navegador. Porém, pode-se obter o Firefox versão 51, de 64 bits para acessar sua conta corrente via Internet, já que essa foi a última versão do Firefox a dar suporte ao plugin NPAPI do JRE. Após baixar o arquivo comprimido firefox-51.0.tar.bz2, use o terminal do shell para acessar a pasta em que você salvou esse arquivo e então execute este comando de descompactação:

Código: [Selecionar]
sudo tar -xvf firefox-51.0.tar.bz2
Nessa mesma pasta surgirá uma subpasta firefox. Use o terminal mesmo para entrar nela. Porém, antes de executar o Firefox 51 pela primeira vez, execute seu Firefox atual, para poder desativar a atualização automática, daí acesse o endereço about:preferences#advanced, clique na opção Atualizações, marque a caixa Nunca verificar (não recomendado: risco de segurança) e, por fim, feche o Firefox.

Após fazer isso (para evitar que o Firefox versão 51 - que funciona com o plugin NPAPI do JRE - automaticamente se atualize para a versão mais recente - que não suporta plugins NPAPI), retorne ao terminal do shell, que deverá estar conectado à pasta do Firefox 51, e então execute este comando (ele inicializará o Firefox versão 51):

Código: [Selecionar]
./firefox
O uso do ./ é importante para informar que você quer executar especificamente o arquivo binário firefox que se encontra dentro da pasta que você acessou via terminal (a pasta do Firefox 51).

Se você executar o Firefox 51 com a "atualização automática" desabilitada, você conseguirá usar o Firefox 51 para acessar o website do Banco do Brasil, daí o website do banco fornecerá o applet Java para o Firefox 51 e o Firefox 51 conseguirá executar esse applet, já que o Firefox 51 é capaz de executar o plugin Java. Enquanto o applet (módulo de segurança) Java continuar hospedado no website do Banco do Brasil, você continuará podendo usar o Firefox 51 para acessar sua conta pelo método "antigo" / tradicional, ou seja: via Java (sem precisar do Warsaw).

Espero que alguém descubra como resolver esse problema (já que relatei esse problema para o Banco do Brasil, mas o "maravilhoso" suporte técnico está há mais de 1 semana sem se manifestar, tampouco sem resolver o problema). Se eu conseguir resolver isso, publico aqui.
« Última modificação: 24 de Março de 2017, 00:36 por Sampayu »
Yuri Sucupira ("Sampayu")