Autor Tópico: Minitube  (Lida 569 vezes)

Offline Mauricio Lara

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Minitube
« Online: 24 de Fevereiro de 2017, 15:43 »
Boa tarde amigos
Não consigo instalar o Minitube de maneira alguma, sempre aparece uma msg conforme vcs podem ver no link abaixo
Qq coisa que preciso gerar uma chave, mas como sou novato no linux nem imagino como fazer isso
Qualquer ajuda será bem vinda
Obrigado

http://ap.imagensbrasil.org/image/ET9c7K

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.526
    • Ver perfil
Re:Minitube
« Resposta #1 Online: 25 de Fevereiro de 2017, 16:15 »
Não consigo instalar o Minitube de maneira alguma, sempre aparece uma msg conforme vcs podem ver no link abaixo
Qq coisa que preciso gerar uma chave, mas como sou novato no linux nem imagino como fazer isso

Como fez para instalar?

Não seria o caso de fazer exatamente como a mensagem de erro está dizendo para fazer, que é baixar o pacote deb do endereço mencionado?

http://flavio.tordini.org/minitube

Ou, querendo, mais diretamente por linha de comando, no terminal:

Código: [Selecionar]
wget -c http://flavio.tordini.org/files/minitube/minitube.deb
Uma vez baixado o pacote deb, então de dentro do diretório onde baixou:

Código: [Selecionar]
sudo dpkg -i minitube.deb
Fiz aqui experimentalmente numa instalação live-iso do ubuntu-mate e o dpkg instalou porém deixou desconfigurado por problemas de dependências:

Citar
A seleccionar pacote anteriormente não seleccionado minitube.
(Lendo banco de dados ... 205406 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar minitube.deb ...
A descompactar minitube (2.6) ...
dpkg: problemas com dependências impedem a configuração de minitube:
 minitube depende de phonon4qt5; porém:
  Pacote phonon4qt5 não está instalado.
 minitube depende de libphonon4qt5-4; porém:
  Pacote libphonon4qt5-4 não está instalado.
 minitube depende de phonon4qt5-backend-gstreamer; porém:
  Pacote phonon4qt5-backend-gstreamer não está instalado.

dpkg: erro ao processar o pacote minitube (--install):
 problemas de dependência - deixando desconfigurado
A processar 'triggers' para hicolor-icon-theme (0.15-0ubuntu1) ...
A processar 'triggers' para desktop-file-utils (0.22-1ubuntu5) ...
A processar 'triggers' para bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
A processar 'triggers' para mime-support (3.59ubuntu1) ...
Erros foram encontrados durante o processamento de:
 minitube

Então foi necessário corrigir fazendo:

Código: [Selecionar]
sudo apt-get -f install
Na verdade nem sei direito para que serve o Minitube, qual seria realmente a utilidade dele, não tenho instalado e nunca usei.
Em todo caso é o que foi possível apurar, por enquanto.


www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.526
    • Ver perfil
Re:Minitube
« Resposta #2 Online: 25 de Fevereiro de 2017, 20:05 »
Só agora pude testar, igualmente não funcionou fazendo como disse no post #1.  :(

Vamos tentar um outro caminho,

https://github.com/flaviotordini/minitube/blob/master/README.md#google-api-key

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.526
    • Ver perfil
Re:Minitube
« Resposta #3 Online: 25 de Fevereiro de 2017, 20:39 »
Melhor esperar um pouco para estudar mais em detalhes isso aí.

Se bem entendi, nessa forma o aplicativo pede o consentimento do usuário e este ao fornecer está autorizando o acesso aos dados do usuário no Google.

https://console.developers.google.com/apis/api/youtube/overview

Não gostei disso, melhor alguma cautela nisso e estudar melhor a questão.

Não vejo porque para simplesmente executar uma merreca de software deva fornecer autorização para acesso aos meus dados no Google.

Se for isso mesmo, apenas não quero executar esse software no meu sistema.
« Última modificação: 25 de Fevereiro de 2017, 20:41 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.526
    • Ver perfil
Re:Minitube
« Resposta #4 Online: 25 de Fevereiro de 2017, 22:13 »
Compilei o minitube a partir do github numa instalação blindada por questões de segurança, completou a compilação, e instalei usando o checkinstall para poder remover mais facilmente.

Há realmente algo estranho nisso, pois para compilar diz lá que precisa definir:

qmake "DEFINES += APP_GOOGLE_API_KEY=YourAPIKeyHere"

Em outras palavras, o usuário do software obtém uma API key no Google, que é dele e não do software que irá usar, e vai usar essa API key no software do outro.

Esquisito isso, muito esquisito, além do que contrário às boas práticas de segurança no uso de API keys.

Best practices for securely using API keys

https://support.google.com/cloud/answer/6310037

Do not embed API keys directly in code: API keys that are embedded in code can be accidentally exposed to the public—for example, if you forget to remove the keys from code that you share. Instead of embedding your API keys in your applications, store them in environment variables or in files outside of your application's source tree.

Tome cuidado, pois isso pode estar abrindo as portas para o roubo de quotas no Goolgle, dentre outros estragos possíveis.

Quem quiser correr o risco:

How do I generate a Google API Key

https://mapifypro.zendesk.com/hc/en-us/articles/225022048-How-do-I-generate-a-Google-API-Key-

How to generate and set a Google Maps Javascript API (browser) key

https://kb.yoast.com/kb/generate-set-google-maps-browser-key/#generate

Não tenho tempo e muito menos disposição para analisar o código fonte para ver mais em detalhes o que há lá.

Não recomendo fortemente usar esse tal minitube até o cabal esclarecimento desse aspecto de segurança.
É melhor nem mesmo instalar o pacote deb no sistema.

« Última modificação: 25 de Fevereiro de 2017, 22:20 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Mauricio Lara

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Minitube
« Resposta #5 Online: 26 de Fevereiro de 2017, 21:33 »
Obrigado, compreendi o q vc disse, tbm não vejo necessidade desse tipo de chave pra instalar um programa pra ver videos do youtube.
Vou continuar pelo navegador mesmo.
Abraços