Autor Tópico: Teclado não funciona ao iniciar o sistema  (Lida 600 vezes)

Offline Brisighelli

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Teclado não funciona ao iniciar o sistema
« Online: 05 de Fevereiro de 2017, 03:07 »
Boa tarde a todos,

Estou com um problema que ao iniciar o Ubuntu-mate 16.04 o teclado não funciona,preciso desligar o notebook e liga-lo novamente e ai sim ele carrega.
Tenho outras distros ,OpenSuse Leap 42.1 e Mageia 5.1, e nelas o teclado carrega sem problema algum.
Meu notebook é japones(generico),mas sempre foi reconhecido de boa, inclusive pelo Ubuntu 14.04.
Segue as configurações

-Computer-
Processor      : 4x Intel(R) Core(TM) i5 CPU       M 480  @ 2.67GHz
Memory      : 3840MB (1563MB used)
Operating System      : Ubuntu 16.04.1 LTS
-Display-
Resolution      : 1366x768 pixels
OpenGL Renderer      : Mesa DRI Intel(R) Ironlake Mobile
X11 Vendor      : The X.Org Foundation
-Multimedia-
Audio Adapter      : HDA-Intel - HDA Intel MID
-Input Devices-
 Lid Switch
 Sleep Button
 Power Button
 AT Translated Set 2 keyboard
 Video Bus
 SynPS/2 Synaptics TouchPad
 HDA Intel MID Mic
 HDA Intel MID Headphone
 HDA Intel MID HDMI/DP,pcm      : 3=
-SCSI Disks-
ATA WDC WD7500BPVT-0
TSSTcorp CDDVDW TS-L633F

Procurei um topico mas não encontrei nenhum que me ajudasse
Bom espero que possam me ajudar.



Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.443
    • Ver perfil
Re:Teclado não funciona ao iniciar o sistema
« Resposta #1 Online: 06 de Fevereiro de 2017, 20:02 »
Considerando que funciona satisfatoriamente em outras distros, então se afasta que possa ser algum defeito no próprio equipamento.

1) Funciona quando está na tela do menu do grub?
Na verdade como aparentemente há um sistema multiboot, várias distros, qual delas controla de fato o menu do grub (distro master)?

2) Se subir o sistema atraves de um live-iso (pendrive ou cdrom) tambem do Ubuntu-Mate (ou pelo menos de outro "sabor" Ubuntu 16.04), funciona ou nao?

3) Se tiver disponível um teclado externo do tipo usb (com ou sem fio), fazer um teste pode ser interessante como tentativa de segmentar e individualizar o problema;

4) No Ubuntu-Mate indo no ControlCenter/Keyboard, como o teclado aparece identificado?

5) Traga informações do pacote inxi sobre o sistema (normalmente ele já vem pré-instalado no Ubuntu-Mate):

Código: [Selecionar]
inxi -FxZ
6) Traga ao tópico os resultados dos comandos:

Código: [Selecionar]
xinput --list
(duplo hífen antes do --list)

Código: [Selecionar]
ls /dev/input/*
Código: [Selecionar]
dmesg | grep keyboard
« Última modificação: 06 de Fevereiro de 2017, 20:21 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Brisighelli

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re:Teclado não funciona ao iniciar o sistema
« Resposta #2 Online: 07 de Fevereiro de 2017, 12:32 »
Considerando que funciona satisfatoriamente em outras distros, então se afasta que possa ser algum defeito no próprio equipamento.

1) Funciona quando está na tela do menu do grub?
Na verdade como aparentemente há um sistema multiboot, várias distros, qual delas controla de fato o menu do grub (distro master)?

2) Se subir o sistema atraves de um live-iso (pendrive ou cdrom) tambem do Ubuntu-Mate (ou pelo menos de outro "sabor" Ubuntu 16.04), funciona ou nao?

3) Se tiver disponível um teclado externo do tipo usb (com ou sem fio), fazer um teste pode ser interessante como tentativa de segmentar e individualizar o problema;

4) No Ubuntu-Mate indo no ControlCenter/Keyboard, como o teclado aparece identificado?

5) Traga informações do pacote inxi sobre o sistema (normalmente ele já vem pré-instalado no Ubuntu-Mate):

Código: [Selecionar]
inxi -FxZ
6) Traga ao tópico os resultados dos comandos:

Código: [Selecionar]
xinput --list
(duplo hífen antes do --list)

Código: [Selecionar]
ls /dev/input/*
Código: [Selecionar]
dmesg | grep keyboard

boa tarde e obrigado por responder.

segue as respostas

1-Funciona sim e o grub pertece ao proprio ubuntu-mate

2-Funciona sim.... subi pelo live do ubuntu-mate

3-nao tenho um teclado usb, mas se for o caso posso arrumar um no proximo fim de semana

4-Pc (intl) 105 teclas

5-
Código: [Selecionar]
System:   Kernel: 4.4.0-62-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.12.1 (Gtk 3.18.9-1ubuntu3.1)
           Distro: Ubuntu 16.04 xenial
Machine:   System: KOUZIRO (portable) product: KOUZIRONB v: 1.0
           Mobo: PEGATRON model: H36Y v: 1.0
           Bios: American Megatrends v: 202 date: 04/16/2010
CPU:       Dual core Intel Core i5 M 480 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10641
           clock speeds: max: 2667 MHz 1: 1333 MHz 2: 1599 MHz 3: 1333 MHz
           4: 1599 MHz
Graphics:  Card: Intel Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.64hz
           GLX Renderer: Mesa DRI Intel Ironlake Mobile
           GLX Version: 2.1 Mesa 13.1.0-devel Direct Rendering: Yes
Audio:     Card Intel 5 Series/3400 Series High Definition Audio
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-62-generic
Network:   Card-1: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
           driver: ath9k bus-ID: 02:00.0
           IF: wlp2s0 state: up
           Card-2: Qualcomm Atheros AR8131 Gigabit Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: c000 bus-ID: 05:00.0
           IF: enp5s0 state: down
Drives:    HDD Total Size: 750.2GB (13.0% used)
           ID-1: /dev/sda model: WDC_WD7500BPVT size: 750.2GB
Partition: ID-1: / size: 98G used: 87G (95%) fs: ext4 dev: /dev/sda4
           ID-2: swap-1 size: 4.08GB used: 0.05GB (1%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 42.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 216 Uptime: 1:23 Memory: 1113.4/3750.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.461) inxi: 2.2.35

6-
Código: [Selecionar]
⎡ Virtual core pointer                    id=2 [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              id=4 [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              id=10 [slave  pointer  (2)]
⎣ Virtual core keyboard                    id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard              id=5 [slave  keyboard (3)]
    ↳ Power Button                            id=6 [slave  keyboard (3)]
    ↳ Video Bus                                id=7 [slave  keyboard (3)]
    ↳ Sleep Button                            id=8 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            id=9 [slave  keyboard (3)]

Código: [Selecionar]
/dev/input/event0  /dev/input/event3  /dev/input/event6  /dev/input/mice
/dev/input/event1  /dev/input/event4  /dev/input/event7  /dev/input/mouse0
/dev/input/event2  /dev/input/event5  /dev/input/event8

/dev/input/by-path:
platform-i8042-serio-0-event-kbd    platform-i8042-serio-4-mouse
platform-i8042-serio-4-event-mouse

Código: [Selecionar]
[    1.205266] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input3
esses foram os resultados
 obrigado pelo feedback.


Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.443
    • Ver perfil
Re:Teclado não funciona ao iniciar o sistema
« Resposta #3 Online: 07 de Fevereiro de 2017, 13:49 »
2) Se subir o sistema atraves de um live-iso (pendrive ou cdrom) tambem do Ubuntu-Mate (ou pelo menos de outro "sabor" Ubuntu 16.04), funciona ou nao?
segue as respostas
[...] 2-Funciona sim.... subi pelo live do ubuntu-mate

Apenas para deixar um pouco mais claro, na questão 2 anterior, o que se quer saber é se subindo o sistema através de um live-iso (pendrive ou cdrom), o problema do teclado não funcionar **nunca** ocorre, ou seja, se subir n vezes por um live-iso, sempre tudo funciona normal, o teclado funciona normal, nunca falha.

Confirma?

A razão da pergunta é distinguir entre o sistema live-iso e o sistema realmente instalado no disco.

Essa é uma situação difícil de diagnosticar e para ajudar o problema é intermitente, pois como você disse no post inicial "o teclado não funciona,preciso desligar o notebook e liga-lo novamente e ai sim ele carrega."

Ou seja, não é que não funcione sempre, funciona nessa específica situação.
« Última modificação: 07 de Fevereiro de 2017, 13:54 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.443
    • Ver perfil
Re:Teclado não funciona ao iniciar o sistema
« Resposta #4 Online: 07 de Fevereiro de 2017, 14:11 »
Bem, a única pista que há no momento é o uso do driver para o chip i8042 na identificação do keyboard pelo dmesg, então vamos experimentar um parâmetro de kernel associado a ele para ver se resulta.

Usando o editor de texto do Mate, o "pluma" ou qualquer outro que tenha instalado ou ainda o "nano", edite o arquivo:


Código: [Selecionar]
sudo pluma /etc/default/grub
acrescente o parâmetro:

Citar
i8042.nomux=1 i8042.reset

na linha:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"


que então fica assim:

Citar
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nomux=1 i8042.reset
"

o quiet e o splash dessa linha são opcionais, podem eventualmente até não existir na sua instalação caso você os tenha anteriormente excluído, servem apenas para mostrar ou não as linhas de carga do sistema e ainda aquela tela das bolinhas, então, se preferir, questão de gosto, também pode ser assim:

Citar
GRUB_CMDLINE_LINUX_DEFAULT="i8042.nomux=1 i8042.reset"

Note, entretanto, que sempre estarão entre " " aspas duplas.
Evite digitar para evitar erros de retranscrição, marque com o mouse, depois copie e cole no arquivo.

Salvar e sair

Agora precisa atualizar o grub, que você disse que o master do grub aí no sistema é o próprio Ubuntu-Mate que controla o grub para todas as demais instalações de distro existentes, então execute:

Código: [Selecionar]
sudo update-grub
Reinicie o sistema e vamos ver o que acontece.

Depois de reiniciado confirme se o sistema subiu mesmo usando aquele parâmetro fazendo num terminal:

Código: [Selecionar]
cat /proc/cmdline
Deverá estar sendo possível ver o parâmetro colocado na linha de boot.

« Última modificação: 07 de Fevereiro de 2017, 14:29 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Brisighelli

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re:Teclado não funciona ao iniciar o sistema
« Resposta #5 Online: 10 de Fevereiro de 2017, 11:44 »
2) Se subir o sistema atraves de um live-iso (pendrive ou cdrom) tambem do Ubuntu-Mate (ou pelo menos de outro "sabor" Ubuntu 16.04), funciona ou nao?
segue as respostas
[...] 2-Funciona sim.... subi pelo live do ubuntu-mate

Apenas para deixar um pouco mais claro, na questão 2 anterior, o que se quer saber é se subindo o sistema através de um live-iso (pendrive ou cdrom), o problema do teclado não funcionar **nunca** ocorre, ou seja, se subir n vezes por um live-iso, sempre tudo funciona normal, o teclado funciona normal, nunca falha.

Confirma?

A razão da pergunta é distinguir entre o sistema live-iso e o sistema realmente instalado no disco.

Essa é uma situação difícil de diagnosticar e para ajudar o problema é intermitente, pois como você disse no post inicial "o teclado não funciona,preciso desligar o notebook e liga-lo novamente e ai sim ele carrega."

Ou seja, não é que não funcione sempre, funciona nessa específica situação.
isso mesmo...
eu carreguei por um pendrive uma live iso e o teclado carrega perfeito mas no ubuntu-mate que esta instalado na hd acontece de nao carregar, simplesmente nao carrega...

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.443
    • Ver perfil
Re:Teclado não funciona ao iniciar o sistema
« Resposta #6 Online: 11 de Fevereiro de 2017, 21:40 »
isso mesmo...
eu carreguei por um pendrive uma live iso e o teclado carrega perfeito mas no ubuntu-mate que esta instalado na hd acontece de nao carregar, simplesmente nao carrega...

OK, então o sistema sobe por um live-iso seguidas vezes sem problemas.

Fez as alterações propostas no post #4 no sistema instalado no disco?
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Brisighelli

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re:Teclado não funciona ao iniciar o sistema
« Resposta #7 Online: 13 de Fevereiro de 2017, 12:03 »
isso mesmo...
eu carreguei por um pendrive uma live iso e o teclado carrega perfeito mas no ubuntu-mate que esta instalado na hd acontece de nao carregar, simplesmente nao carrega...

OK, então o sistema sobe por um live-iso seguidas vezes sem problemas.

Fez as alterações propostas no post #4 no sistema instalado no disco?

Bom dia...

Fiz as alteracoes e o teclado nao apresentou o problema, mas confesso que nao tive mtu tempo para realizar varios testes...


Código: [Selecionar]
BOOT_IMAGE=/boot/vmlinuz-4.4.0-62-generic root=UUID=d2482c0e-2682-48ea-9b3d-44cb8d1386f6 ro i8042.nomux=1 i8042.reset

Fim de semana poderei verificar melhor
obrigado

Offline Brisighelli

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re:Teclado não funciona ao iniciar o sistema
« Resposta #8 Online: 25 de Fevereiro de 2017, 04:57 »
Ola..

bom nao tive mais problemas om o teclado...
Entao acredito que o problema foi resolvido

obrigado pela atencao

valeu ae  druidaobelix