Autor Tópico: base de dados de programas corrompida  (Lida 866 vezes)

Offline José Possobom

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
base de dados de programas corrompida
« Online: 10 de Janeiro de 2017, 19:36 »
(Resolvido)Sou novato, instalei a poucos dias. Consegui instalar o Inkscape no qual faço fotolitos e o Stelarium. Ao tentar instalar o Wine apareceu no terminal uma tela cinza com contrato da Microsoft, porém não surgiram opções para aceitar e prosseguir a instalação. Após tentei instalar o Synaptic e o Frostwire, mas só aparece a mensagem de erro  no DPKG, tem de correr manualmente. Apaguei 2 arquivos lock no /var/ lib e no DPKG não consegui. O comando configure-a não responde, configure-f  também não.Na instalação do Synaptic aparece a tela cinza e a mensagem base de dados corrompidas.Desde já agradeço e desejo Paz, Saúde, Felicidade e Vida Longa a todos. E viva a liberdade!
« Última modificação: 16 de Janeiro de 2017, 23:34 por José Possobom »

Offline hipplerlx

  • Usuário Ubuntu
  • *
  • Mensagens: 27
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #1 Online: 11 de Janeiro de 2017, 07:55 »
viva, vamos por partes a ver se conseguimos ajudar...
Wine - corra os seguintes comandos
sudo pkexec gedit /var/lib/dpkg/status e veja se encontra o package que esta a dar o erro, depois grave o ficheiro e saia do gedit
sudo dpkg --configure -a
sudo apt-get -f install (just in case :) )


Offline José Possobom

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #2 Online: 11 de Janeiro de 2017, 11:56 »
Caro hipplerlx: Antes de tudo agradeço a atenção e lhe desejo Saúde e Paz.
Eis a resposta:Failed to connect to Mir: Failed to connect to server socket: Arquivo ou diretório não encontrado
Unable to init server: Não foi possível conectar: Conexão recusada

(gedit:21951): Gtk-WARNING **: cannot open display:
resposta  do sudo dpkg--configure-ajoseolimpio@joseolimpio-S460-L-BG22P1:~$ sudo dpkg--configure-a
sudo: dpkg--configure-a: comando não encontrado
rodei novamente e respondeu assim:
dpkg: erro: base de dados de estado do dpkg está bloqueado por outro processo

~$ sudo apt-get -f install

E: Não foi possível obter trava /var/lib/dpkg/lock - open (11: Recurso temporariamente indisponível)
E: Não foi possível obter acesso exclusivo ao directório de administração (/var/lib/dpkg/), outro processo está a utilizá-lo?
Espero sinceramente que o amigo possa encontrar a solução. E reforço minha Gratidão.
« Última modificação: 11 de Janeiro de 2017, 12:40 por José Possobom »

Offline hipplerlx

  • Usuário Ubuntu
  • *
  • Mensagens: 27
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #3 Online: 11 de Janeiro de 2017, 12:14 »
gedit é apenas um editor grafico, experimente com o nano....
sudo pkexec nano /var/lib/dpkg/status   .... identifique o package que esta a dar o erro ( wine) , apague, grave,saia do nano  e corra os comandos
sudo dpkg --configure -a  e nao isto - "sudo: dpkg--configure-a": comando não encontrado, isto esta errado!!
sudo apt-get -f install



Caro hipplerlx: Antes de tudo agradeço a atenção e lhe desejo Saúde e Paz.
Eis a resposta:Failed to connect to Mir: Failed to connect to server socket: Arquivo ou diretório não encontrado
Unable to init server: Não foi possível conectar: Conexão recusada

(gedit:21951): Gtk-WARNING **: cannot open display:
resposta  do sudo dpkg--configure-ajoseolimpio@joseolimpio-S460-L-BG22P1:~$ sudo dpkg--configure-a
sudo: dpkg--configure-a: comando não encontrado
~$ sudo apt-get -f install

E: Não foi possível obter trava /var/lib/dpkg/lock - open (11: Recurso temporariamente indisponível)
E: Não foi possível obter acesso exclusivo ao directório de administração (/var/lib/dpkg/), outro processo está a utilizá-lo?
Espero sinceramente que o amigo possa encontrar a solução. E reforço minha Gratidão.

Offline José Possobom

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #4 Online: 11 de Janeiro de 2017, 13:01 »
Corri o Nano porém não consegui identificar o package que está a dar erro. Perdoe e entenda minha ignorância mas não sei apagar e gravar. Pois a resposta tem mais de 400 linhas. Corrigi o
sudo dpkg --configure-a
base de dados de estado do dpkg está bloquedo por outro processo

Offline nomade

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.100
  • O negócio não tem alma
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #5 Online: 11 de Janeiro de 2017, 21:31 »
Corri o Nano porém não consegui identificar o package que está a dar erro. Perdoe e entenda minha ignorância mas não sei apagar e gravar. Pois a resposta tem mais de 400 linhas. Corrigi o
sudo dpkg --configure-a
base de dados de estado do dpkg está bloquedo por outro processo
Você está com algum gerenciador de pacotes trabalhando

antes de executar algum dos comandos dados para reparar pacotes quebrados, você precisa matar todos os processos de gerenciadores de pacotes:
synaptic, gdebi, apt, apt-get, dpkg;

mate todos esses processos.

Se ainda assim não funcionar, execute esse comando:
Código: [Selecionar]
rm /var/lib/dpkg/lock

Depois disso, execute novamente os comandos sugeridos anteriormente pelos colegas


Rodando Ubuntu Gnome 16.04.2 com: AMD Bulldozer FX-6100 3.3GHz 6-Core Black Edition/ Gigabyte 78LMT-S2P/ 8GB de Ram/ Radeon R7 260X 2GB GDDR5 128bit

Offline José Possobom

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #6 Online: 11 de Janeiro de 2017, 23:02 »
Caro Nomade o bug do Ubuntu software foi resolvido. Apenas não sei explicar qual comando fez a tarefa. Apenas não entendi como e qual processo matar, pois há muitos e m funcionamento, mas o que mais usa memória é o Firefox.

Offline José Possobom

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #7 Online: 11 de Janeiro de 2017, 23:11 »
Quando corro o comando sudo dpkg --configure -a
[sudo] senha para joseolimpio:
dpkg: problemas com dependências impedem a configuração de synaptic:
 synaptic depende de libept1.5.0; porém:
  Pacote libept1.5.0 não está instalado.

dpkg: erro ao processar o pacote synaptic (--configure):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 synaptic
Já é um progresso, agora já dá mais detalhes.
Configurando ttf-mscorefonts-installer ├─────────────────┐
 │                                                                           │
 │ TrueType core fonts for the Web EULA                                       
 │                                                                             
 │ END-USER LICENSE AGREEMENT FOR MICROSOFT SOFTWARE                           
 │                                                                             
 │ IMPORTANT-READ CAREFULLY: This Microsoft End-User License Agreement         
 │ ("EULA") is a legal agreement between you (either an individual or a       
 │ single entity) and Microsoft Corporation for the Microsoft software         
 │ accompanying this EULA, which includes computer software and may include   
 │ associated media, printed materials, and "on-line" or electronic           
 │ documentation ("SOFTWARE PRODUCT" or "SOFTWARE"). By exercising your       
 │ rights to make and use copies of the SOFTWARE PRODUCT, you agree to be     
 │ bound by the terms of this EULA. If you do not agree to the terms of       
 │ this EULA, you may not use the SOFTWARE PRODUCT.                           
 │                                                                             
 │                                                                             
 │                                  <Ok>                 
mas aparece esta tela e nenhuma opção para avançar quand corri o comando: sudo apt-get -f install
Desde já agradeço e parabenizo a todos por dividir conosco seu farto e invejável conhecimento.

Offline nomade

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.100
  • O negócio não tem alma
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #8 Online: 13 de Janeiro de 2017, 13:30 »
Pra matar um processo você usa o comando "killall"

ficaria:

Para matar o synaptic, seria:
Código: [Selecionar]
sudo killall synapticPara matar o apt, seria:
Código: [Selecionar]
sudo killall aptPara matar o apt-get, seria:
Código: [Selecionar]
sudo killall apt-get
Assim por diante.

_____________//_______________

Vamos a sua outra questão sobre as dependências para instalar o synaptic.
Isso não é comum.

Tente o seguinte:

Código: [Selecionar]
sudo apt install libapt-inst1.5 libept1.4.12
Código: [Selecionar]
sudo apt install synaptic
Se o synaptic não instalar tem algo errado com sua sources list

Você instalou alguma PPA (fonte de softwares) diferente da padrão?

Me mostre seu arquivo /etc/apt/sources.list

Código: [Selecionar]
gedit /etc/apt/sources.list
Cole aqui pra eu dar uma olhada

« Última modificação: 13 de Janeiro de 2017, 15:43 por nomade »
Rodando Ubuntu Gnome 16.04.2 com: AMD Bulldozer FX-6100 3.3GHz 6-Core Black Edition/ Gigabyte 78LMT-S2P/ 8GB de Ram/ Radeon R7 260X 2GB GDDR5 128bit

Offline José Possobom

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #9 Online: 13 de Janeiro de 2017, 16:18 »
Caro Nomade eis o arquivo:# deb cdrom:[Ubuntu 16.04.1 LTS _Xenial Xerus_ - Release amd64 (20160719)]/ xenial main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://br.archive.ubuntu.com/ubuntu/ xenial main restricted
# deb-src http://br.archive.ubuntu.com/ubuntu/ xenial main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://br.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
# deb-src http://br.archive.ubuntu.com/ubuntu/ xenial-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://br.archive.ubuntu.com/ubuntu/ xenial universe
# deb-src http://br.archive.ubuntu.com/ubuntu/ xenial universe
deb http://br.archive.ubuntu.com/ubuntu/ xenial-updates universe
# deb-src http://br.archive.ubuntu.com/ubuntu/ xenial-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://br.archive.ubuntu.com/ubuntu/ xenial multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ xenial multiverse
deb http://br.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ xenial-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://br.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu xenial partner
# deb-src http://archive.canonical.com/ubuntu xenial partner

deb http://security.ubuntu.com/ubuntu xenial-security main restricted
# deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
deb http://security.ubuntu.com/ubuntu xenial-security universe
# deb-src http://security.ubuntu.com/ubuntu xenial-security universe
deb http://security.ubuntu.com/ubuntu xenial-security multiverse
# deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse

O Ububntu Software abriu ontem, hoje voltou a apresentar problemas. Abre e em seguida fecha sem mostrar nada apenas sinais de carregamento.
eis a resposta para o comando  sudo apt install libapt-inst1.5 libept1.4.12 e sudo apt install synaptic     --atenção esse comando apareceu após eu abrir outro terminal, pois no primeiro aberto apareceu aquela janela cinza sobre a qual me referi na mensagem anterior, na qual não é possível avançar e nem sair, com um contrato de adesão da Microsoft.
 Não foi possível obter trava /var/lib/dpkg/lock - open (11: Recurso temporariamente indisponível)
E: Não foi possível obter acesso exclusivo ao directório de administração (/var/lib/dpkg/), outro processo está a utilizá-lo?
Caro amigo Nomade lhe desejo um ótimo fim de semana e espero sinceramente que seu conhecimento me auxilie neste intrincado problema. Paz, Saúde, Felicidade e vida longa!!!

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.282
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #10 Online: 13 de Janeiro de 2017, 17:27 »
[...]  no primeiro aberto apareceu aquela janela cinza sobre a qual me referi na mensagem anterior, na qual não é possível avançar e nem sair, com um contrato de adesão da Microsoft. [...]

Naquela tela do contrato de adesão normalmente basta usar a tecla TAB para que o campo ativo vá para o OK e então acionar [Enter]

Não responde ao mouse, tampouco às teclas direcionais, normalmente funciona é com a tecla TAB mesmo.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline nomade

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.100
  • O negócio não tem alma
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #11 Online: 13 de Janeiro de 2017, 18:25 »
[...]  no primeiro aberto apareceu aquela janela cinza sobre a qual me referi na mensagem anterior, na qual não é possível avançar e nem sair, com um contrato de adesão da Microsoft. [...]

Naquela tela do contrato de adesão normalmente basta usar a tecla TAB para que o campo ativo vá para o OK e então acionar [Enter]

Não responde ao mouse, tampouco às teclas direcionais, normalmente funciona é com a tecla TAB mesmo.
Boa druidaobelix! Eu havia esquecido de comentar esse lance...

Caro Nomade eis o arquivo:# deb cdrom:[Ubuntu 16.04.1 LTS _Xenial Xerus_ - Release amd64 (20160719)]/ xenial main restricted
...
...
O Ububntu Software abriu ontem, hoje voltou a apresentar problemas. Abre e em seguida fecha sem mostrar nada apenas sinais de carregamento.
eis a resposta para o comando  sudo apt install libapt-inst1.5 libept1.4.12 e sudo apt install synaptic     --atenção esse comando apareceu após eu abrir outro terminal, pois no primeiro aberto apareceu aquela janela cinza sobre a qual me referi na mensagem anterior, na qual não é possível avançar e nem sair, com um contrato de adesão da Microsoft.
 Não foi possível obter trava /var/lib/dpkg/lock - open (11: Recurso temporariamente indisponível)
E: Não foi possível obter acesso exclusivo ao directório de administração (/var/lib/dpkg/), outro processo está a utilizá-lo?
Caro amigo Nomade lhe desejo um ótimo fim de semana e espero sinceramente que seu conhecimento me auxilie neste intrincado problema. Paz, Saúde, Felicidade e vida longa!!!


Então, a tela cinza a que se refere são os termos de licenciamento da instalação das fontes da microsoft. como o druidaobelix mencionou, para interagir com ela, é só clicar nela com o mouse (não vai acontecer nada mas você a estará selecionando) e depois teclar TAB (você verá que estará interagindo e podendo escolher entre concordar e não concordar. Aceite os termos e dê enter.

A mensagem ... Não foi possível obter trava /var/lib/dpkg/lock - open... se refere ao processo em andamento, que é essa tela cinza, cujo os termos de licença não foram aceitos e por isso o "apt" continua rodando, gerando o arquivo "lock" (trava) que serve para impedir outro processo de instalação de pacotes ao mesmo tempo, para evitar,  justamente, a quebra de pacotes.

_______________//_____________

Sobre sua sources.list

Parece tudo ok, mas você não habilitou o servidor internacional dos repositórios do Ubuntu, nem o repositório de parceiros Canonical.

Para fazer isso abra "Programas e atualizações" (software and updates)

Em "baixar de", escolha "servidor principal", marque a caixa "código fonte"

Vá na aba "outros programas" e marque "Parceiros Canonical"

Vá na aba "Atualizações" e marque "xenial-security, xenial-updates e xenial-backports", feche e nas opções que vão aparecer escolha "recarregar".

Depois disso, no terminal utilize o comando:

Código: [Selecionar]
sudo apt full-upgradese der algum erro, tente novamente:
Código: [Selecionar]
sudo dpkg --configure -ase não funcionar tente:
Código: [Selecionar]
sudo apt -f purge synapticse correr tudo bem, tente o
Código: [Selecionar]
sudo apt full-upgradedepois o
Código: [Selecionar]
sudo apt install synaptic
Com o synaptic instalado, boa parte dos problemas com pacotes podem ser resolvidos sem uso do terminal.

Obs.: esqueça temporariamente o Ubuntu Software, nem abra ele até não ter mais mensagens de erro em pacotes no terminal.

Quando seu sistema estiver ok, atualizado e sem pacotes quebrados, a gente começa a ver os erros do Ubuntu Software se ainda os tiver. Ok?
Muitas pessoas estão tendo problemas com o Ubuntu Software (que na verdade é o Gnome Software). As soluções mais comuns é instalar a antiga Central de Programas do Ubuntu, o synaptic, o gdebi (para instalar pacotes .deb diretamente), entre outras opções, mas a gente vê isso depois.

Manda brasa aí!

Se nada funcionar, faça uma instalação limpa e a gente te ajuda a configurar seu sistema do início para não haver erro.
Normalmente por uma coisa simples o sistema fica difícil de reparar...

« Última modificação: 13 de Janeiro de 2017, 18:35 por nomade »
Rodando Ubuntu Gnome 16.04.2 com: AMD Bulldozer FX-6100 3.3GHz 6-Core Black Edition/ Gigabyte 78LMT-S2P/ 8GB de Ram/ Radeon R7 260X 2GB GDDR5 128bit

Offline José Possobom

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #12 Online: 13 de Janeiro de 2017, 22:40 »
Caro Nomade consegui refazer todos os passos anteriores, inclusive avancei na tela do contrato conforme a dica do Druidaobelix e o launcher do synaptic até aparece, mas ao tentar abrir surge a mensagem de erro: Falha ao baixar arquivos de dados adicionais

Os seguintes pacotes solicitaram o download de dados adicionais após a instalação do pacote, mas os dados não puderam ser baixados ou não puderam ser processados.

ttf-mscorefonts-installer

O download será tentado novamente mais tarde, ou você pode tentar baixar novamente agora. A execução deste comando demanda uma conexão à Internet ativa.
Ao selecionar a opção de tentar agora aparece um novo terminal que em seguida fecha.
No terminal anterior aparece assim:Err:1 http://downloads.sourceforge.net/corefonts/andale32.exe
  400  Bad Request
W: Can't drop privileges for downloading as file '/var/lib/update-notifier/package-data-downloads/partial/andale32.exe' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permissão negada)
E: Falhou ao buscar https://ufpr.dl.sourceforge.net/project/corefonts/the fonts/final/andale32.exe  400  Bad Request

E: Download Failed
O  libept1.5.0 foi intalado.

Como podem ver estamos muito próximos do sucesso e resolução e mais uma vez agradeço aos Srs. pela atenção e dedicação seu auxílio está sendo valioso. Muito obrigado!!!!!!

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.282
    • Ver perfil
Re:base de dados de programas corrompida
« Resposta #13 Online: 13 de Janeiro de 2017, 23:04 »
[...] o launcher do synaptic até aparece, mas ao tentar abrir surge a mensagem de erro: Falha ao baixar arquivos de dados adicionais
Os seguintes pacotes solicitaram o download de dados adicionais após a instalação do pacote, mas os dados não puderam ser baixados ou não puderam ser processados.

ttf-mscorefonts-installer

O download será tentado novamente mais tarde, ou você pode tentar baixar novamente agora. A execução deste comando demanda uma conexão à Internet ativa.

Há um tópico neste momento correndo aqui no Fórum exatamente sobre essa questão do ttf-mscorefonts-installer, idêntica questão.

Confira lá, especialmente o post #3 do "flavioml":

http://ubuntuforum-br.org/index.php/topic,121258.msg666057.html#msg666057
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline creto

  • Expectador
  • Usuário Ubuntu
  • *
  • Mensagens: 293
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:base de dados de programas corrompida
« Resposta #14 Online: 14 de Janeiro de 2017, 08:10 »
Apenas a titulo de informação tive problemas no GIMP e Inkscape no xubuntu 16.04, ou seja a instalaçõ de programas na versão atual LTS não esta assim tão prática.

E ainda tem que o script ttf-msorefonts-installer da versão 16.04 esta bugada tentando puxar os pacotes de endereços inexistentes do sourceforge.net, ou seja a instalação de programas no ubuntu, vai movimentar o fórum de novo.

http://ubuntuforum-pt.org/index.php/topic,121265.msg666053.html#msg666053

T+
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Creto - Teste Blog do Creto