Autor Tópico: Problemas na instação - "Forçar a instalação UEFI?"  (Lida 1490 vezes)

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.282
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #15 Online: 06 de Março de 2017, 00:40 »
Fiz backup, alterei tudo para GPT e reinstalei os sistemas novamente tudo em UEFI.
Fiz alteração na ordem dos boots com o GRUB, [...]

Tudo reinstalado, novo particionamento, novos sistemas de arquivos, então as informações anteriores não mais servem para analisar a questão atual, já que o cenário agora é outro.

Providencie novas informações do cenário atual, use o Bootinfo do Boot-Repair para essa finalidade.

Inicie o sistema através de um live-iso (pendrive ou cdrom).

Habilite o repositório Universe antes de fazer a instalação.

Citar
Confirgurações do sistema/Programas e atualizações/Aplicativos Ubuntu

Deixe os 4 habilitados (main, universe, restricted, multiverse), fazendo o Reload.

ou então  mais diretamente pelo terminal:

Código: [Selecionar]
sudo software-properties-gtk
Depois de instalado o boot-repair há um botão com o nome Bootinfo, ele irá gerar um relatório e ao final pergunta se quer colocar o relatório no Pastebin, a partir do que gera uma url que permite acessar, então traga aqui ao tópico aquela url informada por ele para que se possa analisar.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Agt

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #16 Online: 06 de Março de 2017, 16:16 »
Segue a URL  http://paste2.org/FfFBh02F
Tentei entender o relatório, aparentemente não tem erros no boot, mas achei estranho o comportamento da entrada. E nessa nova instalação o Ubuntu demora ou eventualmente ocorre erro ao montar /dev/sda4 , acredito que isso faz com que não apareça a imagem que escolhi dessa partição e coloquei para o boot.
Outra curiosidade, quando mando reiniciar ou desligar o Ubuntu o PC faz Bip espaçados 3 vezes, como se estivesse fazendo boot 3 vezes, mas a tela fica escura. Isso acontece normalmente? Eu não me lembro de ter reparado nisso na primeira vez que instalei o Ubuntu.

Acabei de perceber que na BIOS as opções de Boot quando sem o DVD no drive,  são:  Windows Boot Manager (P1: SSD) e 2 opções de ubuntu (P1: SSD). Achei estranho, nunca vi dessa forma, sem poder escolher a ordem por unidade.

Tirando esses detalhes que observei e fiquei curioso para entender, os sistemas Windows 10 e Ubuntu estão funcionais. Talvez o maior problema seja os eventuais erros ou demora para montar a unidade sda4, quando na primeira vez que instalei o Ubuntu ele montava direto na inicialização.

« Última modificação: 06 de Março de 2017, 16:26 por Agt »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.282
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #17 Online: 07 de Março de 2017, 01:20 »
Tentei entender o relatório, aparentemente não tem erros no boot, mas achei estranho o comportamento da entrada. [...]

De fato, examinando o bootinfo parece não haver mesmo estruturalmente nada de errado, entretanto, com esse desenho de particionamento, você está saboreando o doce pela metade.  :)

Talvez haja uma questão de sincronia entre as unidades de disco.
« Última modificação: 07 de Março de 2017, 01:27 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Agt

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #18 Online: 07 de Março de 2017, 14:16 »
você está saboreando o doce pela metade.  :)

haha
Bom, como está funcional vou usando assim mesmo. Assim que conseguir trabalho vou comprar um SSD exclusivo para o Ubuntu. Quero deixar os OS em discos diferentes.
Mais uma vez muito obrigado pela ajuda e pelo aprendizado.  :D

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 920
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #19 Online: 07 de Março de 2017, 16:02 »
Sua partição efi está no seu segundo dispositivo de boot (/dev/sdb), ou seja, a unidade SSD.

Vc deve trocar isso no SETUP.

O primeiro dispositivo de boot deve ser a unidade SSD (/dev/sda)
O segundo dispositivo de boot deve ser o HD de 1 TiB (/dev/sdb)

Não sei se após fazer isso seu sistema continuará bootável. Caso não continue bootável, basta desfazer isso no SETUP.
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline Agt

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #20 Online: 08 de Março de 2017, 10:28 »
Sua partição efi está no seu segundo dispositivo de boot (/dev/sdb), ou seja, a unidade SSD.

Então selvaking, no SETUP da BIOS as opções de BOOT estão aparecendo assim: - ubuntu (P1: Samsung 850evo SSD)
                                                                                                                                                              - Windows Boot Manager (P1: Samsung 850evo SSD)
                                                                                                                                                              - ubuntu (P1: Samsung 850evo SSD)

Nunca vi ele dessa forma, sem poder escolher qual drive. Ele só apareceu a opção do driver de DVD/CD quando tinha colocado o DVD do Ubuntu para executar ele em live e executar o boot-repair.
Se deixo Windows Boot Manager em primeiro ele entra direto no Win10 sem passar pelo GRUB.
Só apareceu a opção de driver do DVD no SETUP quando inseri o disco do Ubuntu para executar ele em live.
A história dos "bips" que ele faz, quando desligo Ubuntu faz 2 "bips" bem espaçados, é um bip de POST. Como se para desligar o Ubuntu precisasse fazer o POST 2x antes de desligar a máquina e se for reiniciar são 2 bips para desligar o Ubuntu e 1 bip para reinício da máquina.
Coisa mais estranha...  :o


PS.: não são bips de erro de RAM, vídeo ou outro erro, são realmente como POST.

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 920
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #21 Online: 08 de Março de 2017, 12:31 »
Então selvaking, no SETUP da BIOS as opções de BOOT estão aparecendo assim: - ubuntu (P1: Samsung 850evo SSD)
                                                                                                                                                              - Windows Boot Manager (P1: Samsung 850evo SSD)
                                                                                                                                                              - ubuntu (P1: Samsung 850evo SSD)

Nunca vi ele dessa forma, sem poder escolher qual drive. Ele só apareceu a opção do driver de DVD/CD quando tinha colocado o DVD do Ubuntu para executar ele em live e executar o boot-repair.
Se deixo Windows Boot Manager em primeiro ele entra direto no Win10 sem passar pelo GRUB.
Só apareceu a opção de driver do DVD no SETUP quando inseri o disco do Ubuntu para executar ele em live.

A BIOS UEFI é assim. Ela mostra os sistemas bootaveis da partição EFI. Mais mesmo isso acontecendo deve haver uma escolha pra qual dispositivo inicializar primeiro ou vc deve fazer isso manualmente conectando o SSD na porta SATA0 e o HD de 1 TiB na porta SATA1 da sua placa-mãe!
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline Agt

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #22 Online: 08 de Março de 2017, 14:04 »
No caso não é estranho estar aparecendo 2 opções de Boot ubuntu no SSD? Talvez seria mais razoável se aparecesse 2 opções de boot ubuntu uma no SSD e outra no HDD, ele teria feito isso por estar instalado no HDD, mas identificou outro OS no SSD, logo gravaria boot em cada unidade.

E viajando ainda mais.... será que os 2 bips de POST que escuto ao desligar o Ubuntu não tem alguma relação com fato de estar aparecendo essas 2 opções de boot por ubuntu no SETUP?

Estou pensando em excluir as partições do Ubuntu e reinstalar, talvez só isso já resolveria a confusão.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.282
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #23 Online: 08 de Março de 2017, 14:20 »
Estou pensando em excluir as partições do Ubuntu e reinstalar, talvez só isso já resolveria a confusão.

Então se está mesmo disposto a aventuras, faça isso:

Código: [Selecionar]
sudo efibootmgr -o 4,3,2,0
Talvez precise ser assim:

Código: [Selecionar]
sudo efibootmgr -o 4,3,0,2
Pode ser que simplesmente não funcione ou que o setup não guarde essa alteração, depende do fabricante.

O primeiro -o é a letra vogal -o

Depois, para podermos ver o que aconteceu, traga o resultado para:

Código: [Selecionar]
efibootmgr -v
Nota:

Também pode ser que seja necessário especificar a ordem de forma completa:

0004,0003,0002,0000

Se o caso, se não funcionar daquela forma, teste dessa forma.
« Última modificação: 08 de Março de 2017, 14:47 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.282
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #24 Online: 08 de Março de 2017, 14:32 »
Em tempo, e se for reinstalar mesmo, veja se funciona criando uma partição adicional /boot no disco SSD, onde ficarão os arquivos do grub e o kernel, não precisa ser grande, se alocar um único 1GB para isso dá para a vida toda. Na reinstalação faça as opções manualmente e direcione o /boot para essa partição.

Isso evidentemente independe da partição EFI que já existe e continuará lá do jeito que está.
O bootloader do grub direcione para a EFI como já fez antes.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Agt

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #25 Online: 13 de Março de 2017, 10:12 »
Desculpa a demora, correria para entregar algumas atividades da faculdade.

Então os resultados:
Código: [Selecionar]
sudo efibootmgr -o 4,3,2,0
Invalid boot order entry value: 4
                                ^
Boot entry 0004 does not exist

Mesmo adicionando 000.

E
Código: [Selecionar]
efibootmgr -v
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0000,0002
Boot0000* Windows Boot Manager HD(2,GPT,bf0822b6-3744-4e94-98da-fe65bbe17a78,0xe1800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...o................
Boot0001* ubuntu HD(2,GPT,bf0822b6-3744-4e94-98da-fe65bbe17a78,0xe1800,0x32000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0002* ubuntu HD(2,GPT,bf0822b6-3744-4e94-98da-fe65bbe17a78,0xe1800,0x32000)/File(\EFI\UBUNTU\GRUBX64.EFI)

Acredito que vou precisar reinstalar o Ubuntu para ver o que aconte, criando essa partição /boot no SSD

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 4.282
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #26 Online: 13 de Março de 2017, 14:37 »
sudo efibootmgr -o 4,3,2,0
Invalid boot order entry value: 4
Boot entry 0004 does not exist

Faça sem usar o 4, que na realidade é a unidade de cdrom.

Código: [Selecionar]
sudo efibootmgr -o 3,2,0
ou

Código: [Selecionar]
sudo efibootmgr -o 3,0,2
« Última modificação: 13 de Março de 2017, 14:43 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Agt

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re:Problemas na instação - "Forçar a instalação UEFI?"
« Resposta #27 Online: 13 de Março de 2017, 18:52 »
Tive que fazer assim:
Código: [Selecionar]
sudo efibootmgr -o 2,0
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0002,0000
Boot0000* Windows Boot Manager
Boot0001* ubuntu
Boot0002* ubuntu

Código: [Selecionar]
efibootmgr -v
BootCurrent: 0001
Timeout: 1 seconds
show_boot_order(): Permission denied
Boot0000* Windows Boot Manager HD(2,GPT,bf0822b6-3744-4e94-98da-fe65bbe17a78,0xe1800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...o................
Boot0001* ubuntu HD(2,GPT,bf0822b6-3744-4e94-98da-fe65bbe17a78,0xe1800,0x32000)/File(\EFI\UBUNTU\SHIMX64.EFI)
Boot0002* ubuntu HD(2,GPT,bf0822b6-3744-4e94-98da-fe65bbe17a78,0xe1800,0x32000)/File(\EFI\UBUNTU\GRUBX64.EFI)

A opção Security Boot tá desligada, mesmo assim tá com SHIMX64... , não seria ele responsável pelo duplo POST quando desligo o Ubuntu?
Continua lento para desligar e fazendo 2 bips de POST.
Vou formatar e reinstalar, espero que resolva.
Como excluo SHIMX64  e GRUBX64 do SSD?
« Última modificação: 13 de Março de 2017, 19:25 por Agt »