Autor Tópico: server ubuntu não libera internet para a rede  (Lida 1344 vezes)

Offline jonatanrader

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
server ubuntu não libera internet para a rede
« Online: 14 de Dezembro de 2016, 17:18 »
Ola pessoal,  o server que tenho estava rodando muito bem, porém ao voltar das férias ele não esta compartilhando mais a rede nem a internet.  irei postar minhas configs,
PS: criei um script do iptables, dei permissão para executar no boot, mas não esta subindo. Estou reconfigurando ele do zero. Lembrando tenho duas placas de rede, uma local e outra rede externa.
Parece não esta fazendo o roteamento ;D, mas configurei, se alguém puder ajudar. fico grato.


Dhcp.conf

 ddns-update-style none;
default-lease-time 600;
max-lease-time 7200;
authoritative;

subnet 192.168.0.1 netmask 255.255.255.0 {   
   range 192.168.0 4 192.168.1.250;
   option routers 192.168.0.0;
   option domain-name-servers 8.8.8.8;
   options broadcast-address 192.168.0.255
}

root@FIREWALL:/home/spark# ifconfig

(ESTA É A REDE EXTERNA, LINK DA NET, ESTA CONECTADO)
enp2s0    Link encap:Ethernet  Endereço de HW 50:e5:4
          inet end.: 192.168.1.12  Bcast:192.168.1.255  Masc:255.255.255.0
          endereço inet6: 2804:14d:4cd0:1c39:52e5:49ff:fef6:9445/64 Escopo:Global
          endereço inet6: fe80::52e5:49ff:fef6:9445/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:12312 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:633 erros:0 descartados:0 excesso:0 portadora:1
          colisões:0 txqueuelen:1000
          RX bytes:1071364 (1.0 MB) TX bytes:72471 (72.4 KB)


REDE LOCA, DISTRUI PARA AS OUTRAS MAQUINAS, NÃO ESTA FUNCIONANDO.
enp3s0    Link encap:Ethernet  Endereço de HW 1c:7e:e5 
          endereço inet6: fe80::1e7e:e5ff:fe2d:262a/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:184 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:101 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:19356 (19.3 KB) TX bytes:16785 (16.7 KB)

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:181 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:181 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1
          RX bytes:12967 (12.9 KB) TX bytes:12967 (12.9 KB)

root@FIREWALL:/home/spark# iptables -S
-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT
root@FIREWALL:/home/spark# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         
root@FIREWALL:/home/spark# start firezinh

interfaces:
auto lo enp2s0 enp3s0
iface lo inet loopback

iface enp2s0 inet dhcp
   
   #address 192.168.1.110
   #netmask 255.255.255.0
   #network 192.168.1 0
   #broadcast 192.168.1.255
   #gateway 192.168.1.3


iface enp2s0 inet static
   
   address 192.168.0.2
   netmask 255.255.255.0
   network 192.168.0 0
   broadcast 192.168.1.255



Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.570
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #1 Online: 15 de Dezembro de 2016, 10:48 »
Tua configuração de dhcp tá toda errada...

Primeiro, se tua subnet é /24 e o range começou em "192.168.0.4", vc não pode terminar em "192.168.1.254", ele tem q terminar em "192.168.0.254".
E o valor do campo "routers" não pode ser "192.168.0.0", ele deve ser igual ao endereço da se a máquina nessa rede (supondo que ela é o gateway dessa rede).

Ainda não vi o resto da configuração, mais tarde comento sobre os outros dados q vc postou.

Enviado do meu smartphone.

Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline jonatanrader

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #2 Online: 15 de Dezembro de 2016, 11:57 »
Ola, sim Zakkerj, eu vi depois que postei, estou fazendo na correria pois o tempo é curto,

dhcp
 ddns-update-style none;
default-lease-time 600;
max-lease-time 7200;
authoritative;

subnet 192.168.0.0 netmask 255.255.255.0 {   
   range 192.168.0.4 192.168.0.250;
   option routers 192.168.0.1;
   option domain-name-servers 8.8.8.8;
   options broadcast-address 192.168.0.255;
}

mas reporta este erro:
root@FIREWALL:/home/spark# service isc-dhcp-server status
● isc-dhcp-server.service - ISC DHCP IPv4 server
   Loaded: loaded (/lib/systemd/system/isc-dhcp-server.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Qui 2016-12-15 11:43:00 BRST; 3s ago
     Docs: man:dhcpd(8)
  Process: 10904 ExecStart=/bin/sh -ec      CONFIG_FILE=/etc/dhcp/dhcpd.conf;      if [ -f /etc/ltsp/dhcpd.conf ]; then CONFI
 Main PID: 10904 (code=exited, status=1/FAILURE)

Dez 15 11:43:00 FIREWALL sh[10904]: Not configured to listen on any interfaces!
Dez 15 11:43:00 FIREWALL sh[10904]: If you think you have received this message due to a bug rather
Dez 15 11:43:00 FIREWALL sh[10904]: than a configuration issue please read the section on submitting
Dez 15 11:43:00 FIREWALL sh[10904]: bugs on either our web page at www.isc.org or in the README file
Dez 15 11:43:00 FIREWALL sh[10904]: before submitting a bug.  These pages explain the proper
Dez 15 11:43:00 FIREWALL sh[10904]: process and the information we find helpful for debugging..
Dez 15 11:43:00 FIREWALL sh[10904]: exiting.
Dez 15 11:43:00 FIREWALL systemd[1]: isc-dhcp-server.service: Main process exited, code=exited, status=1/FAILURE
Dez 15 11:43:00 FIREWALL systemd[1]: isc-dhcp-server.service: Unit entered failed state.
Dez 15 11:43:00 FIREWALL systemd[1]: isc-dhcp-server.service: Failed with result 'exit-code'.

iptables basico

root@FIREWALL:/home/spark# iptables -L -n -v
Chain INPUT (policy ACCEPT 616K packets, 41M bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain OUTPUT (policy ACCEPT 14113 packets, 1354K bytes)
 pkts bytes target     prot opt in     out     source               destination         

Offline jonatanrader

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #3 Online: 19 de Dezembro de 2016, 15:19 »
se alguém poder me da um help, o servidor DHCP esta enviando os ips, o Iptable esta correto recebe tudo e envia tudo, o nat esta ativo, porém nas maquinas clientes não esta navegando.

Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface
0.0.0.0         192.168.1.3     0.0.0.0         UG    0      0        0 enp2s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 enp3s0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 enp3s0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 enp2s0



DHCP
oot@FIREWALL:/home/spark# service isc-dhcp-server status
● isc-dhcp-server.service - ISC DHCP IPv4 server
   Loaded: loaded (/lib/systemd/system/isc-dhcp-server.service; enabled; vendor
   Active: active (running) since Sáb 2016-12-17 12:23:50 BRST; 2 days ago
     Docs: man:dhcpd(8)
 Main PID: 1181 (dhcpd)
   CGroup: /system.slice/isc-dhcp-server.service
           └─1181 dhcpd -user dhcpd -group dhcpd -f -4 -pf /run/dhcp-server/dhcp

Dez 19 15:15:47 FIREWALL dhcpd[1181]: DHCPDISCOVER from 50:b7:c via en
Dez 19 15:15:48 FIREWALL dhcpd[1181]: DHCPOFFER on 192.168.0.4 to 50:b7:
Dez 19 15:15:48 FIREWALL dhcpd[1181]: parse_option_buffer: malformed option dhcp (erro)
Dez 19 15:15:53 FIREWALL dhcpd[1181]: Wrote 1 leases to leases file.
Dez 19 15:15:53 FIREWALL dhcpd[1181]: DHCPREQUEST for 192.168.0.4 (192.168.0.5)
Dez 19 15:15:53 FIREWALL dhcpd[1181]: DHCPACK on 192.168.0.4 to 50:b7:
Dez 19 15:15:59 FIREWALL dhcpd[1181]: DHCPINFORM from 192.168.0.4 via enp3s0
Dez 19 15:15:59 FIREWALL dhcpd[1181]: DHCPACK to 192.168.0.4 (50:b7:c
Dez 19 15:17:03 FIREWALL dhcpd[1181]: DHCPINFORM from 192.168.0.4 via enp3s0
Dez 19 15:17:03 FIREWALL dhcpd[1181]: DHCPACK to 192.168.0.4 (50:b7:c

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.570
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #4 Online: 24 de Dezembro de 2016, 16:19 »
E o valor do campo "routers" não pode ser "192.168.0.0", ele deve ser igual ao endereço da se a máquina nessa rede (supondo que ela é o gateway dessa rede).
Confirma isso??? No primeiro post, vc deu a entender que o endereço da tua máquina é "192.168.0.2", não "192.168.0.1".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline jonatanrader

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #5 Online: 06 de Janeiro de 2017, 14:06 »
Olá.

Então segue as configs das placas


auto lo enp2s0
iface enp2s0 inet dhcp
   
   #address 192.168.1.88
   #netmask 255.255.255.0
   #network 192.168.1 3
   #broadcast 192.168.1.255
   

auto lo enp3s0
iface enp3s0 inet static
   
   address 192.168.0.5
   netmask 255.255.255.0
   network 192.168.0 1
   broadcast 192.168.0.255

A situação é a seguinte ,  o roteamento esta ativo, DHCP esta configurado,  Bind esta ok,  mas não esta conectando nas maquinas clientes,  dou um Ping no dns do google, porém o host esta inacessível, pensei que poderia ser Bind, pois não estaria resolvendo os nomes, o DHCP esta sendo distribuído corretamente e o gateway das maquinas clientes é o 192.168.0.1.




Offline jonatanrader

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #6 Online: 06 de Janeiro de 2017, 14:55 »
Estava revendo as configurações e o bind esta reportando erro, não sei o que fiz de errado. Ta liberado no Firewall  a porta.
o uniuco arquivo que modifiquei foi o /etc/default/bind9
# run resolvconf?
RESOLVCONF=yes

# startup options for the server
OPTIONS="-4 -u bind"

root@FIREWALL:/home/spark# netstat -na | grep :53
tcp        0      0 127.0.1.1:53            0.0.0.0:*               OUÇA     
udp        0      0 0.0.0.0:5353            0.0.0.0:*                         
udp        0      0 127.0.1.1:53            0.0.0.0:*                         
udp6       0      0 :::5353                 :::*


root@FIREWALL:/home/spark# service bind9 status
● bind9.service - BIND Domain Name Server
   Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: en
  Drop-In: /run/systemd/generator/bind9.service.d
           └─50-insserv.conf-$named.conf
   Active: failed (Result: exit-code) since Sex 2017-01-06 13:56:43 BRST; 15s ag
     Docs: man:named(8)
  Process: 5012 ExecStop=/usr/sbin/rndc stop (code=exited, status=1/FAILURE)
  Process: 4988 ExecStart=/usr/sbin/named -f -u bind (code=exited, status=1/FAIL
 Main PID: 4988 (code=exited, status=1/FAILURE)

Jan 06 13:56:43 FIREWALL named[4988]: using up to 4096 sockets
Jan 06 13:56:43 FIREWALL named[4988]: loading configuration from '/etc/bind/name
Jan 06 13:56:43 FIREWALL named[4988]: /etc/bind/named.conf.options:21: expected
Jan 06 13:56:43 FIREWALL named[4988]: loading configuration: unexpected token
Jan 06 13:56:43 FIREWALL named[4988]: exiting (due to fatal error)
Jan 06 13:56:43 FIREWALL systemd[1]: bind9.service: Main process exited, code=ex
Jan 06 13:56:43 FIREWALL rndc[5012]: rndc: connect failed: 127.0.0.1#953: connec
Jan 06 13:56:43 FIREWALL systemd[1]: bind9.service: Control process exited, code
Jan 06 13:56:43 FIREWALL systemd[1]: bind9.service: Unit entered failed state.
Jan 06 13:56:43 FIREWALL systemd[1]: bind9.service: Failed with result 'exit-cod



Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.570
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #7 Online: 06 de Janeiro de 2017, 15:13 »
Olá.

Então segue as configs das placas


auto lo enp2s0
iface enp2s0 inet dhcp
   
   #address 192.168.1.88
   #netmask 255.255.255.0
   #network 192.168.1 3
   #broadcast 192.168.1.255
   

auto lo enp3s0
iface enp3s0 inet static
   
   address 192.168.0.5
   netmask 255.255.255.0
   network 192.168.0 1
   broadcast 192.168.0.255

A situação é a seguinte ,  o roteamento esta ativo, DHCP esta configurado,  Bind esta ok,  mas não esta conectando nas maquinas clientes,  dou um Ping no dns do google, porém o host esta inacessível, pensei que poderia ser Bind, pois não estaria resolvendo os nomes, o DHCP esta sendo distribuído corretamente e o gateway das maquinas clientes é o 192.168.0.1.
Agora sua interface está com o endereço "192.168.0.5".
Pq ela não está com o endereço "192.168.0.1"?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.570
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #8 Online: 06 de Janeiro de 2017, 15:21 »
Estava revendo as configurações e o bind esta reportando erro, não sei o que fiz de errado. Ta liberado no Firewall  a porta.
o uniuco arquivo que modifiquei foi o /etc/default/bind9
# run resolvconf?
RESOLVCONF=yes

# startup options for the server
OPTIONS="-4 -u bind"

root@FIREWALL:/home/spark# netstat -na | grep :53
tcp        0      0 127.0.1.1:53            0.0.0.0:*               OUÇA     
udp        0      0 0.0.0.0:5353            0.0.0.0:*                         
udp        0      0 127.0.1.1:53            0.0.0.0:*                         
udp6       0      0 :::5353                 :::*


root@FIREWALL:/home/spark# service bind9 status
● bind9.service - BIND Domain Name Server
   Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: en
  Drop-In: /run/systemd/generator/bind9.service.d
           └─50-insserv.conf-$named.conf
   Active: failed (Result: exit-code) since Sex 2017-01-06 13:56:43 BRST; 15s ag
     Docs: man:named(8)
  Process: 5012 ExecStop=/usr/sbin/rndc stop (code=exited, status=1/FAILURE)
  Process: 4988 ExecStart=/usr/sbin/named -f -u bind (code=exited, status=1/FAIL
 Main PID: 4988 (code=exited, status=1/FAILURE)

Jan 06 13:56:43 FIREWALL named[4988]: using up to 4096 sockets
Jan 06 13:56:43 FIREWALL named[4988]: loading configuration from '/etc/bind/name
Jan 06 13:56:43 FIREWALL named[4988]: /etc/bind/named.conf.options:21: expected
Jan 06 13:56:43 FIREWALL named[4988]: loading configuration: unexpected token
Jan 06 13:56:43 FIREWALL named[4988]: exiting (due to fatal error)
Jan 06 13:56:43 FIREWALL systemd[1]: bind9.service: Main process exited, code=ex
Jan 06 13:56:43 FIREWALL rndc[5012]: rndc: connect failed: 127.0.0.1#953: connec
Jan 06 13:56:43 FIREWALL systemd[1]: bind9.service: Control process exited, code
Jan 06 13:56:43 FIREWALL systemd[1]: bind9.service: Unit entered failed state.
Jan 06 13:56:43 FIREWALL systemd[1]: bind9.service: Failed with result 'exit-cod
Aparentemente o rndc (aplicativo auxiliar) não está autorizado a controlar o processo bind. Há um procedimento pra isso, é preciso gerar uma chave de acesso, que fica gravada no arquivo "/etc/bind/rndc.key".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline jonatanrader

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #9 Online: 09 de Janeiro de 2017, 17:22 »
E ai,  já resolvi o problema do Bind.

● bind9.service - BIND Domain Name Server
   Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: en
  Drop-In: /run/systemd/generator/bind9.service.d
           └─50-insserv.conf-$named.conf
   Active: active (running) since Seg 2017-01-09 14:26:35 BRST; 2h 28min ago
     Docs: man:named(8)
 Main PID: 1154 (named)
   CGroup: /system.slice/bind9.service
           └─1154 /usr/sbin/named -f -u bind



resolv.conf
nameserver 8.8.8.8
nameserver 192.168.1.3
nameserver 127.0.1.1 ( Não configurei)

root@FIREWALL:/home/spark# netstat -na | grep :53
tcp        0      0 127.0.1.1:53            0.0.0.0:*               OUÇA     
tcp        0      0 192.168.1.88:53         0.0.0.0:*               OUÇA     
tcp        0      0 192.168.0.5:53          0.0.0.0:*               OUÇA     
tcp        0      0 127.0.0.1:53            0.0.0.0:*               OUÇA     
tcp6       0      0 :::53                   :::*                    OUÇA     
udp        0      0 0.0.0.0:5353            0.0.0.0:*                         
udp        0      0 127.0.1.1:53            0.0.0.0:*                         
udp        0      0 192.168.1.88:53         0.0.0.0:*                         
udp        0      0 192.168.0.5:53          0.0.0.0:*                         
udp        0      0 127.0.0.1:53            0.0.0.0:*                         
udp6       0      0 :::5353                 :::*                               
udp6       0      0 :::53                   :::*

Iptables

oot@FIREWALL:/home/spark# iptables -S
-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT
-A INPUT -p tcp -m tcp --dport 53 -j ACCEPT
-A INPUT -p udp -m udp --dport 53 -j ACCEPT
-A FORWARD -d 192.168.1.0/24 -i enp2s0 -m string --string "facebook.com" --algo bm --to 65535 -j DROP
-A FORWARD -d 192.168.1.0/24 -i enp2s0 -m string --string "twitter.com" --algo bm --to 65535 -j DROP


Regras iptables
as regras;
iptables -F INPUT
iptables -F OUTPUT
iptables -F FORWARD
iptables -t nat -F
iptables -t mangle -F


#adicionando modulos no kernel;

modprobe iptable_nat

#liberando encaminhamento de pacotes;
echo "1" > /proc/sys/net/ipv4/ip_forward

#compartilhando a internet;
iptables -t nat -A POSTROUTING -o enp2s0 -j MASQUERADE

-A INPUT -p udp -m udp --dport 53 -j ACCEPT

-A INPUT -p tcp --dport 53 -j ACCEPT


Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface
0.0.0.0         192.168.1.3     0.0.0.0         UG    0      0        0 enp2s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 enp3s0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 enp3s0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 enp2s0


Deixei assim mesmo
auto lo enp3s0
iface enp3s0 inet static
   
   address 192.168.0.5  (creio que não existe problema em deixar este ip!)
   netmask 255.255.255.0
   network 192.168.0 1
   broadcast 192.168.0.255


mas ainda estiou sem rede nos pcs clientes, da erro de gateway e ip


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.570
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #10 Online: 09 de Janeiro de 2017, 17:31 »
Mas claro que vai dar erro de gateway nos clientes. Eles esperam encontrar o gateway em 192.168.0.1, vc está configurando sua máquina pra escutar em 192.168.0.5...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline jonatanrader

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #11 Online: 10 de Janeiro de 2017, 16:27 »
Deixei assim a placa da rede interna

Deixei assim mesmo
auto lo enp3s0
iface enp3s0 inet static
   
   address 192.168.0.1 
   netmask 255.255.255.0
   network 192.168.0 1
   broadcast 192.168.0.255

continuo sem rede. nos clientes.

Mas notei um outro problema, eu criei um script para o firewall, porém ao ver as regras do iptables (iptables -L)  não é o script que criei.
ja verifiquei os arquivos do iptables e não achei nada de errado, desinstalei e reinstalei ele e continuou no mesmo, tem alguma idéia do que pode ser,
e ai pode estar o problema do roteamento......?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.570
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #12 Online: 10 de Janeiro de 2017, 17:42 »
Uma coisa de cada vez.

Entre em uma das estações de trabalho da rede, execute o comando "ipconfig". Cole o resultado aqui.
Execute também o comando "ping 192.168.0.1". Cole o resultado aqui também.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline jonatanrader

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #13 Online: 11 de Janeiro de 2017, 15:13 »
SEGUE RESULTADO DA MAQUINA CLIENTE

C:\Users\FIRE>IPCONFIG

Configuração de IP do Windows


Adaptador Ethernet Conexão de Rede Bluetooth:

   Estado da mídia. . . . . . . . . . . . . .  : mídia desconectada
   Sufixo DNS específico de conexão. . . . . . :

Adaptador Ethernet Conexão local:

   Sufixo DNS específico de conexão. . . . . . :
   Endereço IPv6 de link local . . . . . . . . : fe80::f03e:3f58:8cd
   Endereço IPv4. . . . . . . .  . . . . . . . : 192.168.0.4
   Máscara de Sub-rede . . . . . . . . . . . . : 255.255.255.0
   Gateway Padrão. . . . . . . . . . . . . . . : 192.168.1.3

C:\Users\FIRE>PING 192.168.0.1

Disparando 192.168.0.1 com 32 bytes de dados:
Resposta de 192.168.0.1: bytes=32 tempo<1ms TTL=64
Resposta de 192.168.0.1: bytes=32 tempo<1ms TTL=64
Resposta de 192.168.0.1: bytes=32 tempo<1ms TTL=64
Resposta de 192.168.0.1: bytes=32 tempo<1ms TTL=64

Estat¡sticas do Ping para 192.168.0.1:
    Pacotes: Enviados = 4, Recebidos = 4, Perdidos = 0 (0% de
             perda),
Aproximar um n£mero redondo de vezes em milissegundos:
    M¡nimo = 0ms, M ximo = 0ms, M‚dia = 0ms




Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.570
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:server ubuntu não libera internet para a rede
« Resposta #14 Online: 11 de Janeiro de 2017, 15:19 »
 
Citar
Gateway Padrão. . . . . . . . . . . . . . . : 192.168.1.3
???  :o

De onde veio isso?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D