Autor Tópico: (tópico dividido) Wifi desconecta apenas da internet e não reconecta sem reboot  (Lida 569 vezes)

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 315
    • Ver perfil
Tenho o mesmo problema na CPU e estou acompanhando o tópico.
Alguns detalhes da configuração da máquina que julguei relevante para este tópico:
Código: [Selecionar]
~$ cat /proc/cpuinfo
model name : Intel(R) Core(TM)2 Duo CPU     E4600  @ 2.40GHz
~$ lspci
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
~$ lsusb
Bus 001 Device 003: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 04f2:0402 Chicony Electronics Co., Ltd Genius LuxeMate i200 Keyboard
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Abaixo o resultado dos comandos.
Código: [Selecionar]
~$ sudo lshw -C network
*-network               
       descrição: Ethernet interface
       produto: RTL-8110SC/8169SC Gigabit Ethernet
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 5
       informações do barramento: pci@0000:01:05.0
       nome lógico: eth2
       versão: 10
       serial: 00:1a:4d:a5:b2:a6
       tamanho: 10Mbit/s
       capacidade: 1Gbit/s
       largura: 32 bits
       clock: 66MHz
       capacidades: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=64 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
       recursos: irq:21 porta de E/S:a000(tamanho=256) memória:e1000000-e10000ff memória:e0000000-e001ffff
  *-network
       descrição: Interface sem fio
       ID físico: 1
       informações do barramento: usb@1:6
       nome lógico: wlan1
       serial: e8:94:f6:13:af:9e
       capacidades: ethernet physical wireless
       configuração: broadcast=yes driver=rtl8192cu driverversion=4.4.0-47-generic firmware=N/A ip=192.168.1.2 link=yes multicast=yes wireless=IEEE 802.11bgn
~$ ifconfig -a
eth2      Link encap:Ethernet  Endereço de HW 00:1a:4d:a5:b2:a6 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:23767 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:23767 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1
          RX bytes:2284741 (2.2 MB) TX bytes:2284741 (2.2 MB)

wlan1     Link encap:Ethernet  Endereço de HW e8:94:f6:13:af:9e 
          inet end.: 192.168.1.2  Bcast:192.168.1.255  Masc:255.255.255.0
          endereço inet6: 3ffe:501:ffff:100:ea94:f6ff:fe13:af9e/64 Escopo:Global
          endereço inet6: fe80::ea94:f6ff:fe13:af9e/64 Escopo:Link
          endereço inet6: 3ffe:501:ffff:100:304b:8802:370c:8bdf/64 Escopo:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:185449 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:162872 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:170292737 (170.2 MB) TX bytes:24862444 (24.8 MB)
~$ iwconfig
lo        no wireless extensions.

wlan1     IEEE 802.11bgn  ESSID:"Preta24" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: C4:01:7C:26:A5:A8   
          Bit Rate=6.5 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=56/70  Signal level=-54 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:48   Missed beacon:0

eth2      no wireless extensions.
O Resolv.conf também está apontando para o 127.0.0.1.

Observações importantes:
1 - Ao digitar uma URL no firefox e pressionar Enter, a guia fica pensando um tempão antes de abrir a página solicitada. Então, abro uma nova guia e passo o mouse sobre as sugestões da página inicial. Este procedimento parece (eu disse parece) que "acorda" a solicitação inicial que começa, enfim, a processar a página solicitada. Também funciona fazendo uma procura qualquer na busca da segunda guia.
2 - As atualizações demoram um tempão para começar a processar. Depois que engrena,  opera normal.
3 - Na metade das vezes as enganadas do item 1 não funcionam. Então clico no ícone que fica na barra superior e seleciono novamente a mesma conexão que estava antes. O sistema mostra um aviso de desconexão e reconexão em uns 10 segundos. Um F5 e volta ao normal
« Última modificação: 29 de Novembro de 2016, 11:20 por maurov »

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 315
    • Ver perfil
(tópico dividido) Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #1 Online: 01 de Dezembro de 2016, 10:29 »
- Como na conexão cabeada não cai, descartamos a hipótese do DNS.
- Também troquei de porta USB o adaptador, mas continuou a mesma coisa. Poderia ser as USB como um todo, sei lá. A impressora e a webcam que estão via USB operam normalmente, embora a exigência seja bem menor.
- Sobre o sinal wireless, tem outras máquinas na rede (com ubuntu e windows), e até mais distantes do access point, que operam sem cair.
- Já troquei de adaptador USB. Usava um TP-LInk TL-WN821N 300Mbps que não caia no Ubuntu14.04 e passei a usar um
TP-Link TL-WN 822N 300Mbps com 2 antenas igual ao usado em outra máquina ubuntu na rede que está funcionando normalmente.

Aceito sugestões dos parceiros
« Última modificação: 06 de Dezembro de 2016, 14:16 por nomade »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.427
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #2 Online: 01 de Dezembro de 2016, 15:28 »
Quanto a você, Maurov, sinto muito te informar, mas você não tem o mesmo problema: você tem o mesmo sintoma.

Você não usa a mesma controladora wireless que o massonals, e me parece também que você está usando outra versão do Ubuntu, visto que suas interfaces ainda estão com o nome antigo. Pelo bem da pesquisa, seria até melhor que seu caso fosse tratado em um tópico separado. Mas a esta altura...

O que eu posso te dizer é que eu tive uma ótima experiência com o adaptador TL-WN822N, funcionou de primeira no (K)ubuntu 14.04. Sugiro fortemente que você dê preferência a usar este no seu Ubuntu, e deixe o outro, o WN821N, que usa o chipset problemático RTL8192CU, para a outra máquina.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 315
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #3 Online: 01 de Dezembro de 2016, 16:44 »
Pois é, mesmo sintoma.
Também pensei em criar um novo tópico, mas na hora julguei melhor continuar a discussão neste, sei lá.

Eu já estava usando usando o adaptador  TL-WN822N, deixei o WN821N guardado. Ambos funcionavam bem no 14.04. Aliás, ainda tem máquina com 14.04 com este mesmo adaptador 822 funcionando bem, na rede.

Por controladora, você se refere ao barramento USB listado no lspci?
USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)

E o sistema acho que é o mesmo 16.04. Não fiz instalação do zero, fiz o upgrade quando foi disponibilizado.
Código: [Selecionar]
~$ lsb_release -d
Description: Ubuntu 16.04.1 LTS

Se for o caso, reinstalo geral.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.427
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #4 Online: 01 de Dezembro de 2016, 16:57 »
Não, essa é a controladora USB. A controladora wireless é essa:
(...)
~$ lsusb
Bus 001 Device 003: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter
(...)
Essa descrição é compatível com o TL-WN821N.

O TL-WN822N usa outro chipset (Atheros), não um Realtek.

Quanto à versão do Ubuntu, o fato de vc ter atualizado, em vez de reinstalar, explica a diferença dos nomes das interfaces.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 315
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #5 Online: 01 de Dezembro de 2016, 17:18 »
Ôpa! Pode ser por aí. Tirei um e pluguei o outro. O sistema pareceu compreender que era o mesmo.
Como faço para limpar este registro? Já desliguei várias vezes a máquina e liguei de novo e nada mudou.
:)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.427
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #6 Online: 02 de Dezembro de 2016, 07:43 »
Não, não reconhece sendo o mesmo não. Os drivers são diferentes. O que pode ter acontecido é que a interface recebeu o mesmo nome.
Deixe o WN822 conectado e repita os testes (os comandos que eu pedi ao autor do tópico).
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 315
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #7 Online: 02 de Dezembro de 2016, 09:18 »
Com o adaptador 822, aquele que tem as 2 antenas plugado desde o início do boot:
Código: [Selecionar]
:~$ lsusb
Bus 001 Device 003: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter
Este adaptador 822 está na versão3.0, segundo a etiqueta

Com o 821 agora (não rebootei)
Código: [Selecionar]
:~$ lsusb
Bus 001 Device 004: ID 0cf3:7015 Atheros Communications, Inc. TP-Link TL-WN821N v3 / TL-WN822N v2 802.11n [Atheros AR7010+AR9287]

Nota: Ambos funcionavam na v14.04antes do upgrade para a v16.04
« Última modificação: 02 de Dezembro de 2016, 09:24 por maurov »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.427
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #8 Online: 02 de Dezembro de 2016, 12:23 »
... os comandos que eu pedi, só com o WN822...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 315
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #9 Online: 02 de Dezembro de 2016, 12:47 »
Código: [Selecionar]
:~$ lshw
*-network               
       descrição: Ethernet interface
       produto: RTL-8110SC/8169SC Gigabit Ethernet
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 5
       informações do barramento: pci@0000:01:05.0
       nome lógico: eth2
       versão: 10
       serial: 00:1a:4d:a5:b2:a6
       tamanho: 10Mbit/s
       capacidade: 1Gbit/s
       largura: 32 bits
       clock: 66MHz
       capacidades: pm bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=64 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
       recursos: irq:21 porta de E/S:a000(tamanho=256) memória:e1000000-e10000ff memória:e0000000-e001ffff
  *-network
       descrição: Interface sem fio
       ID físico: 1
       informações do barramento: usb@1:6
       nome lógico: wlan1
       serial: e8:94:f6:13:af:9e
       capacidades: ethernet physical wireless
       configuração: broadcast=yes driver=rtl8192cu driverversion=4.4.0-51-generic firmware=N/A ip=192.168.1.2 link=yes multicast=yes wireless=IEEE 802.11bgn

Código: [Selecionar]
:~$ ifconfig -a
eth2      Link encap:Ethernet  Endereço de HW 00:1a:4d:a5:b2:a6 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:146987 erros:0 descartados:1 excesso:0 quadro:0
          Pacotes TX:122964 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:147449645 (147.4 MB) TX bytes:16178466 (16.1 MB)

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:18729 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:18729 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1
          RX bytes:1753186 (1.7 MB) TX bytes:1753186 (1.7 MB)

wlan1     Link encap:Ethernet  Endereço de HW e8:94:f6:13:af:9e 
          inet end.: 192.168.1.2  Bcast:192.168.1.255  Masc:255.255.255.0
          endereço inet6: 3ffe:501:ffff:100:ea94:f6ff:fe13:af9e/64 Escopo:Global
          endereço inet6: fe80::ea94:f6ff:fe13:af9e/64 Escopo:Link
          endereço inet6: 3ffe:501:ffff:100:cd89:4ada:d4cd:a515/64 Escopo:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:222 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:338 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:59933 (59.9 KB) TX bytes:50070 (50.0 KB)

Código: [Selecionar]
:~$ iwconfig
lo        no wireless extensions.

wlan1     IEEE 802.11bgn  ESSID:"MinhaRede24" 
          Mode:Managed  Frequency:2.432 GHz  Access Point: C4:01:7C:26:A5:A8   
          Bit Rate=78 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-38 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2   Missed beacon:0

eth2      no wireless extensions.
Código: [Selecionar]
:~$ nmcli dev wifi
*  SSID        MODO   CANAL  TAXA       SINAL  BARRAS  SEGURANÇA
*  MinhaRede24     Infra  5      54 Mbit/s  80     ▂▄▆_    WPA2

Código: [Selecionar]
:~$ cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1

Código: [Selecionar]
:~$ route -n
Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    600    0        0 wlan1
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan1
192.168.1.0     0.0.0.0         255.255.255.0   U     600    0        0 wlan1

Código: [Selecionar]
:~$ lsusb
Bus 001 Device 005: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 04f2:0402 Chicony Electronics Co., Ltd Genius LuxeMate i200 Keyboard
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
« Última modificação: 02 de Dezembro de 2016, 12:49 por maurov »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.427
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #10 Online: 02 de Dezembro de 2016, 13:03 »
Você executou com o WN821.
Com o WN822, qual o resultado?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 315
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #11 Online: 02 de Dezembro de 2016, 14:41 »
Executei com o TL-WN822N ver3.0 S/N2141259007180
300Mbps High Gain Wireless USB Adapter
Anatel 1233-11-3177

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.427
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #12 Online: 02 de Dezembro de 2016, 15:14 »
Não, no momento em que você plugou, estava um WN821, com chipset Realtek.
Será que você tem 2 WN821, e pensa que tem um WN822?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 315
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #13 Online: 02 de Dezembro de 2016, 15:21 »
hehe, com certeza não.
O 821 é parecido com um pen-drive.
O 822 é um estojinho simpático branco com duas antenas laterais.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.427
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #14 Online: 02 de Dezembro de 2016, 15:24 »
Mas o chipset não mente: o WN821 tem chipset Realtek; o WN822 tem chipset Atheros (tenho certeza pois eu tenho um).
O único chipset que está aparecendo é o Realket RTL8192CU (nome muito apropriado, diga-se de passagem...) --- só pode ser um WN821.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D