Autor Tópico: mysql 5.7  (Lida 1093 vezes)

Offline jssa

  • Usuário Ubuntu
  • *
  • Mensagens: 48
  • "Seja a mudança que vc quer ver no mundo"Dalailama
    • Ver perfil
mysql 5.7
« Online: 24 de Outubro de 2016, 18:44 »
Boa noite pessoal.

Bom atualizei meu ubuntu para o 16.04, fazem uns 6 meses. Porém, não consigo queo mysql 5.7 seja instalar e configurado. Apresenta erro
root@syncler-laptop:/home/syncler# dpkg --configure -a
Configurando mysql-server-5.7 (5.7.15-0ubuntu0.16.04.1) ...
Renaming removed key_buffer and myisam-recover options (if present)
initctl: Não foi possível conectar ao Upstart: Failed to connect to socket /com/ubuntu/upstart: Conexão recusada
insserv: warning: script 'screen-cleanup' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `screen-cleanup'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `screen-cleanup'
initctl: Não foi possível conectar ao Upstart: Failed to connect to socket /com/ubuntu/upstart: Conexão recusada
insserv: warning: script 'binfmt-support' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `binfmt-support'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `binfmt-support'
Job for mysql.service failed because the control process exited with error code. See "systemctl status mysql.service" and "journalctl -xe" for details.
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: erro ao processar o pacote mysql-server-5.7 (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 1
dpkg: problemas com dependências impedem a configuração de mysql-server:
 mysql-server depende de mysql-server-5.7; porém:
  Pacote mysql-server-5.7 não está configurado ainda.

dpkg: erro ao processar o pacote mysql-server (--configure):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 mysql-server-5.7
 mysql-server


Eu a documentação, eles referenciaram sobre a forma como você está a configurar , se não estiver como root apresenta os erro de socket.(Me avisem se eu estiver errado nessa minha interpretação, até pq meu inglês é péssimo,  e o português tbm rsrs). So que não encontrei um topico nos foruns oficiais que me levasse a uma solução. 

Grato pela atenção de todos.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.324
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:mysql 5.7
« Resposta #1 Online: 24 de Outubro de 2016, 19:15 »
Tem que ser o MySQL mesmo? Não serve o MariaDB?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline jssa

  • Usuário Ubuntu
  • *
  • Mensagens: 48
  • "Seja a mudança que vc quer ver no mundo"Dalailama
    • Ver perfil
Re:mysql 5.7
« Resposta #2 Online: 24 de Outubro de 2016, 21:44 »
Tem que ser o MySQL mesmo? Não serve o MariaDB?


Entao zekkerj,

nunca utilizei o MariaDB. Mas se for igual pode ser. E que nao sei se esse MariaDB, trabalha tão bem com apache e php e phpmydadmin
« Última modificação: 24 de Outubro de 2016, 21:51 por jssa »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.324
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:mysql 5.7
« Resposta #3 Online: 24 de Outubro de 2016, 21:54 »
É um fork do MySQL, então teoricamente qualquer lugar que aceite um aceita o outro.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline jssa

  • Usuário Ubuntu
  • *
  • Mensagens: 48
  • "Seja a mudança que vc quer ver no mundo"Dalailama
    • Ver perfil
Re:mysql 5.7
« Resposta #4 Online: 26 de Outubro de 2016, 16:40 »
É um fork do MySQL, então teoricamente qualquer lugar que aceite um aceita o outro.

grato pela ajuda. Irei testar o MariaDB

PS: Favor me corrigir se estiver errado, ma sesse bug com o mysql ainda não não teve solução correto.
« Última modificação: 27 de Outubro de 2016, 22:17 por jssa »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.324
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:mysql 5.7
« Resposta #5 Online: 26 de Outubro de 2016, 16:50 »
Não testei instalar, não sei dizer como está.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline cviniciusm

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re:mysql 5.7
« Resposta #6 Online: 26 de Outubro de 2016, 20:09 »
Olá,

Se trata do seu servidor de produção então já tentou simular o upgrade em outro servidor ? E tentar corrigir e aprender com isso para fazer no servidor de produção.

É um servidor dedicado ao MySQL? Em caso positivo porque não instala o 16.04.1 LTS e depois o MySQL 5.7. E em seguida faz migração ?

Está ciente das mudanças entre o 16.04 LTS e 14.04 LTS, como utilização do systemd ao invés do upstart e fim do suporte ao LSB, né ?!

Enviado de meu MotoG3-TE usando Tapatalk


Offline jssa

  • Usuário Ubuntu
  • *
  • Mensagens: 48
  • "Seja a mudança que vc quer ver no mundo"Dalailama
    • Ver perfil
Re:mysql 5.7
« Resposta #7 Online: 27 de Outubro de 2016, 22:22 »
Tem que ser o MySQL mesmo? Não serve o MariaDB?

Fala zekker, bão?

cara seguinte tentei instalar tbm o maria DB mas me retorna o mesmo erro que ocorria com o mysql

 seleccionar pacote anteriormente não seleccionado mariadb-server.
A preparar para desempacotar .../mariadb-server_10.0.27-0ubuntu0.16.04.1_all.deb ...
A descompactar mariadb-server (10.0.27-0ubuntu0.16.04.1) ...
A processar 'triggers' para man-db (2.7.5-1) ...
A processar 'triggers' para systemd (229-4ubuntu11) ...
A processar 'triggers' para ureadahead (0.100.0-19) ...
Configurando libdbi-perl (1.634-1build1) ...
Configurando libdbd-mysql-perl (4.033-1ubuntu0.1) ...
Configurando libreadline5:i386 (5.2+dfsg-3build1) ...
Configurando mariadb-client-core-10.0 (10.0.27-0ubuntu0.16.04.1) ...
Configurando mariadb-client-10.0 (10.0.27-0ubuntu0.16.04.1) ...
Configurando mariadb-server-core-10.0 (10.0.27-0ubuntu0.16.04.1) ...
Configurando mariadb-server-10.0 (10.0.27-0ubuntu0.16.04.1) ...
initctl: Não foi possível conectar ao Upstart: Failed to connect to socket /com/ubuntu/upstart: Conexão recusada
insserv: warning: script 'screen-cleanup' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `screen-cleanup'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `screen-cleanup'
initctl: Não foi possível conectar ao Upstart: Failed to connect to socket /com/ubuntu/upstart: Conexão recusada
insserv: warning: script 'binfmt-support' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `binfmt-support'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `binfmt-support'
Configurando mariadb-server (10.0.27-0ubuntu0.16.04.1) ...
A processar 'triggers' para libc-bin (2.23-0ubuntu4) ...
A processar 'triggers' para systemd (229-4ubuntu11) ...
A processar 'triggers' para ureadahead (0.100.0-19) ...
root@syncler-laptop:/home/syncler#


Acho q o problema esta não esta no mysql.
Mas grato pela ajuda ae.
Estou meio intrigado pq eu tinha o o mysql configurado na maquina e após atualizar para o 16.04, fiz todas as configurações  que durante a atualização pede com referencia a senha etc. e após isso começou o problema.

Offline jssa

  • Usuário Ubuntu
  • *
  • Mensagens: 48
  • "Seja a mudança que vc quer ver no mundo"Dalailama
    • Ver perfil
Re:mysql 5.7
« Resposta #8 Online: 28 de Outubro de 2016, 10:35 »
Olá,

Se trata do seu servidor de produção então já tentou simular o upgrade em outro servidor ? E tentar corrigir e aprender com isso para fazer no servidor de produção.

É um servidor dedicado ao MySQL? Em caso positivo porque não instala o 16.04.1 LTS e depois o MySQL 5.7. E em seguida faz migração ?

Está ciente das mudanças entre o 16.04 LTS e 14.04 LTS, como utilização do systemd ao invés do upstart e fim do suporte ao LSB, né ?!

Enviado de meu MotoG3-TE usando Tapatalk

Beleza cviniciusm? entao cara estou tentando resolver faz um mês, e não consigo. Não havia tentado outro servidor ainda. Tenho instalado o mysql para estudo mesmo.
Quando tento instalar qualquer outra coisa, um simples upgrade esta aparecendo erro de que o Upstart nao consegue conectar  ao socket enfim, terei q formatar msm e fazer do zero. Mas vlw mesmo pela dica

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.324
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:mysql 5.7
« Resposta #9 Online: 28 de Outubro de 2016, 11:59 »
Acho que estamos perdendo o ponto vital desse problema. Me parece que precisamos resolver primeiro esse problema com o Upstart.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline jssa

  • Usuário Ubuntu
  • *
  • Mensagens: 48
  • "Seja a mudança que vc quer ver no mundo"Dalailama
    • Ver perfil
Re:mysql 5.7
« Resposta #10 Online: 28 de Outubro de 2016, 15:48 »
Acho que estamos perdendo o ponto vital desse problema. Me parece que precisamos resolver primeiro esse problema com o Upstart.

Hoje irei, sentar e tentar resolver este problema, pois durante a semana é difícil para mim.

Mas se resolver eu aviso vocês

Desde ja agradeço o auxílio de Vocês, vlw msm

Offline jssa

  • Usuário Ubuntu
  • *
  • Mensagens: 48
  • "Seja a mudança que vc quer ver no mundo"Dalailama
    • Ver perfil
Re:mysql 5.7
« Resposta #11 Online: 07 de Dezembro de 2016, 22:52 »
Acho que estamos perdendo o ponto vital desse problema. Me parece que precisamos resolver primeiro esse problema com o Upstart.

Hoje irei, sentar e tentar resolver este problema, pois durante a semana é difícil para mim.

Mas se resolver eu aviso vocês

Desde ja agradeço o auxílio de Vocês, vlw msm

Fala pessoal, tudo bem?

Bom seguinte  acredito ter resolvido o problema do UpStart, mas continuo com problemas ao instalar o mysql ou maria DB

Configurando mysql-server-5.7 (5.7.16-0ubuntu0.16.04.1) ...
mysql stop/waiting
Renaming removed key_buffer and myisam-recover options (if present)
insserv: warning: script 'screen-cleanup' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `screen-cleanup'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `screen-cleanup'
insserv: warning: script 'binfmt-support' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `binfmt-support'
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `binfmt-support'
mysql start/running, process 10107
mysql stop/waiting
mysql start/running, process 10268
mysql_upgrade: Got error: 1524: Plugin 'unix_socket' is not loaded while connecting to the MySQL server
Upgrade process encountered error and will not continue.
mysql_upgrade failed with exit status 11
dpkg: erro ao processar o pacote mysql-server-5.7 (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
 mysql-server-5.7


É um erro de socket, mas não consigo sanar... heheh

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.324
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:mysql 5.7
« Resposta #12 Online: 07 de Dezembro de 2016, 23:21 »
Vc já tentou executar esse comando "mysql_upgrade" em separado?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline jssa

  • Usuário Ubuntu
  • *
  • Mensagens: 48
  • "Seja a mudança que vc quer ver no mundo"Dalailama
    • Ver perfil
Re:mysql 5.7
« Resposta #13 Online: 10 de Dezembro de 2016, 00:18 »
Vc já tentou executar esse comando "mysql_upgrade" em separado?

Ola zekkerj tudo bem

havia feito em outras tentativas antes de postas a primeira vez o problema.  Com o mysql_upgrade apresenta o erro segue abaixo. Estou quase formatando a maquina pra fazer do Zero hahah

Logico q não e solução desejada, pois prefiro tentar sanar

root@syncler-laptop:/home/syncler# mysql_upgrade
mysql_upgrade: Got error: 1524: Plugin 'unix_socket' is not loaded while connecting to the MySQL server

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.324
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:mysql 5.7
« Resposta #14 Online: 10 de Dezembro de 2016, 06:26 »
Experimente jogar essa saída no google, pra ver se vem alguma dica de solução.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D