Autor Tópico: [RESOLVIDO] Fontes/Tema/Ícones desconfigurados ao iniciar sessão  (Lida 2467 vezes)

Offline erico_kl

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
[RESOLVIDO] Fontes/Tema/Ícones desconfigurados ao iniciar sessão
« Online: 18 de Outubro de 2016, 13:49 »
Olá pessoal!

Estou com um bugzinho meio chato, que acontece aleatoriamente.. Ás vezes, quando ligo o note, as fontes do nautilus ficam diferentes do padrão, e noto que não é só no nautilus, mas também na barra superior do ubuntu e nos menus laterais e menus da área de trabalho (clique com o direito do mouse). Alguém já enfrentou esse tipo de problema? A fonte normal deveria ser a da primeira imagem a seguir..

https://s12.postimg.org/lczlx5wnx/nautilus_no_problem.png

https://s13.postimg.org/8vcjuva9z/nautilus.png

-----
Editado pela moderação: imagem maior que o permitido. Regras: http://ubuntuforum-br.org/index.php/topic,43147.0.html
« Última modificação: 18 de Março de 2017, 18:57 por erico_kl »

Offline erico_kl

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
Re:Fontes desconfiguradas no Nautilus
« Resposta #1 Online: 19 de Outubro de 2016, 14:46 »
Notei que não é só a fonte.. mas sim qualquer tema que eu habilite.. Aleatoriamente quando ligo o pc todas as configurações de tema e ícones são perdidas e volta ao tema padrão do ubuntu.. Não consegui descobrir o que pode ser, pq isso ocorre aleatoriamente, ás vezes sobe a interface com os ícones e temas que configurei, e ás vezes sobe como o padrão inicial do ubuntu.. Então acho que o furo é mais embaixo.

Alguém aqui já passou por esse tipo de problema?

Offline erico_kl

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
Re:Fontes desconfiguradas no Nautilus
« Resposta #2 Online: 19 de Outubro de 2016, 15:24 »
Caso ajude, segue abaixo o syslog:

Código: [Selecionar]
Oct 19 14:43:29 erico-note avahi-daemon[626]: Joining mDNS multicast group on interface wlp3s0.IPv6 with address fe80::10d2:4da4:3d96:67b2.
Oct 19 14:43:29 erico-note avahi-daemon[626]: New relevant interface wlp3s0.IPv6 for mDNS.
Oct 19 14:43:29 erico-note avahi-daemon[626]: Registering new address record for fe80::10d2:4da4:3d96:67b2 on wlp3s0.*.
Oct 19 14:43:31 erico-note kernel: [    7.637209] usb 1-1.1: device descriptor read/64, error -110
Oct 19 14:43:31 erico-note NetworkManager[778]: <info>  [1476895411.5527] manager: startup complete
Oct 19 14:43:31 erico-note systemd[1]: Started Network Manager Wait Online.
Oct 19 14:43:31 erico-note systemd[1]: Reached target Network is Online.
Oct 19 14:43:31 erico-note systemd[1]: Starting /etc/rc.local Compatibility...
Oct 19 14:43:31 erico-note systemd[1]: Starting LSB: start Samba daemons for the AD DC...
Oct 19 14:43:31 erico-note systemd[1]: Starting LSB: start Samba NetBIOS nameserver (nmbd)...
Oct 19 14:43:31 erico-note systemd[1]: Started /etc/rc.local Compatibility.
Oct 19 14:43:31 erico-note systemd[1]: Starting Hold until boot process finishes up...
Oct 19 14:43:31 erico-note systemd[1]: Started Hold until boot process finishes up.
Oct 19 14:43:31 erico-note systemd[1]: Starting Set console scheme...
Oct 19 14:43:31 erico-note systemd[1]: Started Getty on tty1.
Oct 19 14:43:31 erico-note systemd[1]: Reached target Login Prompts.
Oct 19 14:43:31 erico-note systemd[1]: Started Set console scheme.
Oct 19 14:43:31 erico-note systemd[1]: Started LSB: start Samba daemons for the AD DC.
Oct 19 14:43:31 erico-note nmbd[1406]:  * Starting NetBIOS name server nmbd
Oct 19 14:43:31 erico-note nmbd[1406]:    ...done.
Oct 19 14:43:31 erico-note systemd[1]: Started LSB: start Samba NetBIOS nameserver (nmbd).
Oct 19 14:43:31 erico-note systemd[1]: Starting LSB: start Samba SMB/CIFS daemon (smbd)...
Oct 19 14:43:31 erico-note smbd[1447]:  * Starting SMB/CIFS daemon smbd
Oct 19 14:43:31 erico-note smbd[1447]:    ...done.
Oct 19 14:43:31 erico-note systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).
Oct 19 14:43:31 erico-note systemd[1]: Reached target Multi-User System.
Oct 19 14:43:31 erico-note systemd[1]: Reached target Graphical Interface.
Oct 19 14:43:31 erico-note systemd[1]: Started Stop ureadahead data collection 45s after completed startup.
Oct 19 14:43:32 erico-note systemd[1]: Starting Notify bootloader that boot was successful...
Oct 19 14:43:32 erico-note systemd[1]: Starting Update UTMP about System Runlevel Changes...
Oct 19 14:43:32 erico-note snap[1465]: Ignoring 'booted' on classic
Oct 19 14:43:32 erico-note systemd[1]: Started Notify bootloader that boot was successful.
Oct 19 14:43:32 erico-note systemd[1]: Started Update UTMP about System Runlevel Changes.
Oct 19 14:43:32 erico-note org.gtk.vfs.Daemon[1069]: A connection to the bus can't be made
Oct 19 14:43:32 erico-note systemd[1]: Created slice User Slice of erico.
Oct 19 14:43:32 erico-note systemd[1]: Starting User Manager for UID 1000...
Oct 19 14:43:32 erico-note systemd[1]: Started Session c2 of user erico.
Oct 19 14:43:32 erico-note systemd[1488]: Reached target Sockets.
Oct 19 14:43:32 erico-note systemd[1488]: Reached target Timers.
Oct 19 14:43:32 erico-note systemd[1488]: Reached target Paths.
Oct 19 14:43:32 erico-note systemd[1488]: Reached target Basic System.
Oct 19 14:43:32 erico-note systemd[1488]: Reached target Default.
Oct 19 14:43:32 erico-note systemd[1488]: Startup finished in 10ms.
Oct 19 14:43:32 erico-note systemd[1]: Started User Manager for UID 1000.
Oct 19 14:43:33 erico-note org.ayatana.bamf[1575]: bamfdaemon start/running, process 1677
Oct 19 14:43:34 erico-note org.a11y.atspi.Registry[1733]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Oct 19 14:43:34 erico-note rtkit-daemon[1164]: Successfully made thread 1812 of process 1812 (n/a) owned by '1000' high priority at nice level -11.
Oct 19 14:43:34 erico-note rtkit-daemon[1164]: Supervising 4 threads of 2 processes of 2 users.
Oct 19 14:43:34 erico-note org.gnome.ScreenSaver[1575]: ** (gnome-screensaver:1800): WARNING **: Couldn't get presence status: The name org.gnome.SessionManager was not provided by any .service files
Oct 19 14:43:34 erico-note gnome-session[1716]: SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
Oct 19 14:43:34 erico-note gnome-session[1716]: SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
Oct 19 14:43:34 erico-note gnome-session[1716]: SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
Oct 19 14:43:34 erico-note rtkit-daemon[1164]: Supervising 4 threads of 2 processes of 2 users.
Oct 19 14:43:34 erico-note rtkit-daemon[1164]: Successfully made thread 1848 of process 1812 (n/a) owned by '1000' RT at priority 5.
Oct 19 14:43:34 erico-note rtkit-daemon[1164]: Supervising 5 threads of 2 processes of 2 users.
Oct 19 14:43:34 erico-note rtkit-daemon[1164]: Supervising 5 threads of 2 processes of 2 users.
Oct 19 14:43:34 erico-note rtkit-daemon[1164]: Successfully made thread 1851 of process 1812 (n/a) owned by '1000' RT at priority 5.
Oct 19 14:43:34 erico-note rtkit-daemon[1164]: Supervising 6 threads of 2 processes of 2 users.
Oct 19 14:43:34 erico-note pulseaudio[1812]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files
Oct 19 14:43:34 erico-note rtkit-daemon[1164]: Successfully made thread 1856 of process 1856 (n/a) owned by '1000' high priority at nice level -11.
Oct 19 14:43:34 erico-note rtkit-daemon[1164]: Supervising 7 threads of 3 processes of 2 users.
Oct 19 14:43:34 erico-note pulseaudio[1856]: [pulseaudio] pid.c: Daemon already running.
Oct 19 14:43:34 erico-note gnome-session[1716]: (process:1865): indicator-application-service-WARNING **: Unable to get watcher name 'org.kde.StatusNotifierWatcher'
Oct 19 14:43:34 erico-note gnome-session[1716]: (process:1865): indicator-application-service-WARNING **: Name Lost
Oct 19 14:43:34 erico-note gnome-session-binary[1716]: Entering running state
Oct 19 14:43:34 erico-note dbus[648]: [system] Activating via systemd: service name='org.freedesktop.UDisks2' unit='udisks2.service'
Oct 19 14:43:34 erico-note systemd[1]: Starting Disk Manager...
Oct 19 14:43:34 erico-note udisksd[1906]: udisks daemon version 2.1.7 starting
Oct 19 14:43:34 erico-note dbus[648]: [system] Successfully activated service 'org.freedesktop.UDisks2'
Oct 19 14:43:34 erico-note systemd[1]: Started Disk Manager.
Oct 19 14:43:34 erico-note udisksd[1906]: Acquired the name org.freedesktop.UDisks2 on the system message bus
Oct 19 14:43:34 erico-note org.gtk.vfs.AfcVolumeMonitor[1575]: Volume monitor alive
Oct 19 14:43:34 erico-note gnome-session[1716]: Starting Dropbox...
Oct 19 14:43:34 erico-note gnome-session[1716]: (gnome-software:1869): Gs-WARNING **: Failed to create permission org.freedesktop.packagekit.trigger-offline-update: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.packagekit.trigger-offline-update is not registered
Oct 19 14:43:34 erico-note gnome-session[1716]: (gnome-software:1869): Gs-WARNING **: Failed to create permission org.freedesktop.packagekit.trigger-offline-update: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.packagekit.trigger-offline-update is not registered
Oct 19 14:43:34 erico-note dbus[648]: [system] Activating service name='org.freedesktop.fwupd' (using servicehelper)
Oct 19 14:43:34 erico-note gnome-session[1716]: Initializing nautilus-dropbox 2015.10.28
Oct 19 14:43:35 erico-note org.gnome.ScreenSaver[1575]: ** Message: Lost the name, shutting down.
Oct 19 14:43:35 erico-note gnome-session[1716]: Dropbox isn't running!
Oct 19 14:43:35 erico-note gnome-session[1716]: Done!
Oct 19 14:43:35 erico-note systemd[1]: Started Daemon for generating UUIDs.
Oct 19 14:43:36 erico-note NetworkManager[778]: <info>  [1476895416.4585] WiFi hardware radio set enabled
Oct 19 14:43:36 erico-note NetworkManager[778]: <info>  [1476895416.4586] WWAN hardware radio set enabled
Oct 19 14:43:41 erico-note kernel: [   18.221356] usb 1-1.1: device not accepting address 5, error -32
Oct 19 14:43:41 erico-note kernel: [   18.293393] usb 1-1.1: new full-speed USB device number 6 using ehci-pci
Oct 19 14:43:41 erico-note kernel: [   18.387646] usb 1-1.1: New USB device found, idVendor=13d3, idProduct=3362
Oct 19 14:43:41 erico-note kernel: [   18.387653] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Oct 19 14:43:41 erico-note kernel: [   18.387656] usb 1-1.1: Product: Bluetooth USB Host Controller
Oct 19 14:43:41 erico-note kernel: [   18.387659] usb 1-1.1: Manufacturer: Atheros Communications
Oct 19 14:43:41 erico-note kernel: [   18.387662] usb 1-1.1: SerialNumber: Alaska Day 2006
Oct 19 14:43:41 erico-note mtp-probe: checking bus 1, device 4: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3"
Oct 19 14:43:41 erico-note kernel: [   18.400476] media: Linux media interface: v0.10
Oct 19 14:43:41 erico-note kernel: [   18.404914] Linux video capture interface: v2.00
Oct 19 14:43:41 erico-note mtp-probe: bus: 1, device: 4 was not an MTP device
Oct 19 14:43:41 erico-note org.freedesktop.fwupd[648]: (fwupd:1994): Fu-WARNING **: Failed to coldplug: UEFI firmware updating not supported
Oct 19 14:43:41 erico-note systemd[1]: Starting Load/Save RF Kill Switch Status...
Oct 19 14:43:41 erico-note kernel: [   18.414100] uvcvideo: Found UVC 1.00 device ASUS USB2.0 Webcam (1bcf:2883)
Oct 19 14:43:41 erico-note kernel: [   18.431868] input: ASUS USB2.0 Webcam as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/input/input18
Oct 19 14:43:41 erico-note kernel: [   18.431994] usbcore: registered new interface driver uvcvideo
Oct 19 14:43:41 erico-note kernel: [   18.431996] USB Video Class driver (1.1.1)
Oct 19 14:43:41 erico-note dbus[648]: [system] Successfully activated service 'org.freedesktop.UPower'
Oct 19 14:43:41 erico-note systemd[1]: Started Daemon for power management.
Oct 19 14:43:41 erico-note dbus[648]: [system] Activating via systemd: service name='org.freedesktop.ColorManager' unit='colord.service'
Oct 19 14:43:41 erico-note systemd[1]: Starting Manage, Install and Generate Color Profiles...
Oct 19 14:43:41 erico-note dbus[648]: [system] Successfully activated service 'org.freedesktop.ColorManager'
Oct 19 14:43:41 erico-note systemd[1]: Started Manage, Install and Generate Color Profiles.
Oct 19 14:43:41 erico-note gnome-session[1716]: /usr/bin/prime-indicator:111: GtkWarning: Não foi possível localizar a ferramenta de temas no module_path: "adwaita",
Oct 19 14:43:41 erico-note gnome-session[1716]:   gtk.main()
Oct 19 14:43:41 erico-note gnome-session[1716]: (clipit:1868): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "adwaita",
Oct 19 14:43:41 erico-note gnome-session[1716]: (clipit:1868): Gtk-WARNING **: Não foi possível localizar a ferramenta de temas no module_path: "adwaita",
Oct 19 14:43:41 erico-note gnome-session[1716]: (nm-applet:1861): GLib-CRITICAL **: g_hash_table_remove_all: assertion 'hash_table != NULL' failed
Oct 19 14:43:41 erico-note gnome-session[1716]: (nm-applet:1861): nm-applet-CRITICAL **: nma_icons_free: assertion 'NM_IS_APPLET (applet)' failed
Oct 19 14:43:42 erico-note dbus[648]: [system] Activating via systemd: service name='org.freedesktop.locale1' unit='dbus-org.freedesktop.locale1.service'
Oct 19 14:43:42 erico-note systemd[1]: Starting Locale Service...
Oct 19 14:43:42 erico-note dbus[648]: [system] Successfully activated service 'org.freedesktop.locale1'
Oct 19 14:43:42 erico-note systemd[1]: Started Locale Service.
Oct 19 14:43:42 erico-note dbus[648]: [system] Successfully activated service 'org.freedesktop.fwupd'
Oct 19 14:43:43 erico-note kernel: [   20.429410] Bluetooth: hci0 command 0x1001 tx timeout
Oct 19 14:43:45 erico-note kernel: [   22.433449] Bluetooth: hci0 command 0x1009 tx timeout
Oct 19 14:43:54 erico-note org.gnome.zeitgeist.Engine[1575]: ** (zeitgeist-datahub:2291): WARNING **: zeitgeist-datahub.vala:229: Unable to get name "org.gnome.zeitgeist.datahub" on the bus!
Oct 19 14:43:55 erico-note org.gtk.vfs.Daemon[1575]: ** (gvfsd:1626): WARNING **: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Falha ao recuperar a lista de compartilhamento do servidor: Conexão recusada
Oct 19 14:43:55 erico-note org.gtk.vfs.Daemon[1575]: ** (process:2220): WARNING **: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: A localização especificada não está montada
Oct 19 14:43:55 erico-note org.gtk.vfs.Daemon[1575]: ** (process:2227): WARNING **: Couldn't create directory monitor on smb://x-gnome-default-workgroup/. Error: Não há suporte à operação pelo backend
Oct 19 14:43:55 erico-note systemd[1]: Time has been changed
Oct 19 14:43:55 erico-note systemd[1055]: Time has been changed
Oct 19 14:43:55 erico-note systemd[1488]: Time has been changed
Oct 19 14:43:55 erico-note systemd-timesyncd[482]: Synchronized to time server 91.189.89.198:123 (ntp.ubuntu.com).
Oct 19 14:43:55 erico-note systemd[1]: apt-daily.timer: Adding 2h 23min 16.983674s random time.
Oct 19 14:43:55 erico-note systemd[1]: snapd.refresh.timer: Adding 3h 31min 26.528323s random time.
Oct 19 14:43:55 erico-note systemd[1]: snapd.refresh.timer: Adding 38min 41.611585s random time.
Oct 19 14:43:55 erico-note systemd[1]: Starting Daily apt activities...
Oct 19 14:44:00 erico-note systemd-udevd[401]: Process '/bin/hciconfig hci0 up' failed with exit code 1.
Oct 19 14:44:00 erico-note systemd[1]: Started Load/Save RF Kill Switch Status.
Oct 19 14:44:00 erico-note systemd[1]: Reached target Bluetooth.
Oct 19 14:44:16 erico-note systemd[1]: Starting Stop ureadahead data collection...
Oct 19 14:44:16 erico-note systemd[1]: Stopped Read required files in advance.
Oct 19 14:44:16 erico-note systemd[1]: Started Stop ureadahead data collection.
Oct 19 14:44:17 erico-note systemd[1]: Started Daily apt activities.
Oct 19 14:44:17 erico-note systemd[1]: apt-daily.timer: Adding 1h 46min 41.574542s random time.
Oct 19 14:44:17 erico-note systemd[1]: Startup finished in 1.667s (kernel) + 53.299s (userspace) = 54.966s.
Oct 19 14:44:17 erico-note systemd[1]: apt-daily.timer: Adding 9h 57min 15.125596s random time.
...

Detalhe: Assim como a interface aleatoriamente sobe desconfigurada, o bluetooth também às vezes não starta, mas enfim, isso já é outra questão.. Obrigado desde já!

Offline erico_kl

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
Re:Fontes desconfiguradas no Nautilus
« Resposta #3 Online: 26 de Outubro de 2016, 20:37 »
Pelo que pude notar, ao aparecer a tela de login, se eu logar muito rápido, o ubuntu sobe desconfigurado, porém se eu esperar um tempo e então logar, aí não ocorre este problema e sobe normal, com os temas e ícones que configurei.. Ou seja, ao que parece tem algum processo sendo carregado em background, que não impede que o login seja feito antes do mesmo terminar..

Alguém já passou por esse tipo de problema? Penso que este processo pode estar relacionado ao compiz, porém entendo pouco dele pra poder fazer qualquer mudança neste sentido. Agradeço qualquer dica/ajuda

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.245
    • Ver perfil
Re:Fontes desconfiguradas no Nautilus
« Resposta #4 Online: 27 de Outubro de 2016, 18:47 »
Talvez tenha adicionado algum pacote como o ttf-mscorefonts-installer (Installer for Microsoft TrueType core fonts), o que poderia estar ocasionando esse problema, eventualmente também alguma característica da gpu.

No seu sistema há duas gpu, Intel e Nvidia, esta última carregada pelo Prime.

O problema ocorre com ambas as gpu?

Veja se esse pacote está instalado:

Código: [Selecionar]
apt-cache policy ttf-mscorefonts-installer
Se estiver, desinstale para avaliar:

Código: [Selecionar]
sudo apt remove ttf-mscorefonts-installer
Reincie e avalie o resultado.

Se isso não foi suficiente, então faça também:

Código: [Selecionar]
fc-cache -f -v
Se ainda não resolveu, experimente:

Código: [Selecionar]
cd /etc/fonts
Código: [Selecionar]
sudo mv fonts.conf fonts.conf-bak
Código: [Selecionar]
fc-cache -f -v
« Última modificação: 27 de Outubro de 2016, 18:50 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline erico_kl

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
Re:Fontes desconfiguradas no Nautilus
« Resposta #5 Online: 27 de Outubro de 2016, 20:37 »
Lembrando q não é apenas na fonte o problema, é todo o tema é tema de ícones q desconfigura eventualmente (quando logo rápido)

De qualquer forma, já tentei mexer com as fontes pelo fc-cache e nao resolveu.. O problema, quando ocorre, é apenas no primeiro login. Tanto q para resolver eu encerro a sessão e logo novamente (tanto faz a placa de vídeo na qual início a sessão pelo prime)..

Parece realmente que algo ainda está carregando quando sobe a tela de login, pois se espero uns 15 segundos pra digitar a senha e iniciar a sessão, tudo sobe normal, mas se não espero esse tempo e informo a senha logo que aparece a tela de login, então a sessão inicia desconfigurada

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.245
    • Ver perfil
Re:Fontes/Tema/Ícones desconfigurados ao iniciar sessão
« Resposta #6 Online: 27 de Outubro de 2016, 22:35 »
Se as alterações anteriores não resolveram então desfaça o que foi feito.

Código: [Selecionar]
cd /etc/fonts
Código: [Selecionar]
sudo mv fonts.conf-bak fonts.conf
Novamente:

Código: [Selecionar]
fc-cache -f -v
Se desinstalou o  ttf-mscorefonts-installer, querendo, reinstale.

Código: [Selecionar]
sudo apt install ttf-mscorefonts-installer
Vamos fazer uma abordagem diferente.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.245
    • Ver perfil
Re:Fontes/Tema/Ícones desconfigurados ao iniciar sessão
« Resposta #7 Online: 27 de Outubro de 2016, 22:56 »
[...] desconfigura eventualmente (quando logo rápido)
Parece realmente que algo ainda está carregando quando sobe a tela de login, pois se espero uns 15 segundos pra digitar a senha e iniciar a sessão, tudo sobe normal, mas se não espero esse tempo e informo a senha logo que aparece a tela de login, então a sessão inicia desconfigurada

Então vamos testar a hipótese da demora no logon e se isso realmente resolve o problema, para isso modifique o sistema para autologin e introduza um atraso.

A razão de testar usando autologin é eliminar a variável de demora pessoal, vamos deixar o sistema fazer tudo de forma automática, o que passa a não depender da sua intervenção pessoal, para assim confirmar ou negar a hipótese. Posteriormente, querendo, pode retornar à forma de logon normal.


Citar
--> Configurações do sistema/Contas de usuários/Opções de início de sessão/Início automático de sessão

Ou então já que vai mesmo editar o arquivo onde isso está configurado, faça lá tudo de uma vez.

Edite o arquivo:

Código: [Selecionar]
sudo gedit /etc/lightdm/lightdm.conf
Altere o autologin alterando a linha:

autologin-user=

Fica algo assim:

Código: [Selecionar]
#autologin-user=
autologin-user=username

Nesse arquivo onde está username acima deve estar o seu nome de usuário concreto, comente a linha existente e crie outra com o username.


Agora altere a linha seguinte introduzindo um tempo em segundos, experimente colocar 5 e vá ajustando para mais e para menos até equilibrar e avalie:

Código: [Selecionar]
autologin-user-timeout=5
Não deixe de testar com um atraso de 1 ou 2 segundos, às vezes resolve.
« Última modificação: 28 de Outubro de 2016, 00:56 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.245
    • Ver perfil
Re:Fontes/Tema/Ícones desconfigurados ao iniciar sessão
« Resposta #8 Online: 27 de Outubro de 2016, 23:07 »
Esqueci de dizer algo importante, a sua versão é a 16.04 que usa o systemd, então não dá para testar fazendo apenas um reboot pois o systemd "aprende" o boot e procura otimizar o tempo total. Tendo feito a alteração é melhor fazer mais 3 (três) reboots (talvez dois, mas 3 é mais certeza) para poder realmente avaliar, em razão dessa otimização automática feita pelo systemd.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline erico_kl

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
Re:Fontes/Tema/Ícones desconfigurados ao iniciar sessão
« Resposta #9 Online: 27 de Outubro de 2016, 23:42 »
Não entendi, você quer testar com ou sem autologin?

Pq tirando o nome do meu usuário não irá fazer login automático, não é? De qualquer forma, estou fazendo os testes aqui deixando um timeout de 5 segundos e autologin pro meu usuário, mas não funcionou, e continua aleatoriamente subindo desconfigurado..

Além disso começou a pedir senha do chaveiro de sessão toda vez agora, talvez por causa do login automático..
« Última modificação: 27 de Outubro de 2016, 23:47 por erico_kl »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.245
    • Ver perfil
Re:Fontes/Tema/Ícones desconfigurados ao iniciar sessão
« Resposta #10 Online: 28 de Outubro de 2016, 00:59 »
Não entendi, você quer testar com ou sem autologin?
Pq tirando o nome do meu usuário não irá fazer login automático, não é? De qualquer forma, estou fazendo os testes aqui deixando um timeout de 5 segundos e autologin pro meu usuário, mas não funcionou, e continua aleatoriamente subindo desconfigurado..
Além disso começou a pedir senha do chaveiro de sessão toda vez agora, talvez por causa do login automático..

Correto, é para testar com o autologin (corrigido confusão sonífera no post original)

Se 5 não deu, aumente para 10, depois para 15, se necessário depois para 20, enfim, faça o ajuste a um ponto onde possa ser demonstrado.

« Última modificação: 28 de Outubro de 2016, 01:12 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.245
    • Ver perfil
Re:Fontes/Tema/Ícones desconfigurados ao iniciar sessão
« Resposta #11 Online: 05 de Novembro de 2016, 15:00 »
Nesse ponto talvez também seja adequado experimentar trocar o gerenciador de login, que no Ubuntu padrão (=Unity) é o lightdm, substituindo pelo gdm.

Entretanto é bom saber que essa é uma mudança bastante significativa e pode ter consequências no sistema, ou seja, adicionar um novo gerenciador de login não é tão trivial e eventualmente pode acontecer ter que reinstalar o sistema.

Se quiser experimentar a forma inicial é essa:

Código: [Selecionar]
sudo apt install gdm
O instalador vai esclarecer que só pode ter um gerenciador de login etc e tal, enfim, escolha o gdm quando aparecer a opção.

Terminada a instalação reinicie a sessão e na tela de logon observe que haverá uma entrada adicional que é o gnome, então suba a nova sessão por ali.

O desktop ficará algo assim:



Uma segunda possibilidade, para se fazer depois, é não apenas substituir o gerenciador de login, mas sim experimentar o próprio Ubuntu-Gnome a partir da iso apropriada, fazendo uma nova isntalação.

http://cdimage.ubuntu.com/ubuntu-gnome/releases/16.04.1/release/

Se tiver uma partição adicional disponível dá para fazer sem apagar ou alterar a atual instalação, pois sempre é possível fazer multiboot.

« Última modificação: 05 de Novembro de 2016, 15:11 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline erico_kl

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
Re:Fontes/Tema/Ícones desconfigurados ao iniciar sessão
« Resposta #12 Online: 05 de Novembro de 2016, 21:55 »
Não deu certo mesmo testando com timeouts mais longos.. É bem aleatório, as vezes desconfigura os temas/ícones, e as vezes sobe normal, com o tema e tema de ícones correto que configurei pelo tweaks..

É estranho isso, pois da pra notar que a sessão inicia, e só então que ela, de alguma forma, "aplica" o tema configurado (da pra notar em frações de segundo, que quando a sessão sobe com o tema correto, primeiro sobe o tema antigo e em frações de segundo depois ela aplica o tema personalizado..). Ah, lembrando que isso vale para qualquer tema, inclusive com o tema padrão (acontecendo as diferenças mostradas no primeiro post aqui).

A dica do gdm eu prefiro deixar, pq antes disso eu já vim de manjaro, kubuntu, elementary os, e aqui no ubuntu foi onde me adaptei melhor (não curto muito o gnome), e o unity realmente está bem estável aqui, com a única exceção desse bug..

Offline erico_kl

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
Re:Fontes/Tema/Ícones desconfigurados ao iniciar sessão
« Resposta #13 Online: 11 de Novembro de 2016, 23:10 »
É bem estranho, mas realmente ta comprovado que se eu esperar uns 10 segundos e então logar o sistema sobe normal, e se logar rapidamente aí sobe desconfigurado

Offline mimarechal

  • Usuário Ubuntu
  • *
  • Mensagens: 53
  • Olá!
    • Ver perfil
Re:Fontes/Tema/Ícones desconfigurados ao iniciar sessão
« Resposta #14 Online: 11 de Dezembro de 2016, 18:50 »
Estou exatamente com o mesmo problema. Desde que troquei o meu HD por um SSD o Ubuntu apresenta este bug esquisito. Realmente, caso espere um pouco ou encerre a sessão, tudo volta a ser como deveria. Andei lendo em uns foruns gringos e parece que esse é um problema ainda sem solução. Você também usa SSD?
Eu sou quem sou, porque somos todos nós