Autor Tópico: Wifi desconecta apenas da internet e não reconecta sem reboot  (Lida 1627 vezes)

Offline massonals

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Wifi desconecta apenas da internet e não reconecta sem reboot
« Online: 07 de Outubro de 2016, 10:07 »
Desde que atualizei pro Ubuntu 16.04 o wifi tem desconectado da internet (e só da internet, pois a rede doméstica parece continuar normal) e depois, pra reconectar, eu sou obrigado a reiniciar ou suspender e religar o notebook. Se eu tento reconectar direto pela barra do sistema, aparece uma mensagem de erro dizendo "a rede foi excluída antes de conectar" ou algo semelhante. Meu pai usa Windows e não tem esse problema com o notebook dele; então, acho que é mesmo algum problema no Ubuntu.

Apesar se achar o problema muito bizarro, não tenho experiência profunda com o Linux nem com redes, então não sei nem por onde começar.

Obrigado pela ajuda. Se mais algum dado for necessário, é só pedir. Abç

Dados do notebook:
Dell Inspiron 1525
Memória 2,9GiB
Processador Intel Core 2 Duo CPU T8100 @ 2.10GHz × 2
Gráficos Intel 965GM
HD 250 GB
Sistema Ubuntu 16.04 LTS 64-bit

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.320
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #1 Online: 07 de Outubro de 2016, 14:15 »
Qual servidor DNS você está usando?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline massonals

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #2 Online: 09 de Outubro de 2016, 21:00 »
zekkerj, desculpe a demora.

Se eu entendi sua pergunta, uso NET Virtual e a configuração IPv4 está como Automático DHCP. Era isso?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.320
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #3 Online: 09 de Outubro de 2016, 21:49 »
Parcialmente. Sua configuração é totalmente automática, certo? Então vc está usando o servidor DNS fornecido pelo DHCP, que normalmente é o próprio modem/roteador.

Assim, um teste a fazer é forçar um servidor DNS. Mude, nas propriedades da conexão, para "Automático (Apenas Endereços)" e forneça o servidor DNS do Google ( 8.8.8.8 ), veja se sua conexão estabiliza.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline massonals

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #4 Online: 15 de Novembro de 2016, 21:25 »
Parcialmente. Sua configuração é totalmente automática, certo? Então vc está usando o servidor DNS fornecido pelo DHCP, que normalmente é o próprio modem/roteador.

Assim, um teste a fazer é forçar um servidor DNS. Mude, nas propriedades da conexão, para "Automático (Apenas Endereços)" e forneça o servidor DNS do Google ( 8.8.8.8 ), veja se sua conexão estabiliza.

Mais uma vez, desculpe. Vestibulares...

Obrigado, mas, infelizmente não funcionou.  Continuo sem reconectar e a receber aquela mensagem de erro de que a conexão foi "excluída antes de conectar". Aliás, percebi que tinha esquecido de comentar que a mensagem de erro vem com o que parece ser um código: (2). Pelo que andei vendo por aí, é um erro relacionado com o wifi. Será que é  um problema de driver?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.320
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #5 Online: 16 de Novembro de 2016, 08:34 »
Pode ser relacionado a driver, sim.
Execute os comandos abaixo e cole o resultado aqui.

sudo lshw -C network
ifconfig -a
iwconfig
nmcli dev wifi
cat /etc/resolv.conf
route -n
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline massonals

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #6 Online: 16 de Novembro de 2016, 17:21 »
sudo lshw -C network
  *-network               
       descrição: Ethernet interface
       produto: 88E8040 PCI-E Fast Ethernet Controller
       fabricante: Marvell Technology Group Ltd.
       ID físico: 0
       informações do barramento: pci@0000:09:00.0
       nome lógico: enp9s0
       versão: 12
       serial: 00:23:ae:e0:2d:ab
       capacidade: 100Mbit/s
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 latency=0 link=no multicast=yes port=twisted pair
       recursos: irq:27 memória:fe8fc000-fe8fffff porta de E/S:de00(tamanho=256)
  *-network
       descrição: Interface sem fio
       produto: PRO/Wireless 3945ABG [Golan] Network Connection
       fabricante: Intel Corporation
       ID físico: 0
       informações do barramento: pci@0000:0b:00.0
       nome lógico: wlp11s0
       versão: 02
       serial: 00:1f:3c:d7:55:f0
       largura: 32 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuração: broadcast=yes driver=iwl3945 driverversion=4.4.0-47-generic firmware=15.32.2.9 ip=192.168.0.11 latency=0 link=yes multicast=yes wireless=IEEE 802.11abg
       recursos: irq:31 memória:fe7ff000-fe7fffff


ifconfig -a
enp9s0    Link encap:Ethernet  Endereço de HW 00:23:ae:e0:2d:ab 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          IRQ:16

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:331 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:331 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1
          RX bytes:32939 (32.9 KB) TX bytes:32939 (32.9 KB)

wlp11s0   Link encap:Ethernet  Endereço de HW 00:1f:3c:d7:55:f0 
          inet end.: 192.168.0.11  Bcast:192.168.0.255  Masc:255.255.255.0
          endereço inet6: fe80::ce9a:f775:afcf:3eba/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:1402 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:1341 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:1164887 (1.1 MB) TX bytes:301972 (301.9 KB)



iwconfig
lo        no wireless extensions.

enp9s0    no wireless extensions.

wlp11s0   IEEE 802.11abg  ESSID:"net_16" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: 6C:B5:6B:16:CE:70   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=61/70  Signal level=-49 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:48   Missed beacon:0


nmcli dev wifi
*  SSID    MODO   CANAL  TAXA       SINAL  BARRAS  SEGURANÇA
*  net_16  Infra  1      54 Mbit/s  45     ▂▄__    WPA1 WPA2
   nick    Infra  1      54 Mbit/s  22     ▂___    WPA1 WPA2


cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.1.1


route -n
Tabela de Roteamento IP do Kernel
Destino            Roteador        MáscaraGen.    Opções   Métrica    Ref   Uso      Iface
0.0.0.0              192.168.0.1     0.0.0.0                 UG             600          0        0          wlp11s0
169.254.0.0     0.0.0.0             255.255.0.0        U               1000        0        0         wlp11s0
192.168.0.0     0.0.0.0             255.255.255.0   U               600          0        0          wlp11s0


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.320
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #7 Online: 29 de Novembro de 2016, 12:04 »
 Rapaz, esqueci completamente deste tópico.  :-[

Qual é a sua situação atual, massonals?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 269
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #8 Online: 29 de Novembro de 2016, 12:17 »
Vou desconectar o adaptador wi-fi e fazer um teste usando cabeado.

Offline maurov

  • Usuário Ubuntu
  • *
  • Mensagens: 269
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #9 Online: 29 de Novembro de 2016, 16:25 »
Na conexão cabeada não cai.

Offline massonals

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #10 Online: 01 de Dezembro de 2016, 13:16 »
Rapaz, esqueci completamente deste tópico.  :-[

Qual é a sua situação atual, massonals?

Sem problemas. Não posso falar nada... rsrs...

Minha atual situação é a seguinte.

Tentei atualizar pro 16.10 pra ver se parava de cair. Além de não resolver o meu problema, não gostei da versão do Yak. Fiz backup e voltei pra versão 16.04.1. Até o momento, não tive mais problemas com o wifi.

Se for útil, posso rodar aqueles testes novamente pra comparar. Fiquei curioso pra saber o que estava acontecendo...

De qualquer modo, muito obrigado pela ajuda.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.320
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #11 Online: 01 de Dezembro de 2016, 15:21 »
Provavelmente durante a reinstalação foi aplicada uma nova configuração limpa. Vamos torcer que continue assim, sem regressões.

Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.320
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #12 Online: 05 de Dezembro de 2016, 14:37 »
Ótimo.
Seu sinal está bem forte (-20dBm, 65/70), com pouca interferência ou erros (invalid misc: 6).
Você consegue navegar normalmente? Ou está intermitente?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline massonals

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #13 Online: 06 de Dezembro de 2016, 07:06 »
Provavelmente durante a reinstalação foi aplicada uma nova configuração limpa. Vamos torcer que continue assim, sem regressões.

Infelizmente, a vaca voltou pro brejo. Ontem, tive duas novas ocorrências do problema. E agora?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 18.320
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Wifi desconecta apenas da internet e não reconecta sem reboot
« Resposta #14 Online: 06 de Dezembro de 2016, 08:11 »
Provavelmente durante a reinstalação foi aplicada uma nova configuração limpa. Vamos torcer que continue assim, sem regressões.

Infelizmente, a vaca voltou pro brejo. Ontem, tive duas novas ocorrências do problema. E agora?
Viu se houve alguma atualização em seu sistema?

PS: Moderadores, é possível separar minha conversa com o @maurov pra outro tópico? Não dá pra acompanhar dois problemas diferentes no mesmo tópico ao mesmo tempo, é questão de tempo até eu recomendar alguma coisa pra um dos dois e outro achar que é pra ele, e piorar um problema.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D