Autor Tópico: Elimine o travamento / kernel panic do Ubuntu 16.04 com gráficos AMD  (Lida 11587 vezes)

Offline Zé Eduardo

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re:Elimine o travamento / kernel panic do Ubuntu 16.04 com gráficos AMD
« Resposta #30 Online: 04 de Maio de 2017, 23:01 »
Pessoal,

Eu estava com os mesmos problemas relatados pelos colegas anteriormente aqui no fórum.
Acontecia com muita frequência de fechar a tampa do notebook e depois quando eu abria a tela não ligava mais e eu tinha que reiniciar tudo a força.
Aparentemente este problema foi resolvido com a mudança do kernel, como "tutoriado" aqui.
Agora, com outros problemas não vi tanta melhora.

Explicando:
Trabalho usando dois monitores, o do próprio PC e um acessório ligado por conexão vga. Quando só o do PC está ligado funciona até bem,  quando o acessório está ligado trava um pouco, e quando os dois estão ligados trava muito.
Percebo os problemas de diversas maneiras, no movimento do cursor do mouse, rolando uma página de fotos da web, abrindo fotos do PC com o visualizador de imagens, abrindo fotos com o GIMP (trava muito esse), até mesmo rolando páginas de um PDF.

Só pra esclarecer, estou me referindo como travar, mas por vezes isso é uma lentidão na resposta.

Gostaria então de saber se isso é problema com o driver da placa de vídeo e se tem como solucionar.

___________________________________

Meu notebook é um Dell inspiron 5448, com processador i5, 4 gb de ram e uma placa de vídeo AMD radeon m265.
Estou usando o Xubuntu 16.04 e acabei de atualizar o kernel pra versão 4.7.10

Agradeço qualquer ajuda

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 360
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Re:Elimine o travamento / kernel panic do Ubuntu 16.04 com gráficos AMD
« Resposta #31 Online: 05 de Maio de 2017, 01:17 »
Pessoal,

Eu estava com os mesmos problemas relatados pelos colegas anteriormente aqui no fórum.
Acontecia com muita frequência de fechar a tampa do notebook e depois quando eu abria a tela não ligava mais e eu tinha que reiniciar tudo a força.
Aparentemente este problema foi resolvido com a mudança do kernel, como "tutoriado" aqui.
Agora, com outros problemas não vi tanta melhora.

Explicando:
Trabalho usando dois monitores, o do próprio PC e um acessório ligado por conexão vga. Quando só o do PC está ligado funciona até bem,  quando o acessório está ligado trava um pouco, e quando os dois estão ligados trava muito.
Percebo os problemas de diversas maneiras, no movimento do cursor do mouse, rolando uma página de fotos da web, abrindo fotos do PC com o visualizador de imagens, abrindo fotos com o GIMP (trava muito esse), até mesmo rolando páginas de um PDF.

Só pra esclarecer, estou me referindo como travar, mas por vezes isso é uma lentidão na resposta.

Gostaria então de saber se isso é problema com o driver da placa de vídeo e se tem como solucionar.

___________________________________

Meu notebook é um Dell inspiron 5448, com processador i5, 4 gb de ram e uma placa de vídeo AMD radeon m265.
Estou usando o Xubuntu 16.04 e acabei de atualizar o kernel pra versão 4.7.10

Agradeço qualquer ajuda

Embora meu notebook seja exatamente o mesmo que o seu, eu não tenho um monitor externo para poder simular o problema que você está vivenciando. De qualquer modo, existem algumas possibilidades para o porquê de isso estar ocorrendo, entre elas:

1) Limitação do driver de vídeo.
2) Excesso de monitores virtuais.
3) Má configuração do servidor Xorg.

Não há muito o que se possa fazer a respeito de 1, exceto talvez atualizar o *Ubuntu para a última versão disponível (17.04) caso ela funcione com novas versões dos drivers de vídeo i915 e amdgpu-pro. Como eu uso XUbuntu 16.04 e não li nada a respeito da versão 17.04, estou completamente "por fora" das novidades trazidas pela versão 17.04, por isto vou seguir para a hipótese 2 e sugerir que você reduza a quantidade de monitores virtuais para algo entre 4 e 2 (caso você esteja com mais de 4 monitores virtuais ativados), pois quando você conecta um monitor externo ao computador o servidor Xorg do seu sistema Linux cria, no monitor externo, a mesma quantidade de monitores virtuais que existem no monitor do seu computador, o que significa que se p.ex. houver 8 monitores virtuais, então quando você conectar o monitor externo seu sistema passará a operar com 16 monitores virtuais, e isso requer bastante poder de processamento gráfico, além de poder "amplificar" um eventual problema de baixo desempenho porventura causado por algum dos drivers de vídeo (item 1).

Se após você reduzir a quantidade de monitores virtuais e reiniciar o computador a lentidão persistir, reduza a quantidade de monitores virtuais para 2 e reinicie novamente o computador.

Caso o problema persista, talvez a hipótese 3 seja a causa. Uma solução que funciona em alguns casos dessa hipótese (não tenho como garantir que funcionará no seu caso) consiste em seguir os seguintes passos:

i) Primeiramente, verifique se você tem o GEdit instalado e, em caso negativo, instale-o com este comando:
Código: [Selecionar]
sudo apt-get install gedit -y
ii) Em seguida, acesse a pasta /etc/X11/xorg.conf.d/ ou então crie-a, caso ela não exista. Um comando que você pode executar no terminal para fazer isso é este:
Código: [Selecionar]
if [ ! -d /etc/X11/xorg.conf.d ]; then sudo mkdir /etc/X11/xorg.conf.d; fi
iii) Uma vez que você tenha o editor de textos GEdit instalado e a pasta /etc/X11/xorg.conf.d exista, verifique se dentro de /etc/X11/xorg.conf.d/ existe algum arquivo cujo nome termine com intel.conf. Em caso afirmativo (se o arquivo existir), esse arquivo deverá ser aberto para edição. Em caso negativo (se o arquivo não existir), ele deverá ser criado com o nome padrão 20-intel.conf. Para fazer essa verificação e já abrir (ou criar e em seguida abrir) o arquivo para edição, execute o seguinte supercomando, no terminal do shell:
Código: [Selecionar]
if [ -f /etc/X11/xorg.conf.d/20-intel.conf ]; then sudo gedit /etc/X11/xorg.conf.d/20-intel.conf; elif [ $(sudo updatedb ; locate -i intel.conf |grep /etc/X11/xorg.conf.d |head -1) = $() ]; then sudo gedit /etc/X11/xorg.conf.d/20-intel.conf; else sudo gedit $(sudo updatedb ; locate -i intel.conf |grep /etc/X11/xorg.conf.d |head -1); fi
iv) Uma vez que o arquivo *-intel.conf esteja aberto no editor GEdit, proceda como segue:
iv-i) Caso o arquivo já possua algum código, adicione o seguinte código antes (acima) da linha EndSection: Option "VSync" "false":
Código: [Selecionar]
Section "Device"
    Identifier  "Intel"
    Driver      "intel"
    Option      "VSync" "false"
EndSection
iv-ii) Caso o arquivo não possua nenhum código (esteja em branco), ou ainda caso a linha EndSection: Option "VSync" "false" não exista dentro do arquivo que já contém algum código, vá até o topo (início) do arquivo e adicione o código mostrado em iv-i.

v) Salve o arquivo (vá em Arquivo e clique em Salvar, ou então use a combinação de teclas Ctrl S), em seguida feche o GEdit e reinicie o computador.

vi) Teste se o problema com o monitor externo continua ocorrendo. Caso o problema persista, execute novamente o supercomando do item iii (para voltar ao arquivo que você havia editado), então adicione as seguintes linhas de código ao início (topo) do arquivo:

Código: [Selecionar]
Option"TripleBuffer" "True"
Option"BackingStore" "True"
Option "PixmapCacheSize" "300000"
Option "OnDemandVBlankInterrupts" "True"
Option "InitialPixmapPlacement" "2"
Option "GlyphCache" "1"

...e daí execute novamente as ações do item v.

Se nada disso resolver, não sei como ajudar. :P
Yuri Sucupira ("Sampayu")