Enquete

Em qual distribuição GNU/Linux você utiliza este tutorial (caso use mais de uma, informe a principal)?

Arch
0 (0%)
Debian
2 (2.6%)
ElementaryOS
0 (0%)
Fedora
1 (1.3%)
Gentoo
0 (0%)
Mint (inclusive LMDE)
6 (7.7%)
OpenSUSE
0 (0%)
*Ubuntu (Ubuntu, XUbuntu, KUbuntu, LUbuntu...)
64 (82.1%)
Outra
2 (2.6%)
Nenhuma. Vim aqui só por curiosidade.
3 (3.8%)

Votos Totais: 76

enquete encerrada: 01 de Junho de 2016, 19:20

Autor Tópico: [Tutorial] Instalação manual do Ambiente de Execução Java (JRE) no *Ubuntu Linux  (Lida 214618 vezes)

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 334
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Re:[Tutorial] Banco do Brasil e plugin Sun Java em vários navegadores do Ubuntu
« Resposta #330 Online: 20 de Março de 2017, 02:18 »
Pessoal,

O Banco do Brasil agora está usando a solução da Diebold (warsaw), como outros bancos já fazem, para segurança bancária.

Como o processo de instalação no linux indicado no site do Banco do Brasil não está funcionando em vários casos, resolvi criar um tópico sobre isso em

http://ubuntuforum-br.org/index.php/topic,121558.msg667951.html

Espero ter ajudado e se souberem mais informações, por favor postem naquele tópico.

Li as instruções que você publicou nesse outro tópico. Infelizmente eu já havia feito tudo o que você citou, e nada funcionou. Continuo com o mesmo problema e o Banco do Brasil não me deu mais retorno.  :( Estou começando a ficar brabo com o pessoal do banco. >:(
Yuri Sucupira ("Sampayu")

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 334
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Como resolver o problema com a instalação do Warsaw do Banco do Brasil
« Resposta #331 Online: 25 de Março de 2017, 23:12 »
Solução para o problema do Warsaw no Banco do Brasil: :D

1) Instalar o Warsaw manualmente; e

2) Em seguida, retirar o bloqueio ao socket / websocket.
Yuri Sucupira ("Sampayu")

Offline nogueira13

  • Usuário Ubuntu
  • *
  • Mensagens: 70
    • Ver perfil
O Tutorial foi modificado radicalmente a partir do item "Verifique se o Procedimento Funcionou". Confesso que prefiria o antigo. Não sei o que fazer a partir da criação do painel de controle do SUN/JAVA. E eu não salvei o procedimento antigo...  ::)  Também fui na pasta /usr/lib/firefox-addons/plugins e não encontrei o /usr/lib/firefox-addons/plugins/sanjava  instalado.  Penso que está faltando alguma coisa para mim.  Não tem como me enviar o procedimento antigo?

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 334
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
O Tutorial foi modificado radicalmente a partir do item "Verifique se o Procedimento Funcionou". Confesso que prefiria o antigo. Não sei o que fazer a partir da criação do painel de controle do SUN/JAVA. E eu não salvei o procedimento antigo...  ::)  Também fui na pasta /usr/lib/firefox-addons/plugins e não encontrei o /usr/lib/firefox-addons/plugins/sanjava  instalado.  Penso que está faltando alguma coisa para mim.  Não tem como me enviar o procedimento antigo?

Eu tirei o restante do tutorial (a parte de criação do link simbólico para o plugin funcionar etc.) porque não funciona mais: os navegadores atuais não dão mais suporte ao plugin Java. Não faz sentido o tutorial ensinar a fazer algo que não vai funcionar com nenhum navegador.

Apesar disso, conforme explico bem lá no finalzinho da seção instalação, eu criei um tutorial ensinando a instalar o Firefox 51 (última versão do Firefox a dar suporte ao plugin Java), e em tal tutorial eu pus um método para fazer o plugin Java funcionar com o Firefox 51.  ;)
Yuri Sucupira ("Sampayu")

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.206
    • Ver perfil
Re:Como resolver o problema com a instalação do Warsaw do Banco do Brasil
« Resposta #334 Online: 12 de Abril de 2017, 15:33 »
Solução para o problema do Warsaw no Banco do Brasil: :D

1) Instalar o Warsaw manualmente; e

2) Em seguida, retirar o bloqueio ao socket / websocket.

Show de bola!

Minha esposa e eu agradecemos! 
Para nós só a primeira parte já resolveu!  Já tem um tempo que fiz isso mas só agora agradeço!

Obrigado!
* Linux Mint 18 Mate 64bits / Windows 10 64bits Casa! * CentOS 7 64bits Servidor de arquivos em modo texto - Casa * MacOS Sierra  - Mac Mini servidor multimidia - Casa * DELL Inspiron 14R + Ubuntu Mate 17.04 64bits.

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 334
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Re:Como resolver o problema com a instalação do Warsaw do Banco do Brasil
« Resposta #335 Online: 12 de Abril de 2017, 16:43 »
Show de bola!

Minha esposa e eu agradecemos! 
Para nós só a primeira parte já resolveu!  Já tem um tempo que fiz isso mas só agora agradeço!

Obrigado!

De nada.  :D
Yuri Sucupira ("Sampayu")

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 334
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Atualização do JRE
« Resposta #336 Online: 20 de Abril de 2017, 01:33 »
A todos os que porventura estejam monitorando este tópico: informo que o Sun Java estável / stable / "oficial" a partir de 18/04/2017 passou a ser o 8u131 (versão 8, atualização 131).

Para atualizar manualmente seu Java que havia sido previamente instalado tal qual este tutorial explica, basta executar este comando de desinstalação:

Código: [Selecionar]
sudo rm -rf /opt/java
...e em seguida executar os passos da seção 1 do tutorial, que já está atualizada. :)
Yuri Sucupira ("Sampayu")

Offline Milton Canabrava

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Infelizmente, as novas versões do Firefox, navegador padrão do Ubuntu, não suportam o plugin Java.

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 334
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Infelizmente, as novas versões do Firefox, navegador padrão do Ubuntu, não suportam o plugin Java.

Não mesmo.

Para usar o plugin Java, é necessário instalar o Firefox 51 em paralelo com o Firefox atual.
Yuri Sucupira ("Sampayu")

Offline alevian

  • Usuário Ubuntu
  • *
  • Mensagens: 256
    • Ver perfil
Nossa Sampayu! Que triste notícia.

Eu bem que percebi, em um Ubuntu que usava, simplesmente deixou de funcionar o BB.
(curiosamente declarei o IR, que usa java, salvo engano).

Depois, tinha um Trisquel, rodando no BB normalmente, porque tava sem atualização (falta de espaço no root).

Ontem, apaguei uns kerneis pelo Synaptic e atualizei todo o sistema - mais de 300Mb.

Foi só religar o sistema e o BB parou de funcionar.

Fiquei instalando e desinstalando java, icedtea.
Mas então o caso é esse?

Não funciona mais depois da versão 51 do FF?

Mas não seria inseguro continuar com uma versão desatualizada?

Os caras conseguiram resolver a questão do warsaw? Tá fácil de instalar?

Grato!
Linux User 586375

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 334
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Nossa Sampayu! Que triste notícia.

Eu bem que percebi, em um Ubuntu que usava, simplesmente deixou de funcionar o BB.
(curiosamente declarei o IR, que usa java, salvo engano).

Depois, tinha um Trisquel, rodando no BB normalmente, porque tava sem atualização (falta de espaço no root).

Ontem, apaguei uns kerneis pelo Synaptic e atualizei todo o sistema - mais de 300Mb.

Foi só religar o sistema e o BB parou de funcionar.

Fiquei instalando e desinstalando java, icedtea.
Mas então o caso é esse?

Não funciona mais depois da versão 51 do FF?

Mas não seria inseguro continuar com uma versão desatualizada?

Os caras conseguiram resolver a questão do warsaw? Tá fácil de instalar?

Grato!

Pois é, acabou mesmo o suporte ao plugin Java. Eu não acho uma boa usar o navegador Firefox 51 para insistir no Java, até porque eventualmente o JRE se tornará incompatível com o Firefox 51 (pela própria evolução natural do JRE), além da questão da segurança mesmo (navegador desatualizado). Fiz um tutorial explicando como instalar o Firefox 51 em paralelo com o Firefox atual, mas fiz isso apenas para atender a quem faz questão de usar Firefox com plugin Java.

O correto e ideal mesmo é usar apenas o navegador atualizado, abandonar o plugin Java e instalar o Warsaw. Os links que pus lá na introdução do tutorial explicam direitinho como instalar o Warsaw, e regra geral tem dado certo. A instalação do Warsaw explicada pelo banco é mais simples, mas tem uns problemas. A instalação manual do Warsaw é mais complicada, mas eu pus lá os comandos todos, então é só executar que funciona.
Yuri Sucupira ("Sampayu")

Offline alevian

  • Usuário Ubuntu
  • *
  • Mensagens: 256
    • Ver perfil
Mestre,

Enfim voltei a acessar o BB, agora com o tal do warsal.
(pena que não podemos fugir de mais um programinha proprietário)

Fui pela receita de bolo do Edivaldo: http://www.edivaldobrito.com.br/modulo-de-seguranca-do-banco-do-brasil-no-linux/

Em um dos passos é mencionado que, se precisar de dependências deve ser usado um comando...

Pois eu precisei.

Na verdade, nem me lembro bem a sequecia.. sei que tinha um outro processo aberto, tive que reinicializar, pois não identificava com o top.
Depois apareceu a bolinha vermelha com um tracinho branco no meio, no canto superior mencionando a falta das tais dependências
Em uma parte da instalação pede para fechar o Firefox.

Enfim, fui tentando e deu certo, mas eu nem saberia reconstruir o passo a passo, dada minha debilidade.

De todo modo, como warsaw instalado acho que ficou mais simples.

Vamos ver o que ocorre quando atualizar o kernel.

Outra coisa que li em algum lugar é que o bicho é chato pra desinstalar.
Recomendam até por numa máquina virtual.
Foi o que fiz, por precaução.

Abraços!
Linux User 586375

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 334
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Mestre,

Enfim voltei a acessar o BB, agora com o tal do warsal.
(pena que não podemos fugir de mais um programinha proprietário)

Fui pela receita de bolo do Edivaldo: http://www.edivaldobrito.com.br/modulo-de-seguranca-do-banco-do-brasil-no-linux/

Em um dos passos é mencionado que, se precisar de dependências deve ser usado um comando...

Pois eu precisei.

Na verdade, nem me lembro bem a sequecia.. sei que tinha um outro processo aberto, tive que reinicializar, pois não identificava com o top.
Depois apareceu a bolinha vermelha com um tracinho branco no meio, no canto superior mencionando a falta das tais dependências
Em uma parte da instalação pede para fechar o Firefox.

Enfim, fui tentando e deu certo, mas eu nem saberia reconstruir o passo a passo, dada minha debilidade.

De todo modo, como warsaw instalado acho que ficou mais simples.

Vamos ver o que ocorre quando atualizar o kernel.

Outra coisa que li em algum lugar é que o bicho é chato pra desinstalar.
Recomendam até por numa máquina virtual.
Foi o que fiz, por precaução.

Abraços!

Fico feliz por saber que está conseguindo usar, mas não confie tanto nessa história de máquina virtual: as máquinas virtuais também têm brechas de segurança, e nas máquinas virtuais geralmente acabamos sendo mais desleixados com a segurança (justamente por acreditarmos nessa falsa sensação de "impenetrabilidade" da máquina virtual).

Bom, de qualquer modo isso é outra discussão. O importante é que você está conseguindo usar o Warsaw. Missão cumprida. :D
Yuri Sucupira ("Sampayu")