Recent Posts

Páginas: 1 ... 8 9 [10]
91
Instalação e Atualização / Problemas com dependências
« Última Mensagem: por Anastácio Online 17 de Setembro de 2017, 22:25 »
Alguém pode me ajudar a resolver esse problema de atualização?


 apt-get update
Atingido:1 http://br.archive.ubuntu.com/ubuntu xenial InRelease
Ign:2 http://dl.google.com/linux/deb stable InRelease                         
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                   
Atingido:4 http://security.ubuntu.com/ubuntu xenial-security InRelease         
Atingido:5 http://dl.google.com/linux/deb stable Release                       
Atingido:6 http://archive.canonical.com/ubuntu wily InRelease                 
Ign:7 http://liveusb.info/multisystem/depot all InRelease                     
Atingido:8 http://dl.google.com/linux/chrome/deb stable Release               
Ign:9 http://repo.vivaldi.com/stable/deb stable InRelease                     
Atingido:11 http://liveusb.info/multisystem/depot all Release                 
Atingido:12 http://repo.vivaldi.com/stable/deb stable Release                 
Atingido:16 http://ppa.launchpad.net/flexiondotorg/hal-flash/ubuntu xenial InRelease
Atingido:17 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu xenial InRelease
Atingido:18 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial InRelease
Atingido:19 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu wily InRelease
Atingido:20 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease
Atingido:21 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu xenial InRelease
Atingido:22 http://ppa.launchpad.net/webupd8team/tor-browser/ubuntu xenial InRelease
Lendo listas de pacotes... Pronto
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-pt_BR) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-pt) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target DEP-11 (main/dep11/Components-i386.yml) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/deb stable InRelease' doesn't support architecture 'i386'
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/chrome/deb stable InRelease' doesn't support architecture 'i386'
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-pt_BR) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-pt) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target DEP-11 (main/dep11/Components-i386.yml) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37

 apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Você pode querer executar 'apt-get -f install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
 adwaita-icon-theme : Depende: libgtk-3-bin mas não está instalado
E: Dependências desencontradas. Tente usar -f.

 apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
The following additional packages will be installed:
  libgtk-3-bin
Os NOVOS pacotes a seguir serão instalados:
  libgtk-3-bin
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
8 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/55,3 kB de arquivos.
Depois desta operação, 282 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n]

s

(Lendo banco de dados ... 22486 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libgtk-3-bin_3.18.9-1ubuntu3_i386.deb ...
A acrescentar 'desvio de /usr/sbin/update-icon-caches para /usr/sbin/update-icon-caches.gtk2 por libgtk-3-bin'
dpkg-divert: erro: renomear envolve sobrescrever '/usr/sbin/update-icon-caches.gtk2' com
  arquivo diferente '/usr/sbin/update-icon-caches', não permitido
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libgtk-3-bin_3.18.9-1ubuntu3_i386.deb (--unpack):
 sub-processo novo script pre-installation retornou estado de saída de erro 2
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/libgtk-3-bin_3.18.9-1ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
92
Iniciantes / Problemas com dependências
« Última Mensagem: por Anastácio Online 17 de Setembro de 2017, 22:09 »
 apt-get update
Atingido:1 http://br.archive.ubuntu.com/ubuntu xenial InRelease
Ign:2 http://dl.google.com/linux/deb stable InRelease                         
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                   
Atingido:4 http://security.ubuntu.com/ubuntu xenial-security InRelease         
Atingido:5 http://dl.google.com/linux/deb stable Release                       
Atingido:6 http://archive.canonical.com/ubuntu wily InRelease                 
Ign:7 http://liveusb.info/multisystem/depot all InRelease                     
Atingido:8 http://dl.google.com/linux/chrome/deb stable Release               
Ign:9 http://repo.vivaldi.com/stable/deb stable InRelease                     
Atingido:11 http://liveusb.info/multisystem/depot all Release                 
Atingido:12 http://repo.vivaldi.com/stable/deb stable Release                 
Atingido:16 http://ppa.launchpad.net/flexiondotorg/hal-flash/ubuntu xenial InRelease
Atingido:17 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu xenial InRelease
Atingido:18 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial InRelease
Atingido:19 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu wily InRelease
Atingido:20 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease
Atingido:21 http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu xenial InRelease
Atingido:22 http://ppa.launchpad.net/webupd8team/tor-browser/ubuntu xenial InRelease
Lendo listas de pacotes... Pronto
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-pt_BR) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-pt) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target DEP-11 (main/dep11/Components-i386.yml) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/deb stable InRelease' doesn't support architecture 'i386'
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/chrome/deb stable InRelease' doesn't support architecture 'i386'
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-pt_BR) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-pt) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target DEP-11 (main/dep11/Components-i386.yml) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
W: Target DEP-11-icons (main/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:28 and /etc/apt/sources.list:37
root@#######/home/anastacio# apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Você pode querer executar 'apt-get -f install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
 adwaita-icon-theme : Depende: libgtk-3-bin mas não está instalado
E: Dependências desencontradas. Tente usar -f.
root@########:/home/anastacio# apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
The following additional packages will be installed:
  libgtk-3-bin
Os NOVOS pacotes a seguir serão instalados:
  libgtk-3-bin
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
8 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/55,3 kB de arquivos.
Depois desta operação, 282 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
(Lendo banco de dados ... 22486 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libgtk-3-bin_3.18.9-1ubuntu3_i386.deb ...
A acrescentar 'desvio de /usr/sbin/update-icon-caches para /usr/sbin/update-icon-caches.gtk2 por libgtk-3-bin'
dpkg-divert: erro: renomear envolve sobrescrever '/usr/sbin/update-icon-caches.gtk2' com
  arquivo diferente '/usr/sbin/update-icon-caches', não permitido
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libgtk-3-bin_3.18.9-1ubuntu3_i386.deb (--unpack):
 sub-processo novo script pre-installation retornou estado de saída de erro 2
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/libgtk-3-bin_3.18.9-1ubuntu3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
93
Internet, Redes e Segurança / Re:Segurança do servidor e da rede
« Última Mensagem: por rwarstat Online 17 de Setembro de 2017, 20:35 »
Talvez não tenha me expressado bem, todas as máquinas estão ligas em um switch que está ligado no roteador/modem.
94
Internet, Redes e Segurança / Re:Segurança do servidor e da rede
« Última Mensagem: por zekkerj Online 17 de Setembro de 2017, 20:22 »
Um switch??? Tem certeza? não há algum roteador fazendo NAT no caminho???
95
Sistema / Re:Erro na instalação do wps ubuntu 17.04
« Última Mensagem: por druidaobelix Online 17 de Setembro de 2017, 20:19 »
Bem, é uma solução meia estranha mas funcionou.
Por enquanto, até achar algo melhor, faça dessa forma, baixe o pacote faltante diretamente e instale:

Código: [Selecionar]
cd ~/Downloads
Código: [Selecionar]
wget -c http://mirrors.kernel.org/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1_amd64.deb
Código: [Selecionar]
sudo dpkg -i libpng12-0_1.2.54-1ubuntu1_amd64.deb
Depois como normalmente se instala o wps, fazendo:

Código: [Selecionar]
sudo dpkg -i wps-office_10.1.0.5707~a21_amd64.deb

A solução verdadeira é usar o Ubuntu 16.04 Xenial, que é uma versão LTS, que possui de forma nativa a biblioteca faltante.
O Ubuntu 17.04 Zesty, como se sabe, é uma versão transitória, serve apenas para testes e não para produção.
De toda forma, experimente como indicado acima para ver se o wps se mantém estável dessa forma.
96
Sistema / Re:Erro na instalação do wps ubuntu 17.04
« Última Mensagem: por druidaobelix Online 17 de Setembro de 2017, 20:06 »
Êpa, a biblioteca libpng12-0 não está nos repositórios do Ubuntu 17.04 Zesty.  >:(

ubuntu@ubuntu:~$ apt-cache policy libpng12-0
libpng12-0:
  Installed: (none)
  Candidate: (none)
  Version table:
ubuntu@ubuntu:~$

Consegui reproduzir o erro aqui.

Vamos ver agora como corrigir isso.


97
Sistema / Re:Erro na instalação do wps ubuntu 17.04
« Última Mensagem: por druidaobelix Online 17 de Setembro de 2017, 19:52 »
wps-office depende de libpng12-0; porém:
  Pacote libpng12-0 não está instalado.

Quando faz:

Código: [Selecionar]
sudo apt install libpng12-0
o que acontece?

Editando (19:57):

Instalei aqui e foi liso, sem nenhum problema, porém só agora vi que aí você está usando o Ubuntu 17.04 Zesty, quando aqui estava testando na 16.04 Xenial.
Vou testar no Ubuntu 17.04 Zesty também, já que tenho baixado o .deb do wps nessa mesma versão que a sua.

Vou reiniciar para poder subir o Ubuntu 17.04.
98
Sistema / Erro na instalação do wps ubuntu 17.04
« Última Mensagem: por Gabriel Fernando Online 17 de Setembro de 2017, 19:35 »
Alguem pode me ajudar a instalar wps, esta dando o erro de dependencia ja dei um sudo install - f e e ele remove  o wps de uma vez, ou seja eu instalo mas ele n abre pq esta com esse erro:
sudo dpkg -i wps-office_10.1.0.5707~a21_amd64.deb
[sudo] senha para gabriel:
A seleccionar pacote anteriormente não seleccionado wps-office.
(Lendo banco de dados ... 374045 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar wps-office_10.1.0.5707~a21_amd64.deb ...
A descompactar wps-office (10.1.0.5707~a21) ...
dpkg: problemas com dependências impedem a configuração de wps-office:
 wps-office depende de libpng12-0; porém:
  Pacote libpng12-0 não está instalado.

dpkg: erro ao processar o pacote wps-office (--install):
 problemas de dependência - deixando desconfigurado
A processar 'triggers' para bamfdaemon (0.5.3+17.04.20170406-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
A processar 'triggers' para gnome-menus (3.13.3-6ubuntu5) ...
A processar 'triggers' para desktop-file-utils (0.23-1ubuntu2) ...
A processar 'triggers' para mime-support (3.60ubuntu1) ...
A processar 'triggers' para shared-mime-info (1.8-1) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
A processar 'triggers' para hicolor-icon-theme (0.15-1) ...
Erros foram encontrados durante o processamento de:
 wps-office


99
Aplicativos / Re:converter sites para pdf
« Última Mensagem: por druidaobelix Online 17 de Setembro de 2017, 18:50 »
Salva o site em imprimir e inves de imprimir vc coloca pdf

De fato, usar Ctrl p para imprimir dependendo do site pode ser um ótima opção (e as vezes a única).
100
Programação e Scripts / Re:Como achar o script de runlevel no ubuntu para edita - lo?
« Última Mensagem: por druidaobelix Online 17 de Setembro de 2017, 18:47 »
vi algumas fontes ensinado como mudar o runlevel no debian por exemplo , editando " inittab " mas nao tem no ubuntu e em outras fontes dizia q o ubuntu nao ultiliza mais o inittab

De fato, editar env DEFAULT_RUNLEVEL= no arquivo /etc/init/rc-sysinit.conf não funciona mais, isso valia para o upstart, não mais para o systemd

Mostrar runlevel atual ainda basta fazer no terminal:

Código: [Selecionar]
runlevel
Igualmente ainda vai funcionar se fizer:

Código: [Selecionar]
telinit N
onde N é o runlevel que se queira:

telinit 1 irá levar ao prompt que nada mais é que o prompt do Recovery Mode.

Também ainda funciona se editar:

Código: [Selecionar]
gksudo gedit /etc/default/grub
alterando a linha:

Citar
GRUB_CMDLINE_LINUX=""

colocando entre as aspas o suposto runlevel que se queira, como exemplo:

GRUB_CMDLINE_LINUX="1"

em seguida atualizando o grub fazendo:

Código: [Selecionar]
sudo update-grub
novamente irá levar ao prompt do Recovery Mode.

Porém de uma forma mais atual runlevel é exposto através de "targets units', pelo que deverá ser feito:

Código: [Selecionar]
sudo systemctl isolate runlevelN.target
one o N novamente é o runlevel desejado, como no exemplo:

sudo systemctl isolate runlevel1.target

Note, entretanto, que essa ideia de runlevel está obsoleta, não faz mais sentido no império do systemd, além do que é absolutamente inútil para qualquer finalidade realmente prática.

Num desktop comum não faz sentido levar o sistema para um runlevel 1 ou 3.
Qual a finalidade disso? Qual a razão para fazer uma coisa dessa?

Por outro lado, num servidor faz menos sentido ainda.
O modo seguro de fazer se não quer que determinado serviço seja oferecido é não habilitar o serviço, pois serviço inexistente não pode ser vazado.

Em todo caso, no systemd quando se quer atingir:

Código: [Selecionar]
sudo systemctl isolate runlevel5.target
então se faz na nova concepção:

Código: [Selecionar]
sudo systemctl isolate graphical.target
Veja uma lista fazendo:

Código: [Selecionar]
systemctl list-units --type=target
Páginas: 1 ... 8 9 [10]