Fórum Ubuntu Linux - PT
17 de Setembro de 2014, 02:28 *
Olá, Visitante. Faça o login ou registre-se.
Perdeu o seu e-mail de ativação?

Login com nome de usuário, senha e duração da sessão
Notícias: Informações da última versão: Ubuntu Linux 14.04 - Trusty Tahr
 
   Home   Ajuda Regras Pesquisa Login Registre-se  
Anúncios
Páginas: [1]   Ir para o fundo
  Imprimir  
Autor Tópico: [Resolvido] Não estou conseguindo instalar o Java no Ubuntu 10.04 LTS  (Lida 12230 vezes)
dezt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 17


Dezt - Escape From This World!


Ver Perfil WWW
« em: 01 de Maio de 2010, 14:09 »

Olá, após instalar o Ubuntu 10.04, não estou mais conseguindo instalar o plugin ou o runtime do Java, utilizo Java Plugin para acessar páginas que utilizam o plugin e utilizo o Java Runtime para abrir um aplicativo chamado jDownloader, que utiliza Java.

Visto que sempre consegui utiliza Java normalmente no Ubuntu 9.10, estranhei que em um sistema mais atualizado, o erro ocorra.

OBS: Seguindo uma dica que usava um tal de fakeroot, eu até consegui instalar o Java, apareceu no diretório, etc.

Mas sempre dava erro na hora de abrir qualquer aplicativo *.jar, seguindo a dica para criar um link na pasta plugins do Firefox para o plugin do Java (seguindo tutorial), também não obtive sucesso, o plugin foi até indicado, mas ao abrir o Firefox, continuei sem o plugin.

Gostaria de saber se algum de vocês já conseguiram resolver tal problema no Ubuntu 10.04 LTS.

Atenciosamente,

Reinaldo C. Filho
« Última modificação: 02 de Maio de 2010, 13:26 por dezt » Registrado

Hqxriven
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 1.439



Ver Perfil
« Responder #1 em: 01 de Maio de 2010, 14:13 »

Acrescenta no source list

deb http://archive.canonical.com/ubuntu lucid partner

E dá um sudo aptitude update e depois tenta instalar...
Registrado

Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois
dezt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 17


Dezt - Escape From This World!


Ver Perfil WWW
« Responder #2 em: 01 de Maio de 2010, 14:39 »

Opa, estou fazendo aqui, por precaução, estou baixando novamente para instalar. Piscada

Na realidade, eu sou iniciante no Linux, mas fuçando no Google, descobri como editar a sources.list (está correto, né?), adicionei a linha que foi passada por ti, dei o "sudo aptitude update", agora vamos ver se dá certo, obrigado pela rápida resposta. Piscada

Mas ainda estou no aguardo do término do download para testar. Contente

Jajá eu posto.
Registrado

dezt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 17


Dezt - Escape From This World!


Ver Perfil WWW
« Responder #3 em: 01 de Maio de 2010, 14:59 »

Bom, consegui fazer o Java RunTime rodar normalmente, apesar que ele bloqueou o jDownloader por não o achar confiável.

Mas ainda não consegui fazer o Mozilla Firefox 3.6.3 reconhecer o plugin do Java, já realizei o comando que o tutorial que está localizado aqui: http://pt.kioskea.net/faq/2333-firefox-plugin-java-jre-da-sun .

O tutorial diz na parte que você deve vincular o Firefox ao plugin assim:

Código:
ln -s /usr/java/jre1.5.0_04/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla-firefox-1.0.2/plugins/

Bom, eu fiz exatamente isso (claro que seguindo a minha estrutura de diretórios, no meu caso, usei esse comando:

Código:
sudo ln -s /usr/lib/jvm/java-6-sun-1.6.0.20/jre/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/mozilla/plugins/

Alguém aí tem uma luz?

Abraços.
Registrado

dezt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 17


Dezt - Escape From This World!


Ver Perfil WWW
« Responder #4 em: 01 de Maio de 2010, 15:12 »

Ah, consegui aqui, foi só desinstalar tudo que era relacionado ao Java que já vinha instalado no Gerenciador de Pacotes Synaptic e instalar novamente.

O grande problema é que o jDownloader ainda não está funcionando, ele aparece a seguinte mensagem quando tenta ser aberto igual eu fazia no Ubuntu 9.10.

The file '/home/reinaldocfilho/Download/JDownloader/JDownloader.jar' is not marked as executable.  If this was downloaded or copied form an untrusted source, it may be dangerous to run.  For more details, read about the executable bit.
Registrado

alarcon
Visitante
« Responder #5 em: 01 de Maio de 2010, 15:29 »

O java da Sun eu instalei assim

No Synaptic ativei o repositório partner e pelo terminal digitei:

sudo apt-get update

para atualizar o banco de dados do instalador.

Ainda pelo terminal instalei o java assim:

sudo apt-get -y install sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin

durante o processo de instalação aparecerá um tela para que vc confirme o termo de uso e etc. Este comando acima instala o java da Sun somente o básico se quiser mais que o jre procure e instale o resto.

Depois e caso vc tenha instalado outro java tipo o openjdk, ainda no terminal digite:

sudo update-alternatives --config java

para configurar o java que vai ser usado.

irá aparecer algo semelhante a isso:

Citar
Existem 3 alternativas que fornecem `java'.

  Seleção      Alternativa
-----------------------------------------------
          1    /usr/bin/cacao
*         2    /usr/lib/jvm/java-6-sun/jre/bin/java
 +        3    /usr/lib/jvm/java-6-openjdk/jre/bin/java

Pressione enter para manter o padrão

    * ou digite o número da seleção:

caso tenha mais de um java instalado ok, aí é só digitar o número correto, que no caso acima seria o 2


Quem instala o pacote Ubuntu-restricted-extras (ou um nome parecido com esse) vai instalar o openjdk e o icedtea que antigamente causavam problemas com alguns sites que precisam do java tipo o Banco do Brasil. Não sei se isso já foi corrigido, mas a solução anteriormente era desinstalar eles (o openjdk e o icedtea, principalmente este último) e instalar o java da Sun conforme falei acima.

« Última modificação: 01 de Maio de 2010, 15:35 por alarcon » Registrado
dezt
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 17


Dezt - Escape From This World!


Ver Perfil WWW
« Responder #6 em: 01 de Maio de 2010, 15:58 »

Então, como no post acima eu já havia dito, consegui resolver o problema daquela maneira, mas a sua dica deve ser a mais recomendada para quem quer instalar pela primeira vez.

OBS: O problema em relação ao jDownloader, só para deixar claro, consegui resolver usando uma dica encontrada neste site: http://www.ubuntudicas.com.br/blog/?p=2739

O comando é:

Código:
1 sudo add-apt-repository ppa:jd-team/jdownloader
2 sudo aptitude update
3 sudo apt-get install jdownloader

Isso simplesmente salvou meu dia. Contente

Estava quase voltando para o Ubuntu 9.10 ou Windows 7.

Abraços.

OBS: Quando será que a Propellerheads vai lançar o Reason para Linux, sendo que ele roda no MAC numa boa, eu notei uma incrível semelhança no Ubuntu e o MAC OSX.
Registrado

groove
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 441



Ver Perfil
« Responder #7 em: 03 de Maio de 2010, 00:35 »

Estou com o mesmo problema, não consigo criar o link para o plugin do ff...
acho que o java está instalado corretamente:
Código:
java -version
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01, mixed mode)

Tentei instalar o plugin pelo synaptic(sun-java6-plugin) porém sem sucesso..

Entrei com o comando:
Código:
sudo update-alternatives --list mozilla-javaplugin.so
/usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so
Acredito ser esse o arquivo que tenho que linkar, certo? Pois bem , linkei para a pasta ~/.mozilla/plugins/ e nada =//
Registrado

jbcn
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 5


Ver Perfil
« Responder #8 em: 03 de Maio de 2010, 01:06 »

Depois de atualizar para o Ubuntu 10.04, também não conseguia mais acessar, via Firefox, os sites que exigiam plugin java. Para resolver esse problema, realizei os seguintes procedimentos:

1. Desinstalei, via Synaptic, o pacote sun-java6-bin e sun-java6-jre;

2. Instalei, via Synaptic, os pacotes:
* default-jre
* icedtea-6-jre-cacao
* icedtea6-plugin
* libaccess-bridge-java
* libaccess-bridge-java-jni
* openjdk-6-jre
* openjdk-6-jre-lib.

João Nunes
Registrado
livre1
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 650


Ver Perfil
« Responder #9 em: 03 de Maio de 2010, 04:09 »

Depois de atualizar para o Ubuntu 10.04, também não conseguia mais acessar, via Firefox, os sites que exigiam plugin java. Para resolver esse problema, realizei os seguintes procedimentos:

1. Desinstalei, via Synaptic, o pacote sun-java6-bin e sun-java6-jre;

2. Instalei, via Synaptic, os pacotes:
* default-jre
* icedtea-6-jre-cacao
* icedtea6-plugin
* libaccess-bridge-java
* libaccess-bridge-java-jni
* openjdk-6-jre
* openjdk-6-jre-lib.

João Nunes



Amigo se não estou enganado, com estes pacotes não é possivel usar o site do banco do Brasil, eu não sei se é verdade é o que eu li por ai.



Eu vou tentar instalar estes pacotes, porque instalar o Java da Sun tá dificil no 9.10...
Registrado
groove
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 441



Ver Perfil
« Responder #10 em: 04 de Maio de 2010, 19:15 »

Acredito que o problema esteja na versão do Firefox e não na distruibuição, pois só tive estes problemas depois que atualizei meu FF para versão 3.x.x.
Se alguém souber como linkar o java pro FF, por favor me ajude. Obrigado.
Registrado

jbcn
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 5


Ver Perfil
« Responder #11 em: 05 de Maio de 2010, 00:01 »

Groove,

Veja as orientações em http://plugindoc.mozdev.org/linux.html#Java.

Boa sorte!
Registrado
DannSCCP
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 2


Ver Perfil
« Responder #12 em: 14 de Junho de 2010, 23:50 »

Então, como no post acima eu já havia dito, consegui resolver o problema daquela maneira, mas a sua dica deve ser a mais recomendada para quem quer instalar pela primeira vez.

OBS: O problema em relação ao jDownloader, só para deixar claro, consegui resolver usando uma dica encontrada neste site: http://www.ubuntudicas.com.br/blog/?p=2739

O comando é:

Código:
1 sudo add-apt-repository ppa:jd-team/jdownloader
2 sudo aptitude update
3 sudo apt-get install jdownloader

Isso simplesmente salvou meu dia. Contente

Estava quase voltando para o Ubuntu 9.10 ou Windows 7.

Abraços.

OBS: Quando será que a Propellerheads vai lançar o Reason para Linux, sendo que ele roda no MAC numa boa, eu notei uma incrível semelhança no Ubuntu e o MAC OSX.

Muitooooo boa essa dica para instalação do Jdownloader.

Eu já tinha tentado de várias maneiras e não tinha conseguido, aí com apenas 3 comandos ficou tudo beleza!! Contente
Registrado
Páginas: [1]   Ir para o topo
  Imprimir  
 
Ir para:  

Powered by MySQL Powered by PHP Tema desenvolvido por FaBMak e n3t0
Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines
© 2014 Canonical Ltd. Ubuntu e Canonical são marcas registradas da Canonical Ltd.
XHTML 1.0 válido! CSS válido!