Autor Tópico: [Resolvido]Wine não instala no Precise AMD64  (Lida 6003 vezes)

Offline kkrico

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
[Resolvido]Wine não instala no Precise AMD64
« Online: 30 de Agosto de 2012, 00:56 »
Ola pessoal, meu nome é Daniel e estou com o seguinte problema: O wine não instala no meu precise amd 64.

Quando adiciona a PPA, dou update e rodo "sudo apt-get install wine" retorna:

Código: [Selecionar]
Os pacotes a seguir têm dependências desencontradas:
 wine : Depende: wine1.5 mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Se eu rodo "sudo apt-get install wine1.5" retorna:

Código: [Selecionar]
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 wine1.5 : Depende: wine1.5-i386 (= 1.5.11-0ubuntu1)
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Se eu rodo "sudo apt-get install wine1.5-i386" ele retorna:

Código: [Selecionar]
Os pacotes a seguir têm dependências desencontradas:
 wine1.5-i386:i386 : Depende: libgphoto2-2:i386 (>= 2.4.10.1) mas não será instalado
                     Recomenda: gettext:i386 mas não será instalado
                     Recomenda: libcups2:i386 mas não será instalado
                     Recomenda: libfontconfig1:i386 mas não será instalado ou
                                libfontconfig:i386
                     Recomenda: libsane:i386 mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Estranho é que vou no Synaptic em busca destes pacotes mas todos estão instalados. Tentei usar o comando "sudo apt-get install ia32-libs libc6-i386" para ver se preenchia as dependências e nada. :P

Ps:O synaptic não acha pacotes quebrados '-'

Se alguém souber algo para me ajudar ficarei muito grato :D
« Última modificação: 31 de Agosto de 2012, 20:24 por kkrico »

Willder

  • Visitante
Re: Wine não instala no Precise AMD64
« Resposta #1 Online: 30 de Agosto de 2012, 01:14 »
Olá Daniel seja bem vindo ao fórum!  :D

Bem você é novo aqui mas parece não ser tão novo no mundo Ubuntu por já está mostrando um pouco de conhecimento, então vou fazer uma pergunta um pouco boba: você tentou instalar a versão da Central de Programas?

Eu instalei a versão 1.5 do Wine que você está tentando instalar pelo Terminal e não me dei muito bem, ela não rodava os programas bem como a versão 1.4 rodava (a que está na Central de Programas), lembre-se que ela ainda está em desenvolvimento e portanto pode ser instável.

Então, acho que pode não ser útil para resolver o problema mas fica a dica.

Boa sorte e Boa noite!

Offline mori solutions

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Wine não instala no Precise AMD64
« Resposta #2 Online: 30 de Agosto de 2012, 10:47 »
Bom dia, não sei se o problema já foi resolvido, mas no meu dá o mesmo erro, tentei instalar pela central de programas e nada também.

rodei o apt-get -f install, autoremove, formatei de novo com nova imagem para isolar possibilidade de corrompimento da iso e nada... se tiverem alguma idéia de como resolver agradeço...

Offline kkrico

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Wine não instala no Precise AMD64
« Resposta #3 Online: 30 de Agosto de 2012, 11:19 »
Bom dia a todos e obrigado por responder. Tentei sim instalar tanto o wine 1.4 quanto o 1.5 pelo central de programas e recebo o seguinte erro



Enfim, deu uma pesquisa no askubuntu e vi que é um bug conhecido(já documentado inclusive) que gettext, mas que, infelizmente para mim não funcionou. Sinceramente nao sei o que fazer  :-[

http://askubuntu.com/questions/181156/why-im-not-able-to-install-wine-on-x64

Tente usar a solução do link acima para ver se funciona

Willder

  • Visitante
Re: Wine não instala no Precise AMD64
« Resposta #4 Online: 30 de Agosto de 2012, 21:30 »
Aqui eu uso a versão 1.4 x64 sem problemas, então deixo para alguém mais experiente, não sei como resolver... :(

Offline Donald Francis

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
Re: Wine não instala no Precise AMD64
« Resposta #5 Online: 30 de Agosto de 2012, 22:15 »
Eu tive esse mesmo problema, não só com o wine, mas também com o playOnlinux (bom esse é um frontend para o wine) e problemas com o Skype. Sempre - todos eles- citavam problemas de dependência tanto pela CP como pelo terminal e pelo Synaptic. O que eu só pude perceber foi que (não sei se é o teu caso) Mas com a iso do Ubuntu 12.04 64-bits Eu conseguia instalar tudo que citei sem problemas, mas com a iso 12.04.1 64-bits, dava esses problemas. Não foi problemas da iso, isso eu sei, mas pra mim, pareceu ter algo com a versão do Ubuntu entre a 12.04 e a 12.04.1 (essa foi lançada uns dias atrás.) Não sei se alguém teve problemas com essas duas versões e não sei se foi realmente isso, mas só instalou assim com a 12.04.
Lembre-se disso 24/7:Você é livre!

Offline kkrico

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Wine não instala no Precise AMD64
« Resposta #6 Online: 31 de Agosto de 2012, 11:19 »
Primeiramente obrigado a todos que responderam. Observei a iso que usei e vi que era uma ISO 12.04.1. Vou buscar uma Iso 12.04 e testar. A noite trago os resultados.

Ps.: Nesse meio tempo, usei a versão 32bits, funcionou lindamente  ;D

Offline haereticus

  • Usuário Ubuntu
  • *
  • Mensagens: 976
  • Xubuntu 12.04.2 x64
    • Ver perfil
Re: Wine não instala no Precise AMD64
« Resposta #7 Online: 31 de Agosto de 2012, 11:30 »
Esta versão lançada a poucos dias do 12.04.1 creio que gerou incompatibilidade com alguns programas.
Notebook: Samsung 305E4A-BD1 - AMD A6-3420M (Quad Core) @2.4GHz - Radeon™ 6520G 512MB - 8GB - HD 500GB - 14” LED HD - HDMI - Bluetooth - Webcam 1.3 HD - Base CoolerMaster Notepal Ergostand - Mouse X7 Oscar 750bk 3200dpi.

Sony Xperia L - Android 4.1.2

Offline kkrico

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Wine não instala no Precise AMD64
« Resposta #8 Online: 31 de Agosto de 2012, 20:23 »
Olá pessoal, fiz baixei uma ISO 12.04 e instalou o WIne perfeitamente. Obrigado a todos que ajudaram  ;D

Offline rpazza

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: [Resolvido]Wine não instala no Precise AMD64
« Resposta #9 Online: 01 de Setembro de 2012, 23:10 »
Estou exatamente com o mesmo problema. Pelo Tweak a versão da minha distribuição é 12.04 precision. É a 12.04.1?

Offline Donald Francis

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
Re: [Resolvido]Wine não instala no Precise AMD64
« Resposta #10 Online: 02 de Setembro de 2012, 11:08 »
Estou exatamente com o mesmo problema. Pelo Tweak a versão da minha distribuição é 12.04 precision. É a 12.04.1?

Se você baixou esses dias, deve ser a 12.04.1.
É que a 12.04.1 é a imagem mais recente do disco com as atualizações já inclusas. A 12.04 recebe as atualizações e fica do mesmo jeito. (se não me engano) Ambas são Ubuntu 12.04 LTS. Só difere a .iso que vem com correções de bugs e a outra, 12.04, que tem que atualizar para corrigir os bugs. Qualquer coisa se eu estiver enganado, alguém me corrija. Muita gente está tendo problemas mesmo com essa .iso mais recente. Se alguém baixou essa iso 12.04.1 e não teve problema não sei dizer, pois não vi alguém citar nada até agora. Eu tenho a 12.04 e a 12.04.1 e só a primeira eu consegui fazer a instalação desses programas. Eu atualizei o sistema todo e depois eu instalei os programas normalmente. Mas com a 12.04.1 nem atualizando resolveu.
Lembre-se disso 24/7:Você é livre!

Offline Diego Rodrigues

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [Resolvido]Wine não instala no Precise AMD64
« Resposta #11 Online: 04 de Setembro de 2012, 01:20 »
Ola Donald Francis, eu foi um que pegou uma dessas .iso mais recente, a minha de x64, tive também o mesmo problema, mais consegui resolver, para resolver o problema, é semelhante ao que faziamos no Ubuntu 10.10 quando algum programa não queria instalar. Eu fiz o seguinte, depois de várias horas de procura, não achei nada que pudesse me ajudar, fiz o seguinte, instalei o "Gerenciador de Atualizações Synaptic" depois digitei a senha de usuário, em seguida cliquei em Configurações > Repositórios

Na janela que abrirá na primeira aba estará escrito: "Aplicativos Ubuntu" logo abaixo estará "Baixar de: Servidor Brasil" você clica em cima de "Servidor Brasil" vai ter duas opções "Servidor - Brasil e Servidor Principal" você clica em "Servidor Principal" ... depois você clica na outra aba "Outro software" você marca "Parceiros da Canonical" NÃO marque a opção "Parceiros da Canonical (Código Fonte)"... depois feche a janela!

Volte para a janela principal do Synaptic e clique em Recarregar e aguarde! Depois do processo ter terminado, você vai na central de programas do Ubuntu e instala o Wine! pronto agora você pode disfrutar do Wine plenamente!

Boa Noite e tenha um ótimo dia! Espero ter ajudado!

Offline mori solutions

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: [Resolvido]Wine não instala no Precise AMD64
« Resposta #12 Online: 04 de Setembro de 2012, 14:42 »
Desculpe a demora, mas conseguí instalar o wine, quando procuro a versão do S.O. me fala que é apenas 12.04, no entanto foi baixada recentemente, então deve ser a 12.04.1.
Com relação ao erro do wine, removí todas as bibliotecas referentes a ele pelo synaptic, em seguida reinstalei td do zero, rodou blz...
Só não conseguí resolver o problema do skype, tentando iniciar pelo terminal dá o erro:

romeu@Mori-Notebook:~$ skype
Falha de segmentação (imagem do núcleo gravada)
romeu@Mori-Notebook:~$

O processo descrito acima foi feito para o skype, resolução imediata, mas reiniciou cabô, já era skype, só repetindo o processo.
Ainda não achei a solução pra ele, se alguém tiver...

Offline Donald Francis

  • Usuário Ubuntu
  • *
  • Mensagens: 47
    • Ver perfil
Re: [Resolvido]Wine não instala no Precise AMD64
« Resposta #13 Online: 07 de Setembro de 2012, 16:06 »
Ola Donald Francis, eu foi um que pegou uma dessas .iso mais recente, a minha de x64, tive também o mesmo problema, mais consegui resolver, para resolver o problema, é semelhante ao que faziamos no Ubuntu 10.10 quando algum programa não queria instalar. Eu fiz o seguinte, depois de várias horas de procura, não achei nada que pudesse me ajudar, fiz o seguinte, instalei o "Gerenciador de Atualizações Synaptic" depois digitei a senha de usuário, em seguida cliquei em Configurações > Repositórios

Na janela que abrirá na primeira aba estará escrito: "Aplicativos Ubuntu" logo abaixo estará "Baixar de: Servidor Brasil" você clica em cima de "Servidor Brasil" vai ter duas opções "Servidor - Brasil e Servidor Principal" você clica em "Servidor Principal" ... depois você clica na outra aba "Outro software" você marca "Parceiros da Canonical" NÃO marque a opção "Parceiros da Canonical (Código Fonte)"... depois feche a janela!

Volte para a janela principal do Synaptic e clique em Recarregar e aguarde! Depois do processo ter terminado, você vai na central de programas do Ubuntu e instala o Wine! pronto agora você pode disfrutar do Wine plenamente!

Boa Noite e tenha um ótimo dia! Espero ter ajudado!

Muito boa a dica!  :D
Lembre-se disso 24/7:Você é livre!