Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 634863 vezes)

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #615 Online: 03 de Abril de 2008, 00:54 »
Olá Alarcon. Estou aqui de volta mais uma vez para sanar minhas dúvidas sobre os seu pacotes para usar internet (graças à uma formatação não planejada, cá estou eu de volta à estaca zero...)

Eu baixei os 2 pacotes seus, o v22 e o v21.

O primeiro eu instalei de cara, mas sem sucesso (lá dentro vi que inha até um ícone com um x indicando sua impossibilidade para eu usá-lo).

Com isso, tentei instalar o v21 (que no passado era o que eu usava, e funcionava bem).
A boa notícia é que eu consegui realizar a conexão ! Reparei que agora há um ícone que faz aquela janelinha de "Conectando..." minimizar, como vc explicou aqui...

O problema é que... está MUUITO lento (no monitor do sistema, o gráfico da rede mostra uma pequena montanha-russa, pois fica oscilando entre "enviar um pouquinho" e "idle (parado) " ).

Queria saber de você se há alguma coisa que eu possa fazer para melhorar esta situação (ou se terei que formatar o linux para remover seus pacotes e assim poder reinstalar o v21 direto...), considerando que :

1) Desconfio da rede da minha região (morava em uma área metropolitana, agora moro no interior do estado - telefone chegou aqui há mais ou menos 1 mês, pra você ter uma idéia...). Bom, no momento estou postando pelo windows, a velocidade aqui indica 50,6 Kbps discada, e quando eu usava a net meus 2 Sistemas conectavam a uma velocidade bem parecida ( linux parecia bemmais rápido na hora de baixar alguma coisa...)

2) Ao ter instalado o v22 (sem sucesso) percebi que quando tentava reconectar não dava sinal de vida, então teria que dar um restart nele pelo terminal. Para resolver esse probleminha segui algumas instruções, criei uns arquivos e copiei algumas coisas pra eles (que agora não lembro, tenho que caçar depois este "tutorial"), mas não adiantou...
Falei isso porque instalei o v21 logo depois do v22, então não sei se eles se mesclaram, ou se um sobrepôs o outro por completo, ou sei lá mais o quê.

Queria saber se você me dá uma ajuda quanto a isso. Caso não tenha como conseguir realizar uma conexão boa, existe alguma maneira de conseguir arranjar algum dvd do ubuntu que tenha os aplicativos e programas necessários (Amarok, plugins, Compiz Manager, Emerald, enfim...) para eu poder desfrutar do ubuntu e largar mais do windows ?

Agradeço desde já pela ajuda, (tanto agora quanto antes, com os pacotes).



alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #616 Online: 03 de Abril de 2008, 10:02 »
Caro Shakmatton o pacote v22 pelo que ando observando está problemático para alguns usuários, mas para aqueles no qual ele funciona, pelo que me foi relatado, estão achando até bem melhor (mais rápido e estável) que os outros pacotes.

Qual é o seu tipo de modem?

Deve ser por que este driver mais novo, deve ter algum problema com alguns tipos de modem que ele dá suporte. Só penso que seja isso.

De qualquer forma já vi no site http://linmodems.technion.ac.il/packages/smartlink/ dois novos drivers Smartlink depois deste que é usado no v22. Não sei se eles foram criados para o novo kernel que virá no próximo Ubuntu ou se serve também para o kernel usado no Ubuntu 7.10 Gutsy.

Com relação a reinstalar você deveria fazer assim, ir na pasta criada do pacote que você usou por ultimo (pelo terminal) e ou seja:

cd /home/SEU_USUARIO/modem-arquivos-v2?

e depois executar estes comandos (dentro da pasta e ainda pelo terminal ok):

sudo /etc/init.d/sl-modem-daemon stop

sudo dpkg -r sl-modem-daemon

sudo make uninstall

make clean

e depois é só usar o pacote que deseja instalar novamente.

Quanto e velocidade baixa isso é complicado de afirmar o que possa estar acontecendo, mas na configuração do gnome-ppp no processo de instalação do meu pacote ele pergunta por qual Init2 ele deve usar então teste cada uma das alternativas que tem lá para ver qual é a melhor para o seu caso. Para fazer isso basta rodar novamente o script de instalação e na janela que mostra vários itens selecionados deixar marcada apenas o que cuida da configuração do gnome-ppp (a ultima opção - Dialup "Dialup configuration for gnome-ppp") ou pelo terminal assim:

Abra um terminal em Aplicações > Acessórios > Terminal e digite:

gedit .wvdial.conf

no arquivo que abrir procure pela linha:

Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

mude para:

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0

ou

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2 +MS=34

ou

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=90

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #617 Online: 03 de Abril de 2008, 17:28 »
É, vou tentar isso depois... Vou tirar o v21 e o v22 (não sei se dá pra fazer isso, ou se na primeira limpeza ele tirará tudo...)

E quanto à velocidade foi como no meu post anterior, no windows conecta relativamente bem (para uma conexão discada).
Imagino que deva ser a princípio o fato de ter instalado os 2 de uma vez, um após o outro direto. Nunca mexi no Init quando conectava antigamente (com o pacote v21 instalado).

Porém em outra máquina que tem aqui em casa (máquina esta que possui outro tipo de modem), conecto com o ubuntu e percebo que há uma certa dificuldade para conectar/navegar. Enfim, vou verificar e depois posto o resultado.

Obrigado.

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #618 Online: 12 de Abril de 2008, 22:49 »
Olá Alarcon.
Estou tendo problemas para resolver minha conexão linux. Ao tentar conseguir o seu pacote v21, só consigo baixar uma parte, e ele termina, aí quando vou verificar pelo winrar o que acontece, ele dá uma mensagem de "Erro: final inesperado de arquivo".

Será que vc poderia disponibilizar um link onde eu pudesse baixar o v21 sem problemas, em toda sua totalidade ?

Não sei se o ero reside aí, ou se tenho que usar outra ferramenta de download. Está muito difícil resolver esse problema, mesmo que tivesse aqui o v21, teria que instalá-lo via cd (ou há uma maneira que não dependa dele ?), e pra isso teria que comprar um drive de dvd novo, pois o meu agora cismou que não quer ler nada (embora seja detectado aqui na minha máquina, por ambos os sistemas operacionais...).

Estou começando a desconfiar que a velocidade de conexão pode ter a ver com um possível "desgaste" de meu modem motorola.
Mas se fosse assim, eu conseguiria postar pelo ubuntu do mesmo modo que estou fazendo agora, no windows (numa velocidade sofrível, mas ainda civilizada...)

Obrigado desde já...

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #619 Online: 12 de Abril de 2008, 23:18 »
Olá Alarcon.
Estou tendo problemas para resolver minha conexão linux. Ao tentar conseguir o seu pacote v21, só consigo baixar uma parte, e ele termina, aí quando vou verificar pelo winrar o que acontece, ele dá uma mensagem de "Erro: final inesperado de arquivo".

Será que vc poderia disponibilizar um link onde eu pudesse baixar o v21 sem problemas, em toda sua totalidade ?

Não sei se o ero reside aí, ou se tenho que usar outra ferramenta de download. Está muito difícil resolver esse problema, mesmo que tivesse aqui o v21, teria que instalá-lo via cd (ou há uma maneira que não dependa dele ?), e pra isso teria que comprar um drive de dvd novo, pois o meu agora cismou que não quer ler nada (embora seja detectado aqui na minha máquina, por ambos os sistemas operacionais...).

Estou começando a desconfiar que a velocidade de conexão pode ter a ver com um possível "desgaste" de meu modem motorola.
Mas se fosse assim, eu conseguiria postar pelo ubuntu do mesmo modo que estou fazendo agora, no windows (numa velocidade sofrível, mas ainda civilizada...)

Obrigado desde já...

Tenta baixar o v21 deste link aqui:
http://www.4shared.com/file/43918111/545dad65/modem-arquivos-v21tar.html?dirPwdVerified=33e0a9ae

Não entendi o que você falou quanto ao CD?

Se você está baixando pelo windows e quer levar para o Ubuntu, se é para o mesmo PC que está em dual boot, basta no linux montar a partição do windows, se já não estiver, e então copiar da partição win para linux o arquivo v21 sem a necessidade de transportar por alguma mídia em particular.
« Última modificação: 12 de Abril de 2008, 23:28 por alarcon »

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #620 Online: 13 de Abril de 2008, 11:02 »
Só tava falando que meu drive de dvd deu problema (ele não lê mais nada), pois pra instalar seu pacote, em algum momento ele pede que vc insira o cd do ubuntu...

quanto ao resto ,  tudo tranquilo. V ou ver se baixo aqui o v21... se não conseguir, posto de novo...

Obrigado.

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #621 Online: 13 de Abril de 2008, 11:16 »
Só tava falando que meu drive de dvd deu problema (ele não lê mais nada), pois pra instalar seu pacote, em algum momento ele pede que vc insira o cd do ubuntu...

quanto ao resto ,  tudo tranquilo. V ou ver se baixo aqui o v21... se não conseguir, posto de novo...

Obrigado.

Seu driver de DVD não funciona nem no Windows?

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #622 Online: 14 de Abril de 2008, 19:04 »
Isso mesmo, ele é detectado em ambos os SOs, mas na hora de ler, nada...

Porém, uma coisa meio bizarra aconteceu nesse sábado...
Estava eu usando a net discada no windows, e de vez em quando eu sempre dou uma tentativa com o linux... isso porque no windows tava até boa a conexão (que como falei não andava tão bem, estava desconfiado de tudo mesmo, desiludido , enfim...) .

Foi então que na segunda tentativa sob ubuntu, consegui uma conexão de média 3,1 kB/s , suficiente para navegar (ainda ruinzinho, mas já um pouco civbilizado para internet discada...) e baixar alguns pacotes... fiquei de tocaia o resto da tarde, consegui baIXAR emerald, compiz, suporte a mp3 e wma, e comecei a baixar atualizações do sistema...

Porém, como manda a lei de Murphy, alguma coisa por menor que seja, tem que dar errado...

Percebi que um processo (o compiz.real) estava executando meio que como um câncer, comendo muita memória do meu computador. Pra vc ter uma idéia, o computador de meu irmão tem basicamente a mesma configuração e mesmo tamanho e tipo de memória (512 mega), e no visualizador de desempenho lá (onde vc vê os gráficos de rede, de processador e memória), no dele tem o memso processo usando 20 e poucos mega, enquanto que no meu às vezes tá 33, 60 90 e pouco, chegou a mais de 100, isso vc usando os recursos do compiz, porém ao finalizar por exemplo uma girada de cubo, este processo não retorna ao normal, ou seja, não diminui... Isso acontece lentamente (a diminuição) mas não como deveria, eu sei que o meu tem emerald, mas antes de formatar meu computador, eu usava as mesmíssimas coisas (e muito mais) e dificilmente passava de 70 % de uso, agora tá quase toda usada, usando bastante memória virtual...

Isso tá muito detalhado, vou postar em lugar mais apropriado, mas é só pra vc ter uma idéia mesmo...

Esse negócio da internet "voltar dos mortos" ainda está sobre observação (eu andei testando mudar o buraco do plug de uma porta do modem pra outra, nem sei se foi isso... ), mas se voltar a não conectar, continuo com o problema (ainda preciso comprar um gravador de dvd novo)...

E baixei seu v21 numa boa, obrigado...

Offline FranciscoLima

  • Usuário Ubuntu
  • *
  • Mensagens: 24
  • Usando o Ubuntu 10.04
    • Ver perfil
    • linuxnomicro.blogspot.com
Slmodem funcionando no Ubuntu 8.04 e Kurumin NG
« Resposta #623 Online: 18 de Abril de 2008, 22:49 »
Alarcon, não sei se você já ficou sabendo, mas saiu um novo driver slmodem agora em abril.
Eu havia tentado usar seu pacote do Ubuntu 7.10 no 8.04 beta, mas o driver não compilava, como já havia sido mencionado por outros.
Mas com o driver novo, a compilação ocorreu sem problemas,
inclusive, estou conectado neste momento com ele,
está normal.
Assim que sair a versão final faço o teste novamente.

PS: Acabei de testar no Kurumin NG e também funcionou

Até mais...
FranciscoLima
« Última modificação: 19 de Abril de 2008, 01:32 por FranciscoLima »

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #624 Online: 19 de Abril de 2008, 01:12 »
Talvez só consiga resolver meus problemas quando c hegar o novo ubuntu... hehe

alarcon

  • Visitante
Re: Slmodem funcionando no Ubuntu 8.04 e Kurumin NG
« Resposta #625 Online: 19 de Abril de 2008, 13:33 »
Alarcon, não sei se você já ficou sabendo, mas saiu um novo driver slmodem agora em abril.
Eu havia tentado usar seu pacote do Ubuntu 7.10 no 8.04 beta, mas o driver não compilava, como já havia sido mencionado por outros.
Mas com o driver novo, a compilação ocorreu sem problemas,
inclusive, estou conectado neste momento com ele,
está normal.
Assim que sair a versão final faço o teste novamente.

PS: Acabei de testar no Kurumin NG e também funcionou

Até mais...
FranciscoLima


Sabia sim e inclusive fiz referência a este novo driver no segundo texto desta página ("...De qualquer forma já vi no site http://linmodems.technion.ac.il/packages/smartlink/ dois novos drivers Smartlink depois deste que é usado no v22. Não sei se eles foram criados para o novo kernel que virá no próximo Ubuntu ou se serve também para o kernel usado no Ubuntu 7.10 Gutsy...") e estava esperando apenas sair o novo ubuntu para colocar um novo pacote, mas é que tive problemas no meu PC (por causa do windows) e fiquei sem nenhum sistema operacional, perdendo tudo que estava no PC e que ainda estava sem backup.

Tinha até já começado com o pacote só esperando colocar possíveis pacotes .deb caso necessário.
« Última modificação: 19 de Abril de 2008, 14:13 por alarcon »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #626 Online: 19 de Abril de 2008, 18:57 »
Novo pacote para instalação do Ubuntu 8.04 Hardy Heron e Kubuntu 8.04 Hardy Heron


Bem resolvi adicionar no pacote de instalação um script para que usuários do Kubuntu 8.04 Hardy Heron possam fazer seu modem funcionar com este pacote também.

A forma de instalação é praticamente a mesma dos pacotes anteriores só que agora ao invés de existir o script chamado de install-modem.sh, passou a existir dois scripts chamados de install-modem_Gnome e install-modem_Kde que são para instalar o modem para o Ubuntu e Kubuntu respectivamente.

OBS1: O arquivo em .pdf ainda só fala sobre a forma de instalação do Ubuntu e do script install-modem.sh, mais não mudou nada não, só a forma que as janelas gráficas se apresentam para você. Leiam também o arquivo texto chamado de Leia-me.

OBS2: Não testei o script para o Kubuntu, por que não tenho nenhuma distro baseada no KDE aqui, portanto preciso de voluntários para testar.

Segue abaixo o link do pacote modem-arquivos-v23.tar.gz:

http://prdownloads.sourceforge.net/projeto-messias/modem-arquivos-v23.tar.gz?download


OBS3: Aos que pretendem usar o pacote modem-arquivos-v23.tar.gz com o Kubuntu 8.04 Hardy Heron, antes faça o seguinte procedimento:

Abra um terminal, acho que no kubuntu deve ser K > Sistema > konsole, e digite:

kwrite

se abrir ok. Agora digite:

sudo kwrite

se não abrir, com o terminal aberto,  como usuário comum, faça isso:

xhost local:root

Caso ocorra algum erro então antes do comando instale o pacote sux. Veja se ele se encontra no seu LiveCD tentando instalar assim:

sudo apt-get install sux

isso se o LiveCD estive adicionado no sources.lst do apt-get. Para fazer isso abra um terminal e digite:

sudo apt-cdrom add

irá aparecer uma informação do tipo:

Citar
Usando ponto de montagem de CD-ROm /cdrom/
Desmontando CD-ROM
Aguardando por disco ...
Por favor, insira um Disco no leitor e pressione enter

Se o LiveCD do Kubuntu 8.040 estiver já no driver de CD-Rom basta teclar ENTER, caso contrário coloque-o no driver para depois teclar ENTER.

Caso não esteja adicionado no sources.list ou não queira fazer isso, baixe daqui:

http://mirrors.kernel.org/ubuntu/pool/universe/s/sux/sux_1.0.1-3.2_all.deb

instale, veja se é preciso alguma dependência extra, e repita o passo:

xhost local:root

para ver se agora funciona e siga em frente nos outros passos.

OBS4: caso o pacote sux precise de alguma dependência não instalada no seu Kubuntu 8.04 procure aqui:

http://packages.ubuntu.com/hardy/allpackages

OBS5: Para o caso do Kubuntu 8.04 Hardy Heron, onde eu falo para usar o comando sudo su, mude para sudo sux, obviamente depois de ter instalado o pacote sux como falei mais acima.

agora faça:

sudo nano /root/.bashrc

ou

sudo vi /root/.bashrc

use o que você souber usar (nano ou vi)

e coloque isto no final:

export XAUTHORITY=/home/name/.Xauthority

Onde name, obviamente é o seu nome de usuário na pasta home, aquele nome de login que você digita ao entrar no Ubuntu ok.

salve e saia do arquivo, feche o terminal, abra-o novamente e veja se agora o kwrite  abre via terminal como root. Se ainda não abrir, talvez seja necessário reiniciar o computador.

Citar
Como usar o Vi:

Pressione a tecla Esc e depois a letra i do teclado para inserir textos no arquivo em questão. Para salvar as alterações e sair do Vi pressione Esc novamente e agora Shift+zz ( a letra z do teclado por duas vezes com o Shift pressionado, ou seja, ZZ)

Quem quiser usá-lo com o Ubuntu 8.04 Hardy Heron fique a vontade, mas lembre-se que para o Ubuntu 8.04 Hardy Heron siga os procedimentos normais que estão no guia de instalação.pdf e/ou Leia-me, ou seja tudo que falei mais acima foi para o Kubuntu 8.04 Hardy Heron. ;D

Atenção: Este novo pacote contém o mais novo driver smartlink (slmodem-2.9.11-20080401 datado de Abril de 2008)) e o mais novo driver ungrab-winmodem ( ungrab-winmodem-20080126 datado de Janeiro 2008). Agora os modems com ID 1543:3052 ( parece ser um tipo de modem motorola) passam a ter suporte com o driver Smartlink além do modem motorola de ID 1057:3052 que continua tendo suporte neste driver Smartlink.

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #627 Online: 20 de Abril de 2008, 10:42 »
Alarcon, acho que meu problema é mesmo o modem... acho que pooderia tentar resolver o problema com esse seu novo v23, mas se no  windows acusa que o modem está instalado mas não está funcional, então acho que é mais grave...

Nesse caso, qual  modem para net discada vc m e recomendaria ?

Motorola n ão né ?
Acho que esse me saiu na faixa de uns 30 reais. Vc tem alguma idéia de modem que funcione fácil (instalação fácil)  no ubun tu, com essa faixa de preço ?

Obrigado.

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #628 Online: 20 de Abril de 2008, 10:48 »
Alarcon, acho que meu problema é mesmo o modem... acho que pooderia tentar resolver o problema com esse seu novo v23, mas se no  windows acusa que o modem está instalado mas não está funcional, então acho que é mais grave...

Nesse caso, qual  modem para net discada vc m e recomendaria ?

Motorola n ão né ?
Acho que esse me saiu na faixa de uns 30 reais. Vc tem alguma idéia de modem que funcione fácil (instalação fácil)  no ubun tu, com essa faixa de preço ?

Obrigado.

já experimentou retirar a placa de modem e fazer uma limpeza nela?

Bom os modems LG Neto Dragon são bons para o Linux e o driver Smartlink o problema com nomes é que às vezes você compra um dizendo ser de um certo tipo, tem uma etiqueta falando que ele é aquele tipo, mas na hora de você checar a ID dele, perceberá que na verdade se trata de outro modem que pode ou não ter driver no Linux.

Não tente o v23 por que ele foi feito exclusivamente para o Ubuntu 8.04 Hardy Heron
« Última modificação: 20 de Abril de 2008, 10:50 por alarcon »

Offline Shakmatton

  • Usuário Ubuntu
  • *
  • Mensagens: 213
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #629 Online: 21 de Abril de 2008, 01:19 »
no windows o m odem é  detectado, mas aparece lá  nas configurações dele como n ão-funcional (ou algo do tipo)...
o comportamento dele - ainda no windows - era de travar na janelinha de "discando número tal",  e agora ele simplesmente retorna um código de erro dizendo algo sobre o modem não ter sido encon trado... Isso tudo no windows, no linux então nem comento...

Então, seria de se resolver o problema bastando para isso apenas uma limpeza ?
Vou tentar isso também, de qualquer forma. Quan    toao modem, vou dando umas pesquisadas (no cpu que estou usando agora acho que é neto dragon).

Talvez no próximo ub untu, ele já vreconheça direto o tipo do modem... quem sabe ?

Ob rigado..