Fórum Ubuntu Linux - PT
19 de Dezembro de 2014, 20:39 *
Olá, Visitante. Faça o login ou registre-se.
Perdeu o seu e-mail de ativação?

Login com nome de usuário, senha e duração da sessão
Notícias: Atualização no plugin de busca para Firefox e Internet Explorer.
 
   Home   Ajuda Regras Pesquisa Login Registre-se  
Anúncios
Páginas: [1] 2   Ir para o fundo
  Imprimir  
Autor Tópico: Pequena dica para optimizar um pouco o sistema - Alterar /etc/hosts  (Lida 10291 vezes)
iGama
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 185


Ver Perfil WWW
« em: 21 de Março de 2007, 19:31 »

Fazendo está pequena alteração, sentirá um aumento da velocidade do X na abertura das aplicações.

Nota : para exemplo o hostname da máquina será ubulaptop.

Para saber o hostname da máquina, executar na consola o comando hostname:

Citar
$ hostname
hostname_da_máquina

Aceder ao ficheiro /etc/hosts

Citar
sudo gedit /etc/hosts

e o ficheiro irá ter o seguinte:

Citar
(...)

127.0.0.1       localhost
127.0.1.1       ubulaptop

(...)

e alterar para :

Citar
(...)

127.0.0.1       localhost ubulaptop
127.0.1.1       ubulaptop

(...)


Para testar, abram algumas aplicações como consola e Firefox antes e depois de alterar o ficheiro.

O que acham?
Registrado

MestreDosMares
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 27



Ver Perfil
« Responder #1 em: 22 de Março de 2007, 02:21 »

da pra explicar melhor o por que os programas ficam mais rápidos?

eu gosto de saber no que eu estou mexendo

Lingua
Registrado
iGama
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 185


Ver Perfil WWW
« Responder #2 em: 22 de Março de 2007, 07:33 »

Eu também não percebi muito bem, só me explicaram que é do X que localiza mais rapidamente o hostname ou uma coisa assim.

ainda nao investiguei mais o assunto.
Registrado

Diepartus
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 56



Ver Perfil WWW
« Responder #3 em: 22 de Março de 2007, 10:10 »

http://planeta.ubuntubrasil.org//post/1645
Isso deve explicar um pouco sobre o assunto.
[]'s
Registrado

Sorridente
samuelbh
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 583



Ver Perfil
« Responder #4 em: 23 de Março de 2007, 10:10 »

Vou testar em casa pra ver se melhora mesmo. Obrigado pela dica.
Registrado

Assinatura removida pela Equipe do Fórum
Darcamo
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 1.309


Ver Perfil
« Responder #5 em: 23 de Março de 2007, 12:00 »

Se algo tão simples acelera (mesmo que pouco) o X, então devia vir configurado "de fábrica". Afinal não vejo nenhum problema que isso possa a causar. Só benefício.
Registrado
pinduvoz
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 2.499



Ver Perfil
« Responder #6 em: 24 de Março de 2007, 00:54 »

Citar
http://planeta.ubuntubrasil.org//post/1645
Isso deve explicar um pouco sobre o assunto.
[]'s

Quem leu o contido no link ficou sabendo que a dica resolve um bug do Gnome, ou seja, não é um bug do Ubuntu.
Registrado

:: Linux Registered User nº 439378 ::
iGama
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 185


Ver Perfil WWW
« Responder #7 em: 26 de Março de 2007, 09:23 »

Exacto é da Gnome, as aplicações já deveriam aceder a 127.0.1.1 mas ainda vão ao 127.0.0.1, o por isso de se adicionar o hostname ao referente.
Registrado

Imigrante
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 146


Ver Perfil
« Responder #8 em: 30 de Março de 2007, 09:33 »

iGama,
Valeu pela dica!
Obtive uma melhora significante na abertura dos programas.
Abraços...
Registrado

Imigrante
racional
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 22


Ver Perfil
« Responder #9 em: 14 de Junho de 2007, 09:07 »

Moçada, fiz como todos as configurações abaixo:

sudo gedit /etc/hosts

(...)
127.0.0.1       localhost afrika
127.0.1.1       afrika
(...)

onde afrika eh o nome da minha maquina obtido atravéz do comando "hostname".

Porem os aplicativos demoram d+ para iniciar da mesma forma, na verdade nada alterou.

Minha maquina :
Atlhol 1.3ghz
640mb RAM
HD80gb (sistema e home)
HD40gb (livre)

Se alguem puder me ajudar ok?
Registrado
kenshin6x
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 55



Ver Perfil
« Responder #10 em: 14 de Junho de 2007, 11:06 »

realmente, mto boa a dica, tambem senti um ganho de velocidade
Registrado
racional
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 22


Ver Perfil
« Responder #11 em: 15 de Junho de 2007, 20:21 »

Moçada, fiz como todos as configurações abaixo:

sudo gedit /etc/hosts

(...)
127.0.0.1       localhost afrika
127.0.1.1       afrika
(...)

onde afrika eh o nome da minha maquina obtido atravéz do comando "hostname".

Porem os aplicativos demoram d+ para iniciar da mesma forma, na verdade nada alterou.

Minha maquina :
Atlhol 1.3ghz
640mb RAM
HD80gb (sistema e home)
HD40gb (livre)

Se alguem puder me ajudar ok?

Salve pessoal, tentei abrir o terminal e ele demorou 7 segundos para abrir. Alem das configurações ditas nesse topico alguem teria alguma sugestão do que fazer?
Obrigado.

Registrado
gabriel.goc
Visitante
« Responder #12 em: 20 de Junho de 2007, 22:31 »

Humnn..
Obtive uma melhora significativa na abertura dos programas...
xD
Espero que nas próximas versões os desenvolvedores consertem esse bug do gnome...
Obrigado pela dica

A só uma coisa, no seu post, está assim:
Citar
127.0.0.1       localhost ubulaptop
127.0.1.1       ubulaptop

Mas as pessoas podem se confudir, sugiro alterar para:

127.0.0.1       localhost "nome do computador"
127.0.1.1       "nome do computador"

flwss....
Registrado
cyberlion
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 213



Ver Perfil WWW
« Responder #13 em: 20 de Junho de 2007, 22:50 »

 Sem Graça Muito bom!!! Sem Graça

Aumentou significativamente!
Registrado

Ubuntu 8.10 - LG R405-A MID (160HD - 3GB RAM - ati x1250)
Blog com tirinhas livres: http://noisnatira.com
monthiel
Usuário Ubuntu
*
Deslogado Deslogado

Mensagens: 46



Ver Perfil WWW
« Responder #14 em: 21 de Junho de 2007, 10:36 »

Pessoas,

Ganhei 35segundos de boot após todas algmas alterações no Ubuntu. Incluindo, claro, essa dica que foi dada nesse Post, que por sinal, acelera principalmente, a abertura do Nautilus. Realmente a dica é muito boa. Também fiz outras alterações, que me renderam esses 35s de boot, afinal, minha máquina estava levando 2m05 segundos para bootar... Coloquei tudo aqui:
http://meulinux.blogspot.com/2007/06/performance-do-ubuntu.html

Abraços a todos....
Registrado

E não esqueça, visite meu blog:
http://monthiel.blogspot.com
Páginas: [1] 2   Ir para o topo
  Imprimir  
 
Ir para:  

Powered by MySQL Powered by PHP Tema desenvolvido por FaBMak e n3t0
Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines
© 2014 Canonical Ltd. Ubuntu e Canonical são marcas registradas da Canonical Ltd.
XHTML 1.0 válido! CSS válido!